summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
-rw-r--r--fftw3.patch11
-rw-r--r--liggghts.patch36
-rw-r--r--usrlocal.patch10
5 files changed, 55 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f95971354301..44193250310b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Jul 15 17:34:52 UTC 2017
pkgbase = liggghts
pkgdesc = Open Source Discrete Element Method Particle Simulation Software
- pkgver = 3.7.0
+ pkgver = 3.8.0
pkgrel = 1
url = https://github.com/CFDEMproject/LIGGGHTS-PUBLIC
arch = any
@@ -12,10 +10,8 @@ pkgbase = liggghts
depends = openmpi
depends = voro++
depends = fftw
- source = fftw3.patch
- source = usrlocal.patch
- md5sums = 20fb3f88185884af9f0e16477671ca8e
- md5sums = ea4006138a0750ab6223678bb767ef0c
+ source = liggghts.patch
+ md5sums = fcecfe6b91ce6d74a84b7ecd09be8f38
pkgname = liggghts
diff --git a/PKGBUILD b/PKGBUILD
index d44f77b37863..d510c5f259a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: xpt <user.xpt@gmail.com>
pkgname=liggghts
-pkgver=3.7.0
+pkgver=3.8.0
pkgrel=1
pkgdesc="Open Source Discrete Element Method Particle Simulation Software"
arch=('any')
@@ -9,12 +9,12 @@ url="https://github.com/CFDEMproject/LIGGGHTS-PUBLIC"
license=('GPL')
depends=('paraview' 'openmpi' 'voro++' 'fftw')
makedepends=('git')
-source=('fftw3.patch' 'usrlocal.patch')
-md5sums=('20fb3f88185884af9f0e16477671ca8e' 'ea4006138a0750ab6223678bb767ef0c')
+source=('liggghts.patch')
+md5sums=('fcecfe6b91ce6d74a84b7ecd09be8f38')
_gitroot="https://github.com/CFDEMproject/LIGGGHTS-PUBLIC.git"
_gitname="liggghts-public"
-
+_make="mpi"
build() {
cd "$srcdir"
@@ -34,27 +34,26 @@ build() {
cp -r "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build/"
- patch -Np0 < ../fftw3.patch
- patch -Np0 < ../usrlocal.patch # diff -Naur Makefile.lammps.old Makefile.lammps > usrlocal.patch
-
+ patch -Np0 < ../liggghts.patch # diff -Naur Makefile.mpi.old Makefile.mpi > liggghts.patch
cd src
make clean-all
- make openmpi || return 1
+ make $_make || return 1
}
package() {
- mkdir -p $pkgdir/usr/share/$pkgname
- mkdir -p $pkgdir/usr/share/doc/$pkgname
- mkdir -p $pkgdir/usr/share/$pkgname/examples
- mkdir -p $pkgdir/usr/share/doc/$pkgname/PDF/
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/$pkgname/examples"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname/PDF/"
+ mkdir -p "$pkgdir/usr/bin/"
- cd $srcdir/$_gitname-build
- install -Dm 755 src/lmp_openmpi $pkgdir/usr/bin/$pkgname
+ cd "$srcdir/$_gitname-build"
+ install -Dm 755 src/lmp_$_make "$pkgdir/usr/bin/$pkgname"
- cp -r --no-preserve='ownership' examples/LIGGGHTS/Tutorials_public/* $pkgdir/usr/share/$pkgname/examples
+ cp -r --no-preserve='ownership' examples/LIGGGHTS/Tutorials_public/* "$pkgdir/usr/share/$pkgname/examples"
# install -Dm644 examples/LIGGGHTS/Tutorials_public/ $pkgdir/usr/share/$pkgname/examples
- cp -r --no-preserve='ownership' doc/*.{html,pdf} $pkgdir/usr/share/doc/$pkgname/
- cp -r --no-preserve='ownership' doc/PDF/*.pdf $pkgdir/usr/share/doc/$pkgname/PDF/
+ cp -r --no-preserve='ownership' doc/*.{html,pdf} "$pkgdir/usr/share/doc/$pkgname/"
+ cp -r --no-preserve='ownership' doc/PDF/*.pdf "$pkgdir/usr/share/doc/$pkgname/PDF/"
# install -Dm644 doc/* $pkgdir/usr/share/doc/$pkgname
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
diff --git a/fftw3.patch b/fftw3.patch
deleted file mode 100644
index 345a4c6a86e3..000000000000
--- a/fftw3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/MAKE/Makefile.openmpi.old 2015-05-19 00:03:36.000000000 -0300
-+++ src/MAKE/Makefile.openmpi 2015-05-19 07:50:05.492251486 -0300
-@@ -51,7 +51,7 @@
-
- FFT_INC = -DFFT_FFTW3
- FFT_PATH =
--FFT_LIB = -lfftw
-+FFT_LIB = -lfftw3
-
- # JPEG and/or PNG library, OPTIONAL
- # see discussion in doc/Section_start.html#2_2 (step 7)
diff --git a/liggghts.patch b/liggghts.patch
new file mode 100644
index 000000000000..d6b405de892a
--- /dev/null
+++ b/liggghts.patch
@@ -0,0 +1,36 @@
+--- src/MAKE/Makefile.mpi.old 2018-03-06 01:33:18.183912526 -0300
++++ src/MAKE/Makefile.mpi 2018-03-06 01:33:33.306885953 -0300
+@@ -34,7 +34,7 @@
+ # LAMMPS ifdef settings, OPTIONAL
+ # see possible settings in doc/Section_start.html#2_2 (step 4)
+
+-LMP_INC = -DLAMMPS_GZIP -DLAMMPS_VTK
++LMP_INC = -DLAMMPS_GZIP
+
+ # MPI library, REQUIRED
+ # see discussion in doc/Section_start.html#2_2 (step 5)
+@@ -54,9 +54,9 @@
+ # PATH = path for FFT library
+ # LIB = name of FFT library
+
+-FFT_INC =
++FFT_INC = -DFFT_FFTW3
+ FFT_PATH =
+-FFT_LIB =
++FFT_LIB = -lfftw3
+
+ # JPEG and/or PNG library, OPTIONAL
+ # see discussion in doc/Section_start.html#2_2 (step 7)
+@@ -74,9 +74,9 @@
+ # PATH = path for VTK library
+ # LIB = name of VTK library
+
+-VTK_INC = -I/usr/include/vtk-6.2
+-VTK_PATH = #-L/usr/lib/x86_64-linux-gnu
+-VTK_LIB = -lvtkCommonCore-6.2 -lvtkIOCore-6.2 -lvtkIOXML-6.2 -lvtkIOLegacy-6.2 -lvtkCommonDataModel-6.2 -lvtkIOParallel-6.2 -lvtkParallelCore-6.2 -lvtkParallelMPI-6.2 -lvtkIOImage-6.2 -lvtkCommonExecutionModel-6.2 -lvtkFiltersCore-6.2 -lvtkIOParallelXML-6.2
++VTK_INC =
++VTK_PATH =
++VTK_LIB =
+
+ # ---------------------------------------------------------------------
+ # build rules and dependencies
diff --git a/usrlocal.patch b/usrlocal.patch
deleted file mode 100644
index 8cf9123a6444..000000000000
--- a/usrlocal.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/VORONOI/Makefile.lammps.old 2015-05-19 01:16:44.000000000 -0300
-+++ src/VORONOI/Makefile.lammps 2015-05-19 08:09:13.829257967 -0300
-@@ -15,6 +15,6 @@
-
- # Settings that the LAMMPS build will import when this package is installed
-
--voronoi_SYSINC = -I/usr/local/include/voro++
-+voronoi_SYSINC = -I/usr/include/voro++
- voronoi_SYSLIB = -lvoro++
- voronoi_SYSPATH = -L/usr/local/lib