summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0002-guest-account-Enable-autologin-guest-account-command.patch22
-rw-r--r--PKGBUILD9
3 files changed, 33 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad05384a9f94..e47c604ba9b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lightdm-guest
pkgdesc = A lightweight display manager. With guest-session enabled
pkgver = 1.30.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://www.freedesktop.org/wiki/Software/LightDM/
install = add-autologin-group.install
@@ -34,6 +34,7 @@ pkgbase = lightdm-guest
source = lightdm-default-config.patch
source = Xsession
source = 0001-guest-account-Add-default-GSettings-support.patch
+ source = 0002-guest-account-Enable-autologin-guest-account-command.patch
source = add-autologin-group.script
source = add-autologin-group.service
sha256sums = 05fe38d10dc8966f19806f001561edc057e757656ed37e08ca3127ab32a02692
@@ -46,6 +47,7 @@ pkgbase = lightdm-guest
sha256sums = 70b1d952d1ea8ade6b5561e6de781cfbfe3a86a116c10ea9774cfae73281c7a6
sha256sums = d30321a1b490500483b8ed7825fcff2c24a7c760ac627789ff517693888ec3c5
sha256sums = e4c2c618f5484ba165776b747befadd101e40cfdbe4bc01cbb6d3e22beb6ab65
+ sha256sums = 145fc56dd6d04273cda7058e3d14cfb0cd849ceb7d0089af73be5e69c50fefc6
sha256sums = 8b665387245531d4d25ffee9636a3735667876937238c376d7eece97f7a82c14
sha256sums = 2199300cc27b6b407e46206abd181b2be2679d2520ddd183e4a37a3fc691739a
diff --git a/0002-guest-account-Enable-autologin-guest-account-command.patch b/0002-guest-account-Enable-autologin-guest-account-command.patch
new file mode 100644
index 000000000000..1c53a24b78f1
--- /dev/null
+++ b/0002-guest-account-Enable-autologin-guest-account-command.patch
@@ -0,0 +1,22 @@
+From: Sam Burgos < santiago dot burgos1089 at gmail dot >
+Date: Wed, 22 May 2019 18:30:00 -0600
+Subject: guest-account: Add autologin support
+
+---
+ debian/guest-account.sh | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/debian/guest-account.sh b/debian/guest-account.sh
+index 0fc3daa..38e849c 100644
+--- a/debian/guest-account.sh
++++ b/debian/guest-account.sh
+@@ -71,7 +71,7 @@
+ fi
+ else
+ # does not exist, so create it
+- useradd --system --home-dir ${GUEST_HOME} --comment $(gettext "Guest") --user-group --shell /bin/bash ${GUEST_USER} || {
++ useradd --system --home-dir ${GUEST_HOME} --comment $(gettext "Guest") --user-group -G autologin --shell /bin/bash ${GUEST_USER} || {
+ rm -rf ${GUEST_HOME}
+ exit 1
+ }
+
diff --git a/PKGBUILD b/PKGBUILD
index 885361a6564b..b5ea3c4b2c4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(
liblightdm-qt5-guest
)
pkgver=1.30.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='A lightweight display manager. With guest-session enabled'
_add_group=add-autologin-group
@@ -46,6 +46,7 @@ source=(
lightdm-default-config.patch
Xsession
0001-guest-account-Add-default-GSettings-support.patch
+ 0002-guest-account-Enable-autologin-guest-account-command.patch
$_add_group.script
$_add_group.service
)
@@ -59,6 +60,7 @@ sha256sums=('05fe38d10dc8966f19806f001561edc057e757656ed37e08ca3127ab32a02692'
'70b1d952d1ea8ade6b5561e6de781cfbfe3a86a116c10ea9774cfae73281c7a6'
'd30321a1b490500483b8ed7825fcff2c24a7c760ac627789ff517693888ec3c5'
'e4c2c618f5484ba165776b747befadd101e40cfdbe4bc01cbb6d3e22beb6ab65'
+ '145fc56dd6d04273cda7058e3d14cfb0cd849ceb7d0089af73be5e69c50fefc6'
'8b665387245531d4d25ffee9636a3735667876937238c376d7eece97f7a82c14'
'2199300cc27b6b407e46206abd181b2be2679d2520ddd183e4a37a3fc691739a')
@@ -78,6 +80,11 @@ prepare() {
# put the files in /etc/guest-session/gsettings/. The file format is the same
# as the regular GSettings override files.
patch -p1 -i ../0001-guest-account-Add-default-GSettings-support.patch
+
+ # Add support for autologin in the guest session. In Archlinux and derivatives
+ # this is a requirement to enable a fully functional session. It requires adding
+ # the autologin tweak.
+ patch -p1 -i ../0002-guest-account-Enable-autologin-guest-account-command.patch
}
build() {