summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD47
2 files changed, 18 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17fc2f4e4ded..45222dfd8679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
pkgbase = lightdm-settings
pkgdesc = A configuration tool for the LightDM display manager
- pkgver = 1.5.3
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/linuxmint/lightdm-settings
arch = any
license = GPL3
- makedepends = lightdm-slick-greeter
- makedepends = desktop-file-utils
- makedepends = gettext
depends = hicolor-icon-theme
depends = lightdm-slick-greeter
depends = polkit
@@ -15,7 +12,7 @@ pkgbase = lightdm-settings
depends = python-setproctitle
depends = python-xapp
optdepends = lightdm-guest: Enable guest session options
- source = lightdm-settings-1.5.3.tar.gz::https://github.com/linuxmint/lightdm-settings/archive/1.5.3.tar.gz
- sha256sums = 4ea8e31cfcf8078961ee292e82388d470f49cc3d8bde3618d594780ed8af0144
+ source = lightdm-settings-2.0.1.tar.gz::https://github.com/linuxmint/lightdm-settings/archive/2.0.1.tar.gz
+ sha256sums = a44b62c18e64b7b9bbcc98e623c13b0ac94898974645e47d7afd272e98e0ae17
pkgname = lightdm-settings
diff --git a/PKGBUILD b/PKGBUILD
index 1e8f7c0c2f9f..d76a1955fb28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,32 @@
# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
pkgname=lightdm-settings
-pkgver=1.5.3
+pkgver=2.0.1
pkgrel=1
-pkgdesc='A configuration tool for the LightDM display manager'
+pkgdesc="A configuration tool for the LightDM display manager "
arch=('any')
url="https://github.com/linuxmint/${pkgname}"
-#url="http://packages.linuxmint.com/pool/main/l/${pkgname}"
-license=(GPL3)
+license=('GPL3')
depends=(
- hicolor-icon-theme
- lightdm-slick-greeter
- polkit
- python-gobject
- python-setproctitle
- python-xapp
+ 'hicolor-icon-theme'
+ 'lightdm-slick-greeter'
+ 'polkit'
+ 'python-gobject'
+ 'python-setproctitle'
+ 'python-xapp'
)
-makedepends=(
- lightdm-slick-greeter
- desktop-file-utils
- gettext
+optdepends=(
+ 'lightdm-guest: Enable guest session options'
)
-optdepends=('lightdm-guest: Enable guest session options')
source=("${pkgname}-${pkgver}.tar.gz::$url/archive/${pkgver}.tar.gz")
-#source=("${pkgname}-${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
-sha256sums=('4ea8e31cfcf8078961ee292e82388d470f49cc3d8bde3618d594780ed8af0144')
+sha256sums=('a44b62c18e64b7b9bbcc98e623c13b0ac94898974645e47d7afd272e98e0ae17')
-## Packaging via Github
build() {
- cd $pkgname-$pkgver
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd $pkgname-$pkgver
- cp -r usr $pkgdir
+ cd "$pkgname-$pkgver"
+ cp -r usr "$pkgdir"
}
-
-## Packaging via Linuxmint repository
-#build() {
-# cd ${pkgname}
-# make
-#}
-
-#package() {
-# cd ${pkgname}
-# cp -r usr "$pkgdir"
-#}