summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD29
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eda6199d4e9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jan 16 18:01:42 UTC 2016
+pkgbase = lightdm-webkit-theme-google-git
+ pkgdesc = Google/ChromeOS style LightDM Webkit greeter theme
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/omgmog/lightdm-webkit-google
+ arch = any
+ license = custom:WTFPL
+ depends = lightdm
+ depends = lightdm-webkit-greeter
+ source = lightdm-webkit-theme-google-git::git+https://github.com/omgmog/lightdm-webkit-google.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = e6f431dd1ad48a375db96aeb94d1916e
+
+pkgname = lightdm-webkit-theme-google-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..77ce2fee80a8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+lightdm-webkit-theme-google-git/
+lightdm-webkit-theme-google-git-*.pkg.*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..74aef2884695
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+ Version 2, December 2004
+
+Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>
+
+Everyone is permitted to copy and distribute verbatim or modified
+copies of this license document, and changing it is allowed as long
+as the name is changed.
+
+ DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+0. You just DO WHAT THE FUCK YOU WANT TO.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb93c290589b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David Rodriguez <dissonant.tech@gmail.com>
+
+_themename=google
+pkgname=lightdm-webkit-theme-${_themename}-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Google/ChromeOS style LightDM Webkit greeter theme"
+arch=('any')
+url="https://github.com/omgmog/lightdm-webkit-google"
+license=('custom:WTFPL')
+depends=('lightdm' 'lightdm-webkit-greeter')
+source=("${pkgname}::git+https://github.com/omgmog/lightdm-webkit-google.git"
+ 'LICENSE')
+md5sums=('SKIP'
+ 'e6f431dd1ad48a375db96aeb94d1916e')
+
+build () {
+ cd ${srcdir}/${pkgname}
+}
+
+package () {
+ cd ${srcdir}/${pkgname}
+
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -d "${pkgdir}/usr/share/lightdm-webkit/themes"
+ cp -dpr --no-preserve=ownership "${srcdir}/${pkgname}" "${pkgdir}/usr/share/lightdm-webkit/themes/${_themename}"
+ rm -rf "${pkgdir}/usr/share/lightdm-webkit/themes/${_themename}/.git"
+}