summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd1b8a61dbe8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lightnovel-crawler-bin
+ pkgdesc = An app to download novels from online sources and generate e-books.
+ pkgver = 2.24.5
+ pkgrel = 1
+ url = https://github.com/dipu-bd/lightnovel-crawler.git
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python
+ optdepends = calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr
+ provides = lncrawl
+ conflicts = lncrawl
+ source = https://github.com/dipu-bd/lightnovel-crawler/releases/latest/download/lncrawl
+ md5sums = SKIP
+ sha1sums = SKIP
+ sha256sums = SKIP
+
+pkgname = lightnovel-crawler-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61a910f2b1df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Robert Manning <duckz@protonmail.ch>
+
+pkgname=lightnovel-crawler-bin
+pkgver=2.24.5
+pkgrel=1
+pkgdesc="An app to download novels from online sources and generate e-books."
+arch=('any')
+url="https://github.com/dipu-bd/lightnovel-crawler.git"
+license=('Apache')
+depends=(python)
+makedepends=(git)
+optdepends=('calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr')
+provides=(lncrawl)
+conflicts=(lncrawl)
+
+source=("https://github.com/dipu-bd/lightnovel-crawler/releases/latest/download/lncrawl")
+
+md5sums=('SKIP')
+sha1sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ curl --silent "https://api.github.com/repos/dipu-bd/lightnovel-crawler/releases/latest" |\
+ grep '"tag_name":' |\
+ sed -E 's/.*"v([^"]+)".*/\1/'
+}
+package() {
+ install -Dm755 lncrawl ${pkgdir}/usr/bin/lncrawl
+}