summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD53
-rw-r--r--lighttable15
-rw-r--r--lighttable.desktop9
-rw-r--r--lighttable.install7
-rw-r--r--lighttable.pngbin0 -> 5869 bytes
7 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55b9fa7a6910
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = lighttable
+ pkgdesc = New interactive IDE that lets you modify running programs and embed anything from websites to games.
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = http://www.lighttable.com/
+ install = lighttable.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = nss
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = gconf
+ depends = libudev.so.0
+ depends = gtk2
+ options = !strip
+ options = !emptydirs
+ source = lighttable
+ source = lighttable-0.7.2-.tar.gz::http://d35ac8ww5dfjyg.cloudfront.net/playground/bins/0.7.2/LightTableLinux64.tar.gz
+ source = lighttable.desktop
+ source = lighttable.png
+ source = LICENSE
+ md5sums = e772b3547fdc3a6e32f81e7303422fd1
+ md5sums = e49c9c57d1dec787a58094cc7e6d3f63
+ md5sums = 04a62702b59810a36bca7623bf9e932c
+ md5sums = f8c055be2f047ff4aaffdd028f62f027
+ md5sums = 8870b5e12f58e6a19a53f4fa938755e8
+
+pkgname = lighttable
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8403ffd45c03
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+=====================
+
+Copyright (c) 2014 Kodowa, Inc. & Light Table contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd067f1ceba1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: trashstar <trash@ps3zone.org>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Tony Sokhon <tonyskn@gmail.com>
+# Contributor: Ebubekir KARUL <ebubekirkarul@yandex.com>
+# Contributor: Gaurish Sharma <contact@gaurishsharma.com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Katrina L. Halliwell <rambaldi.kat.47@gmail.com>
+# Contributor: Eugenio Ferreira <eugfcl@gmail.com>
+
+pkgname=lighttable
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="New interactive IDE that lets you modify running programs and embed anything from websites to games."
+url="http://www.lighttable.com/"
+license=('MIT')
+depends=("nss" "alsa-lib" "desktop-file-utils" "gconf" "libudev.so.0" "gtk2")
+options=(!strip !emptydirs)
+arch=('i686' 'x86_64')
+install=$pkgname.install
+
+source=(lighttable
+ $pkgname-$pkgver-$CARCH.tar.gz::http://d35ac8ww5dfjyg.cloudfront.net/playground/bins/$pkgver/LightTableLinux64.tar.gz
+ lighttable.desktop
+ lighttable.png
+ LICENSE)
+md5sums=('e772b3547fdc3a6e32f81e7303422fd1'
+ 'e49c9c57d1dec787a58094cc7e6d3f63'
+ '04a62702b59810a36bca7623bf9e932c'
+ 'f8c055be2f047ff4aaffdd028f62f027'
+ '8870b5e12f58e6a19a53f4fa938755e8')
+PKGEXT=".pkg.tar"
+
+if [[ "$CARCH" == "i686" ]]; then
+ source[1]=$pkgname-$pkgver-$CARCH.tar.gz::http://d35ac8ww5dfjyg.cloudfront.net/playground/bins/$pkgver/LightTableLinux.tar.gz
+ md5sums[1]='999ca3e734ea1cf7b5f3dc190e914ad9'
+fi
+
+package() {
+ install -Dm 755 "$srcdir/lighttable" "$pkgdir/usr/bin/lighttable"
+
+ install -dm755 "$pkgdir/usr/share/licenses/lighttable"
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/lighttable/LICENSE"
+
+ _destdir="$pkgdir/opt/LightTable"
+
+ install -dm755 $_destdir
+ mv $srcdir/LightTable/* $_destdir
+
+ install -Dm 644 "$srcdir/lighttable.desktop" "$pkgdir/usr/share/applications/lighttable.desktop"
+ install -Dm 644 "$srcdir/lighttable.png" "$pkgdir/usr/share/pixmaps/lighttable.png"
+ install -Dm 644 "$pkgdir/opt/LightTable/core/node_modules/marked/man/marked.1" "$pkgdir/usr/share/man/man1/marked.1"
+ rm "$pkgdir/opt/LightTable/core/node_modules/marked/man/marked.1"
+}
diff --git a/lighttable b/lighttable
new file mode 100644
index 000000000000..911daf0c0a17
--- /dev/null
+++ b/lighttable
@@ -0,0 +1,15 @@
+#!/bin/sh
+BIN=ltbin
+LT_HOME=/opt/LightTable
+
+ARGS="$@"
+CORRECTED=${ARGS//-/<d>}
+CORRECTED=${CORRECTED// /<s>}
+
+if [ -t 0 ] && [ $# != 0 ]; then
+ #We're in a terminal...
+ LD_LIBRARY_PATH="$LT_HOME:$LD_LIBRARY_PATH" $LT_HOME/$BIN "<d><d>dir=`pwd`<s>$CORRECTED" &
+else
+ #We were double clicked
+ LD_LIBRARY_PATH="$LT_HOME:$LD_LIBRARY_PATH" $LT_HOME/$BIN &
+fi
diff --git a/lighttable.desktop b/lighttable.desktop
new file mode 100644
index 000000000000..f5d62a5c12ce
--- /dev/null
+++ b/lighttable.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Light Table
+Comment=Light Table IDE
+Type=Application
+Icon=lighttable
+Exec=lighttable
+Categories=Utility;TextEditor;Development
+Terminal=false
+MimeType=text/plain;
diff --git a/lighttable.install b/lighttable.install
new file mode 100644
index 000000000000..fcac9c43bc75
--- /dev/null
+++ b/lighttable.install
@@ -0,0 +1,7 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
diff --git a/lighttable.png b/lighttable.png
new file mode 100644
index 000000000000..47e6d131ffc5
--- /dev/null
+++ b/lighttable.png
Binary files differ