summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD46
-rw-r--r--lighttable15
-rw-r--r--lighttable-bin.install7
-rw-r--r--lighttable.desktop9
-rw-r--r--lighttable.pngbin0 -> 5869 bytes
7 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f832cb980285
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lighttable-bin
+ pkgdesc = New interactive IDE that lets you modify running programs and embed anything from websites to games.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = http://www.lighttable.com/
+ install = lighttable-bin.install
+ arch = x86_64
+ license = MIT
+ depends = nss
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = gconf
+ depends = libudev0-shim
+ depends = gtk2
+ options = !strip
+ options = !emptydirs
+ source = lighttable
+ source = lighttable-bin-0.8.1.tar.gz::https://github.com/LightTable/LightTable/releases/download/0.8.1/lighttable-0.8.1-linux.tar.gz
+ source = lighttable.desktop
+ source = lighttable.png
+ source = LICENSE
+ md5sums = cad9cb77799f087aef08f0436b853412
+ md5sums = 7e4efcce58f2f4a44edb5bde6f5a91db
+ md5sums = 04a62702b59810a36bca7623bf9e932c
+ md5sums = f8c055be2f047ff4aaffdd028f62f027
+ md5sums = 8870b5e12f58e6a19a53f4fa938755e8
+
+pkgname = lighttable-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8403ffd45c03
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+=====================
+
+Copyright (c) 2014 Kodowa, Inc. & Light Table contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6d3de1a6ac4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: trashstar <trash@ps3zone.org>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Tony Sokhon <tonyskn@gmail.com>
+# Contributor: Ebubekir KARUL <ebubekirkarul@yandex.com>
+# Contributor: Gaurish Sharma <contact@gaurishsharma.com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Katrina L. Halliwell <rambaldi.kat.47@gmail.com>
+# Contributor: Eugenio Ferreira <eugfcl@gmail.com>
+
+pkgname=lighttable-bin
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="New interactive IDE that lets you modify running programs and embed anything from websites to games."
+url="http://www.lighttable.com/"
+license=('MIT')
+depends=("nss" "alsa-lib" "desktop-file-utils" "gconf" "libudev0-shim" "gtk2")
+options=(!strip !emptydirs)
+arch=('x86_64')
+install=$pkgname.install
+
+source=(lighttable
+ $pkgname-${pkgver//_/-}.tar.gz::https://github.com/LightTable/LightTable/releases/download/${pkgver//_/-}/lighttable-${pkgver//_/-}-linux.tar.gz
+ lighttable.desktop
+ lighttable.png
+ LICENSE)
+md5sums=('cad9cb77799f087aef08f0436b853412'
+ '7e4efcce58f2f4a44edb5bde6f5a91db'
+ '04a62702b59810a36bca7623bf9e932c'
+ 'f8c055be2f047ff4aaffdd028f62f027'
+ '8870b5e12f58e6a19a53f4fa938755e8')
+PKGEXT=".pkg.tar"
+
+package() {
+ install -Dm 755 "$srcdir/lighttable" "$pkgdir/usr/bin/lighttable"
+
+ install -dm755 "$pkgdir/usr/share/licenses/lighttable"
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/lighttable/LICENSE"
+
+ _destdir="$pkgdir/opt/LightTable"
+
+ install -dm755 $_destdir
+ mv $srcdir/lighttable-${pkgver//_/-}-linux/* $_destdir
+
+ install -Dm 644 "$srcdir/lighttable.desktop" "$pkgdir/usr/share/applications/lighttable.desktop"
+ install -Dm 644 "$srcdir/lighttable.png" "$pkgdir/usr/share/pixmaps/lighttable.png"
+}
diff --git a/lighttable b/lighttable
new file mode 100644
index 000000000000..0cfa84cf9622
--- /dev/null
+++ b/lighttable
@@ -0,0 +1,15 @@
+#!/bin/sh
+BIN=light
+LT_HOME=/opt/LightTable
+
+ARGS="$@"
+CORRECTED=${ARGS//-/<d>}
+CORRECTED=${CORRECTED// /<s>}
+
+if [ -t 0 ] && [ $# != 0 ]; then
+ #We're in a terminal...
+ LD_LIBRARY_PATH="$LT_HOME:$LD_LIBRARY_PATH" $LT_HOME/$BIN "<d><d>dir=`pwd`<s>$CORRECTED" &
+else
+ #We were double clicked
+ LD_LIBRARY_PATH="$LT_HOME:$LD_LIBRARY_PATH" $LT_HOME/$BIN &
+fi
diff --git a/lighttable-bin.install b/lighttable-bin.install
new file mode 100644
index 000000000000..fcac9c43bc75
--- /dev/null
+++ b/lighttable-bin.install
@@ -0,0 +1,7 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
diff --git a/lighttable.desktop b/lighttable.desktop
new file mode 100644
index 000000000000..f5d62a5c12ce
--- /dev/null
+++ b/lighttable.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Light Table
+Comment=Light Table IDE
+Type=Application
+Icon=lighttable
+Exec=lighttable
+Categories=Utility;TextEditor;Development
+Terminal=false
+MimeType=text/plain;
diff --git a/lighttable.png b/lighttable.png
new file mode 100644
index 000000000000..47e6d131ffc5
--- /dev/null
+++ b/lighttable.png
Binary files differ