summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--liground.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27620edc34cf..47784ad8eda2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = liground-bin
pkgdesc = A free, open-source and modern Chess Variant Analysis GUI for the 21st century
pkgver = 0.4.0
- pkgrel = 7
+ pkgrel = 8
url = https://ml-research.github.io/liground.github.io/
arch = x86_64
license = AGPL-3.0-only
@@ -12,6 +12,6 @@ pkgbase = liground-bin
source = liground-0.4.0.AppImage::https://github.com/ml-research/liground/releases/download/0.4.0/liground-0.4.0-linux.AppImage
source = liground.sh
sha256sums = 7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = liground-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4a14340e28f2..5b5573b9b50c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=liground-bin
pkgver=0.4.0
_electronversion=11
-pkgrel=7
+pkgrel=8
pkgdesc="A free, open-source and modern Chess Variant Analysis GUI for the 21st century"
arch=('x86_64')
url="https://ml-research.github.io/liground.github.io/"
@@ -21,11 +21,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/liground.sh b/liground.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/liground.sh
+++ b/liground.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file