summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b86b5a6d525..30ead46036e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = lilypond-devel
pkgdesc = An automated music engraving system (development version)
pkgver = 2.19.81
- pkgrel = 3
+ pkgrel = 4
url = http://lilypond.org/
arch = i686
arch = x86_64
license = GPL
makedepends = fontforge
makedepends = gsfonts
- makedepends = t1utils-git
+ makedepends = t1utils
makedepends = ghostscript
makedepends = texlive-core
makedepends = tex-gyre-fonts
@@ -24,7 +24,6 @@ pkgbase = lilypond-devel
optdepends = tk: for the gui
provides = lilypond=2.19.81
conflicts = lilypond
- conflicts = lilypond-git
source = http://lilypond.org/downloads/sources/v2.19/lilypond-2.19.81.tar.gz
source = no_fontforge-versioncheck.patch
sha256sums = 2ac299045dc4a8fa3bd7c67af7b06877b21cdb50321fec5baa558e3173ed646c
diff --git a/PKGBUILD b/PKGBUILD
index 2ce28a0abb61..caef3bcc185b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lilypond-devel
pkgver=2.19.81
-pkgrel=3
+pkgrel=4
pkgdesc="An automated music engraving system (development version)"
arch=('i686' 'x86_64')
url="http://lilypond.org/"
@@ -16,7 +16,7 @@ depends=('fontconfig'
'python2')
makedepends=('fontforge'
'gsfonts'
- 't1utils-git'
+ 't1utils'
'ghostscript'
'texlive-core'
'tex-gyre-fonts'
@@ -25,13 +25,13 @@ makedepends=('fontforge'
optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
'tk: for the gui')
provides=("lilypond=$pkgver")
-conflicts=('lilypond' 'lilypond-git')
+conflicts=('lilypond')
source=("http://lilypond.org/downloads/sources/v2.19/lilypond-${pkgver}.tar.gz" "no_fontforge-versioncheck.patch")
sha256sums=('2ac299045dc4a8fa3bd7c67af7b06877b21cdb50321fec5baa558e3173ed646c'
'e74391f718babb984c5f637397162cf096c4716f5b9a21346ec76035cfc80817')
prepare() {
- cd "$srcdir/lilypond-$pkgver"
+ cd lilypond-$pkgver
# python2 fix
for file in $(find . -name '*.py' -print); do
@@ -44,7 +44,7 @@ prepare() {
}
build() {
- cd "$srcdir/lilypond-$pkgver"
+ cd lilypond-$pkgver
export PYTHON="python2"
export PYTHON_CONFIG="python2-config"
@@ -63,9 +63,9 @@ build() {
}
package() {
- cd "$srcdir/lilypond-$pkgver/build"
+ cd lilypond-$pkgver/build
make DESTDIR="$pkgdir/" \
vimdir="/usr/share/vim/vimfiles" install
- rm -rf "$pkgdir/usr/share/man"
+ rm -rf "$pkgdir"/usr/share/man
}