summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
-rw-r--r--fix_xml_eisdir.patch33
3 files changed, 67 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75a3d48a04d1..5229c01f1fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = lincity-ng-git
pkgdesc = A city simulation game (development version)
- pkgver = 2.9.beta.r102.gd35c3bee
+ pkgver = 2.9.0.r144.gd4066f9e
pkgrel = 1
+ epoch = 1
url = https://github.com/lincity-ng/lincity-ng
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = GPL2
makedepends = git
- makedepends = ftjam
+ makedepends = cmake
makedepends = mesa
makedepends = glu
depends = sdl2_mixer
@@ -17,9 +20,11 @@ pkgbase = lincity-ng-git
depends = physfs
depends = libxml2
depends = libgl
- provides = lincity-ng=2.9.beta
+ provides = lincity-ng=2.9.0
conflicts = lincity-ng
- source = git+https://github.com/lincity-ng/lincity-ng.git
- md5sums = SKIP
+ source = lincity-ng::git+https://github.com/lincity-ng/lincity-ng
+ source = fix_xml_eisdir.patch
+ sha256sums = SKIP
+ sha256sums = 6f034a0628ebcbeaafdd5e00fe911132eacd4e67ab1792752960e035ce117186
pkgname = lincity-ng-git
diff --git a/PKGBUILD b/PKGBUILD
index 64655eabd7c6..57dfab54e745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,41 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-pkgname=lincity-ng-git
-pkgver=2.9.beta.r102.gd35c3bee
+_pkgname=lincity-ng
+pkgname=${_pkgname}-git
+epoch=1
+pkgver=2.9.0.r144.gd4066f9e
pkgrel=1
pkgdesc="A city simulation game (development version)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/lincity-ng/lincity-ng"
license=('GPL2')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}=${pkgver%.r*}")
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver%.r*}")
depends=('sdl2_mixer' 'sdl2_image' 'sdl2_ttf' 'sdl2_gfx' 'physfs' 'libxml2' 'libgl')
-makedepends=('git' 'ftjam' 'mesa' 'glu')
-source=("git+https://github.com/lincity-ng/lincity-ng.git")
-md5sums=('SKIP')
+makedepends=('git' 'cmake' 'mesa' 'glu')
+source=("${_pkgname}::git+${url}"
+ "fix_xml_eisdir.patch") #https://github.com/lincity-ng/lincity-ng/pull/102
+sha256sums=('SKIP'
+ '6f034a0628ebcbeaafdd5e00fe911132eacd4e67ab1792752960e035ce117186')
pkgver() {
- cd lincity-ng
-
+ cd ${_pkgname}
git describe --long --tags | sed 's/^lincity-ng-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd lincity-ng
-
- # generate CREDITS file
- eval $(grep -m1 CREDITS makerelease.sh)
+prepare () {
+ cd ${_pkgname}
+ patch -uNp1 -r- -i ../fix_xml_eisdir.patch
}
-
+
build () {
- cd lincity-ng
-
- ./autogen.sh
- ./configure --prefix=/usr
- jam -j2 # assume dual core machine at least
+ cd ${_pkgname}
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
}
package () {
- cd lincity-ng
-
- jam -j2 -sprefix="$pkgdir/usr" install
-
- # fixup man
- install -Dm644 doc/lincity-ng.6 "$pkgdir"/usr/share/man/man6/lincity-ng.6
-
- # fixup doc dir
- mv "$pkgdir"/usr/share/doc/{lincity-ng*,lincity-ng}
-
- # licenses
- install -Dm644 COPYING-data.txt "$pkgdir"/usr/share/licenses/$pkgname/COPYING-data.txt
- install -Dm644 COPYING-fonts.txt "$pkgdir"/usr/share/licenses/$pkgname/COPYING-fonts.txt
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
}
diff --git a/fix_xml_eisdir.patch b/fix_xml_eisdir.patch
new file mode 100644
index 000000000000..f18a7258bbe8
--- /dev/null
+++ b/fix_xml_eisdir.patch
@@ -0,0 +1,33 @@
+From 5ec1a353148baababa8b727d181b735f8a40d854 Mon Sep 17 00:00:00 2001
+From: dbear496 <70439542+dbear496@users.noreply.github.com>
+Date: Fri, 19 Jan 2024 21:13:06 -0500
+Subject: [PATCH 1/3] install data+info files from binary dir
+
+---
+ data/CMakeLists.txt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index d5a707a1..7a1e0eb9 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -22,7 +22,8 @@ foreach(dataFile ${allDataFiles})
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "copying ${dataFile} to build directory"
+ )
+- install(FILES ${dataFile} DESTINATION ${CMAKE_INSTALL_APPDATADIR}/${dataFile})
++ cmake_path(GET dataFile PARENT_PATH dataFileDst)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${dataFile} DESTINATION ${CMAKE_INSTALL_APPDATADIR}/${dataFileDst})
+ endforeach()
+ add_custom_target(allDataFiles.target DEPENDS ${allDataFiles})
+ add_dependencies(lincity-ng allDataFiles.target)
+@@ -91,7 +92,8 @@ foreach(infoFile ${infoFiles})
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "copying ${infoFile} to build directory"
+ )
+- install(FILES ${infoFile} DESTINATION ${CMAKE_INSTALL_APPDATADIR}/${infoFile})
++ cmake_path(GET infoFile PARENT_PATH infoFileDst)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${infoFile} DESTINATION ${CMAKE_INSTALL_APPDATADIR}/${infoFileDst})
+ endforeach()
+ add_custom_target(infoFiles.target DEPENDS ${infoFiles})
+ add_dependencies(lincity-ng infoFiles.target)