summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..377b0e9183ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = linedict
+ pkgdesc = A simple dictionary using Youdao webpage source
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/WingT/linedict
+ arch = x86_64
+ license = MIT
+ depends = libxinerama
+ depends = libxft
+ depends = freetype2
+ depends = pcre
+ depends = curl
+ source = https://github.com/WingT/linedict
+ sha256sums = SKIP
+
+pkgname = linedict
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e741e5a89929
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Izzy
+
+pkgname=linedict
+pkgver=1.0
+pkgrel=1
+pkgdesc="A simple dictionary using Youdao webpage source"
+url="https://github.com/WingT/linedict"
+arch=('x86_64')
+license=('MIT')
+depends=('libxinerama' 'libxft' 'freetype2' 'pcre' 'curl')
+source=("$pkgname-$pkgver::git+https://github.com/WingT/linedict")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 FREETYPEINC=/usr/include/freetype2
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}