summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f904da5158e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lingot-git
+ pkgdesc = LINGOT is a musical instrument tuner
+ pkgver = 1
+ pkgrel = 1
+ url = http://nongnu.org/lingot/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ depends = gtk3
+ provides = lingot
+ conflicts = lingot
+ source = git+https://git.savannah.nongnu.org/git/lingot.git
+ md5sums = SKIP
+
+pkgname = lingot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2021b427890
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Genki Sky <alt+archlinux.org@genki.is>
+
+pkgname=lingot-git
+pkgver=1
+pkgrel=1
+pkgdesc='LINGOT is a musical instrument tuner'
+arch=('i686' 'x86_64')
+url='http://nongnu.org/lingot/'
+license=('GPL2')
+depends=('gtk3')
+makedepends=('git' 'intltool')
+provides=('lingot')
+conflicts=('lingot')
+source=('git+https://git.savannah.nongnu.org/git/lingot.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd lingot
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd lingot
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd lingot
+ make DESTDIR="$pkgdir" install
+}