summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dee3ec3956d..0c5226cd198e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
# Generated by mksrcinfo v8
-# Tue Oct 30 00:17:02 UTC 2018
+# Tue Oct 30 00:44:22 UTC 2018
pkgbase = linkchecker
pkgdesc = Check websites for broken links.
pkgver = 9.4.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/linkcheck/linkchecker
arch = x86_64
license = GPL2
depends = python2-requests
depends = python2-dnspython
depends = python2-xdg
- optdepends = python2-argcomplete: For command-line completion
+ optdepends = python2-argcomplete: For command-line completion,
+ optdepends = python2-geoip: For displaying country codes
source = linkchecker-9.4.0.tar.gz::https://github.com/linkchecker/linkchecker/archive/v9.4.0.tar.gz
sha256sums = 1ce495fc5f2366ac5b31cbda6fef2c5cf6582bb2d55fd9648931952611e47473
diff --git a/PKGBUILD b/PKGBUILD
index a8d6185d2cb3..7db703c84d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,21 @@
pkgname=linkchecker
pkgver=9.4.0
-pkgrel=5
+pkgrel=6
pkgdesc="Check websites for broken links."
arch=('x86_64')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
depends=('python2-requests' 'python2-dnspython' 'python2-xdg')
-optdepends=('python2-argcomplete: For command-line completion')
+optdepends=(
+ 'python2-argcomplete: For command-line completion',
+ 'python2-geoip: For displaying country codes'
+)
source=("$pkgname-$pkgver.tar.gz::https://github.com/linkchecker/linkchecker/archive/v$pkgver.tar.gz")
sha256sums=('1ce495fc5f2366ac5b31cbda6fef2c5cf6582bb2d55fd9648931952611e47473')
build() {
cd "$pkgname-$pkgver"
- python2 setup.py sdist --manifest-only
- (cd doc && make)
python2 setup.py build
}