summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 2 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfad64b3d0d4..cb498e425e70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = linux-amd-raven
makedepends = git
makedepends = libelf
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.4.55
source = config.x86_64
source = linux-amd-raven.preset
source = linux.install
diff --git a/PKGBUILD b/PKGBUILD
index 08c1ad82adbd..1f958f2f47fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
-#https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/?h=linux-4.19.y
-
-#source=('git+https://kernel.googlesource.com/pub/scm/linux/kernel/git/torvalds/linux'
-source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
+source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=$gitver"
# the main kernel config files
'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -25,7 +22,6 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
'5013_enable-cpu-optimizations-for-gcc10.patch'
# i2c write rework patch
'timerrework.patch'
-
)
sha256sums=('SKIP'
#config.x86_64
@@ -48,8 +44,6 @@ pkgver() {
prepare() {
cd "${_srcname}"
- #We want to base this on the release
- git checkout tags/$gitver
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else