summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--disable_proc_ac.patch34
3 files changed, 45 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab3387b93659..da6d370e4c47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-raven
pkgver = 5.4.v.38
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -16,10 +16,12 @@ pkgbase = linux-amd-raven
source = config.x86_64
source = linux-amd-raven.preset
source = 5012_enable-cpu-optimizations-for-gcc91.patch
+ source = disable_proc_ac.patch
sha256sums = SKIP
sha256sums = dc24302d434f8fcb829af129040f4bf41bd77ea83982ba926fc972f2505aef0f
sha256sums = 0ac0cf410b0f3eeaa07d41505613e118ea59e01144e905f2dc0a808379f87e87
sha256sums = fb98e49d7a640e05bf0d3a65ca49d0adb19de7547cb7ffca7a6cbacb1f461f0b
+ sha256sums = f412d719977af563ca74b41b218977e49672ac93ab7cc96a0833b66abbfb8b10
pkgname = linux-amd-raven
pkgdesc = Linux kernel with working amdgpu for Raven Ridge hardware
diff --git a/PKGBUILD b/PKGBUILD
index c527909ce44e..87e0ea083cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd-raven
_srcname=linux
gitver=v5.4.38
pkgver=5.4.v.38
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -21,6 +21,8 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
"${pkgbase}.preset"
# patch from our gentoo overlords
'5012_enable-cpu-optimizations-for-gcc91.patch'
+ # disable acountingspam patchfile
+ 'disable_proc_ac.patch'
)
sha256sums=('SKIP'
#config.x86_64
@@ -29,6 +31,8 @@ sha256sums=('SKIP'
'0ac0cf410b0f3eeaa07d41505613e118ea59e01144e905f2dc0a808379f87e87'
#patch file
'fb98e49d7a640e05bf0d3a65ca49d0adb19de7547cb7ffca7a6cbacb1f461f0b'
+ #disable acountingspam patchfile
+ 'f412d719977af563ca74b41b218977e49672ac93ab7cc96a0833b66abbfb8b10'
)
_kernelname=${pkgbase#linux}
@@ -54,6 +58,9 @@ prepare() {
# Implement cpu optimisation (MZEN2) patch from our gentoo lords
git apply ../5012_enable-cpu-optimizations-for-gcc91.patch
+ # Implement disable acountingspam patchfile
+ git apply ../disable_proc_ac.patch
+
# get kernel version
yes "" | make prepare
diff --git a/disable_proc_ac.patch b/disable_proc_ac.patch
new file mode 100644
index 000000000000..294096401bd0
--- /dev/null
+++ b/disable_proc_ac.patch
@@ -0,0 +1,34 @@
+From d8a438149b5f46d3266dc48b32bff15eae55a120 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Tue, 5 May 2020 09:36:01 +0200
+Subject: [PATCH 1/1] stopped proc acc spam
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ kernel/acct.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/kernel/acct.c b/kernel/acct.c
+index 81f9831a7859..dea694894774 100644
+--- a/kernel/acct.c
++++ b/kernel/acct.c
+@@ -114,14 +114,14 @@ static int check_free_space(struct bsd_acct_struct *acct)
+ do_div(suspend, 100);
+ if (sbuf.f_bavail <= suspend) {
+ acct->active = 0;
+- pr_info("Process accounting paused\n");
++ //pr_info("Process accounting paused\n");
+ }
+ } else {
+ u64 resume = sbuf.f_blocks * RESUME;
+ do_div(resume, 100);
+ if (sbuf.f_bavail >= resume) {
+ acct->active = 1;
+- pr_info("Process accounting resumed\n");
++ //pr_info("Process accounting resumed\n");
+ }
+ }
+
+--
+2.26.2
+