summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD40
-rw-r--r--config2
3 files changed, 41 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ed5b809292..05420e01f3c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-staging-drm-next-git
pkgdesc = Linux kernel with AMDGPU DC patches
- pkgver = 5.4.858316.4a6c7afe7d1a
+ pkgver = 5.4.858375.20b60d8f9f72
pkgrel = 1
url = https://cgit.freedesktop.org/~agd5f/linux/
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = linux-amd-staging-drm-next-git
source = 90-linux.hook
source = linux.preset
sha256sums = SKIP
- sha256sums = 659f13ca424866539664bffc189a3939d068848c38005bf8c57b7e82e11e64bb
+ sha256sums = 3390c9937264bf3bcb577a947b61ca8b4547913b5c0fb7bc6eb232cbb2f4fcd9
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = 834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
@@ -41,3 +41,6 @@ pkgname = linux-amd-staging-drm-next-git
pkgname = linux-amd-staging-drm-next-git-headers
pkgdesc = Header files and scripts for building modules for Linux-amd-staging-drm-next-git kernel
+pkgname = linux-amd-staging-drm-next-git-docs
+ pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-amd-staging-drm-next-git kernel
+
diff --git a/PKGBUILD b/PKGBUILD
index 21459857b8f1..d152938cd946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgdesc='Linux kernel with AMDGPU DC patches'
_srcname=${pkgbase}
_branch=amd-staging-drm-next
_kernelname=${pkgbase#linux}
-pkgver=5.4.858316.4a6c7afe7d1a
+pkgver=5.4.858375.20b60d8f9f72
pkgrel=1
arch=(x86_64)
url='https://cgit.freedesktop.org/~agd5f/linux/'
@@ -28,7 +28,7 @@ source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}
linux.preset # standard config files for mkinitcpio ramdisk
)
sha256sums=('SKIP'
- '659f13ca424866539664bffc189a3939d068848c38005bf8c57b7e82e11e64bb'
+ '3390c9937264bf3bcb577a947b61ca8b4547913b5c0fb7bc6eb232cbb2f4fcd9'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -71,7 +71,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules #htmldocs
+ make bzImage modules htmldocs
}
_package() {
@@ -211,11 +211,41 @@ _package-headers() {
chmod -Rc u=rwX,go=rX "$pkgdir"
}
-pkgname=("$pkgbase" "$pkgbase-headers")
+_package-docs() {
+ pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ cd $_srcname
+
+ msg2 "Installing documentation..."
+ mkdir -p "$builddir"
+ cp -t "$builddir" -a Documentation
+
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+
+ msg2 "Fixing permissions..."
+ chmod -Rc u=rwX,go=rX "$pkgdir"
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
_package${_p#$pkgbase}
}"
done
-
diff --git a/config b/config
index 06436df9342c..7b341114ebfa 100644
--- a/config
+++ b/config
@@ -3344,7 +3344,7 @@ CONFIG_LED_TRIGGER_PHY=y
CONFIG_SFP=m
CONFIG_AMD_PHY=m
CONFIG_AQUANTIA_PHY=m
-# CONFIG_AX88796B_PHY is not set
+CONFIG_AX88796B_PHY=m
CONFIG_AT803X_PHY=m
CONFIG_BCM7XXX_PHY=m
CONFIG_BCM87XX_PHY=m