summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--60-linux.hook12
-rw-r--r--90-linux.hook11
-rw-r--r--PKGBUILD15
-rw-r--r--linux.preset14
5 files changed, 8 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54206f5c4252..266cbde70e36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = linux-amd-staging-drm-next-git
pkgdesc = Linux kernel with AMDGPU DC patches
- pkgver = 5.5.875183.2c96a366b9a0
+ pkgver = 5.5.875463.f654d6d1c225
pkgrel = 1
url = https://cgit.freedesktop.org/~agd5f/linux/
arch = x86_64
license = GPL2
- makedepends = xmlto
- makedepends = kmod
- makedepends = inetutils
makedepends = bc
+ makedepends = kmod
makedepends = libelf
- makedepends = git
+ makedepends = xmlto
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
makedepends = graphviz
@@ -19,14 +17,8 @@ pkgbase = linux-amd-staging-drm-next-git
options = !strip
source = linux-amd-staging-drm-next-git::git://people.freedesktop.org/~agd5f/linux#branch=amd-staging-drm-next
source = config
- source = 60-linux.hook
- source = 90-linux.hook
- source = linux.preset
sha256sums = SKIP
sha256sums = 17c288ec0752b07472e928d447ba1c945c77e24ae0ff006eda319b4672344fdc
- sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0
- sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-amd-staging-drm-next-git
pkgdesc = The Linux-amd-staging-drm-next-git kernel and modules
diff --git a/60-linux.hook b/60-linux.hook
deleted file mode 100644
index b33873c854fb..000000000000
--- a/60-linux.hook
+++ /dev/null
@@ -1,12 +0,0 @@
-[Trigger]
-Type = File
-Operation = Install
-Operation = Upgrade
-Operation = Remove
-Target = usr/lib/modules/%KERNVER%/*
-Target = usr/lib/modules/%EXTRAMODULES%/*
-
-[Action]
-Description = Updating %PKGBASE% module dependencies...
-When = PostTransaction
-Exec = /usr/bin/depmod %KERNVER%
diff --git a/90-linux.hook b/90-linux.hook
deleted file mode 100644
index 9851151995bc..000000000000
--- a/90-linux.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Type = File
-Operation = Install
-Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
-Target = usr/lib/initcpio/*
-
-[Action]
-Description = Updating %PKGBASE% initcpios
-When = PostTransaction
-Exec = /usr/bin/mkinitcpio -p %PKGBASE%
diff --git a/PKGBUILD b/PKGBUILD
index 76f15fe76ca9..0b0b2c227a60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,27 +11,22 @@ pkgdesc='Linux kernel with AMDGPU DC patches'
_srcname=${pkgbase}
_branch=amd-staging-drm-next
_kernelname=${pkgbase#linux}
-pkgver=5.5.875183.2c96a366b9a0
+pkgver=5.5.875463.f654d6d1c225
pkgrel=1
arch=(x86_64)
url='https://cgit.freedesktop.org/~agd5f/linux/'
license=(GPL2)
makedepends=(
- xmlto kmod inetutils bc libelf git python-sphinx python-sphinx_rtd_theme
- graphviz imagemagick git
+ bc kmod libelf
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ git
)
options=('!strip')
source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}"
config # the main kernel config file
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
)
sha256sums=('SKIP'
- '17c288ec0752b07472e928d447ba1c945c77e24ae0ff006eda319b4672344fdc'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
+ '17c288ec0752b07472e928d447ba1c945c77e24ae0ff006eda319b4672344fdc')
pkgver() {
cd "${_srcname}"
local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
diff --git a/linux.preset b/linux.preset
deleted file mode 100644
index 66709a8c1537..000000000000
--- a/linux.preset
+++ /dev/null
@@ -1,14 +0,0 @@
-# mkinitcpio preset file for the '%PKGBASE%' package
-
-ALL_config="/etc/mkinitcpio.conf"
-ALL_kver="/boot/vmlinuz-%PKGBASE%"
-
-PRESETS=('default' 'fallback')
-
-#default_config="/etc/mkinitcpio.conf"
-default_image="/boot/initramfs-%PKGBASE%.img"
-#default_options=""
-
-#fallback_config="/etc/mkinitcpio.conf"
-fallback_image="/boot/initramfs-%PKGBASE%-fallback.img"
-fallback_options="-S autodetect"