summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--amdgpu_hdmihotplug.patch173
-rw-r--r--amdgpu_shutdown.patch76
-rw-r--r--config.x86_646
5 files changed, 8 insertions, 271 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 107a41fefebb..b09b2faa1c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd-znver2
- pkgver = 5.11.v.2
+ pkgver = 5.11.v.3
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -13,20 +13,16 @@ pkgbase = linux-amd-znver2
makedepends = libelf
makedepends = lzop
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.11.2
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.11.3
source = config.x86_64
source = linux-amd-znver2.preset
source = linux.install
source = 5013_enable-cpu-optimizations-for-gcc10.patch
- source = amdgpu_hdmihotplug.patch
- source = amdgpu_shutdown.patch
sha256sums = SKIP
- sha256sums = 7935a84230918c8d79b35b50bd5a04108f9f4fa84dc6f435ef94d0e74eec8cbb
+ sha256sums = 017d2f8e61f10b1a89bca204751fda9258b9b3bb12ea4b219f989ac9879397cb
sha256sums = 60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c
sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = 126cd35b1153b69dd8d713f902d09ecc64ce8af2e4fa6f021219a65e62e13875
- sha256sums = abbb23f55cd25941d5487084c627f601bfa0ca63e329d580cc5a472b4638aeaa
- sha256sums = 33ccd96aa615ad9217032535ab9ad88cb885480d33f172beb466bc81020f88fb
pkgname = linux-amd-znver2
pkgdesc = Linux kernel aimed at the znver2 AMD Ryzen CPU based hardware
diff --git a/PKGBUILD b/PKGBUILD
index 3859df2c8ef1..2e2ef8e6b838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=linux-amd-znver2
_srcname=linux
-gitver=v5.11.2
-pkgver=5.11.v.2
+gitver=v5.11.3
+pkgver=5.11.v.3
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -20,24 +20,16 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
'linux.install'
# patch from our gentoo overlords
'5013_enable-cpu-optimizations-for-gcc10.patch'
- # AMDgpu HDMI hotplug patch
- 'amdgpu_hdmihotplug.patch'
- # AMDgpu shutdown patch for renoir
- 'amdgpu_shutdown.patch'
)
sha256sums=('SKIP'
#config.x86_64
- '7935a84230918c8d79b35b50bd5a04108f9f4fa84dc6f435ef94d0e74eec8cbb'
+ '017d2f8e61f10b1a89bca204751fda9258b9b3bb12ea4b219f989ac9879397cb'
#.preset file
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#linux install file
'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#gentoopatch
'126cd35b1153b69dd8d713f902d09ecc64ce8af2e4fa6f021219a65e62e13875'
- #AMDgpu patch
- 'abbb23f55cd25941d5487084c627f601bfa0ca63e329d580cc5a472b4638aeaa'
- #AMDgpu shutdown patch
- '33ccd96aa615ad9217032535ab9ad88cb885480d33f172beb466bc81020f88fb'
)
_kernelname=${pkgbase#linux}
diff --git a/amdgpu_hdmihotplug.patch b/amdgpu_hdmihotplug.patch
deleted file mode 100644
index 074da18dcabb..000000000000
--- a/amdgpu_hdmihotplug.patch
+++ /dev/null
@@ -1,173 +0,0 @@
-commit 85f4f00c1e88b2a5aced59cca7354631e8889dfb
-Author: Alex Deucher <alexander.deucher@amd.com>
-Date: Tue Feb 9 17:21:58 2021 -0500
-
- Revert "drm/amd/display: reuse current context instead of recreating one"
-
- This reverts commit 8866a67ab86cc0812e65c04f1ef02bcc41e24d68.
-
- This breaks hotplug of HDMI on some systems, resulting in
- a blank screen also causes failures for displays to light up
- on other systems.
-
- Bug: https://gitlab.freedesktop.org/drm/amd/-/issues/1487
- Bug: https://gitlab.freedesktop.org/drm/amd/-/issues/1492
- Bug: https://bugzilla.kernel.org/show_bug.cgi?id=211649
- Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
-
-diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-index 34218c2fe835..eed6d04e9572 100644
---- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-@@ -1937,7 +1937,7 @@ static void dm_gpureset_commit_state(struct dc_state *dc_state,
- dc_commit_updates_for_stream(
- dm->dc, bundle->surface_updates,
- dc_state->stream_status->plane_count,
-- dc_state->streams[k], &bundle->stream_update);
-+ dc_state->streams[k], &bundle->stream_update, dc_state);
- }
-
- cleanup:
-@@ -1968,7 +1968,8 @@ static void dm_set_dpms_off(struct dc_link *link)
-
- stream_update.stream = stream_state;
- dc_commit_updates_for_stream(stream_state->ctx->dc, NULL, 0,
-- stream_state, &stream_update);
-+ stream_state, &stream_update,
-+ stream_state->ctx->dc->current_state);
- mutex_unlock(&adev->dm.dc_lock);
- }
-
-@@ -7674,7 +7675,7 @@ static void amdgpu_dm_commit_planes(struct drm_atomic_state *state,
- struct drm_crtc *pcrtc,
- bool wait_for_vblank)
- {
-- int i;
-+ uint32_t i;
- uint64_t timestamp_ns;
- struct drm_plane *plane;
- struct drm_plane_state *old_plane_state, *new_plane_state;
-@@ -7715,7 +7716,7 @@ static void amdgpu_dm_commit_planes(struct drm_atomic_state *state,
- amdgpu_dm_commit_cursors(state);
-
- /* update planes when needed */
-- for_each_oldnew_plane_in_state_reverse(state, plane, old_plane_state, new_plane_state, i) {
-+ for_each_oldnew_plane_in_state(state, plane, old_plane_state, new_plane_state, i) {
- struct drm_crtc *crtc = new_plane_state->crtc;
- struct drm_crtc_state *new_crtc_state;
- struct drm_framebuffer *fb = new_plane_state->fb;
-@@ -7938,7 +7939,8 @@ static void amdgpu_dm_commit_planes(struct drm_atomic_state *state,
- bundle->surface_updates,
- planes_count,
- acrtc_state->stream,
-- &bundle->stream_update);
-+ &bundle->stream_update,
-+ dc_state);
-
- /**
- * Enable or disable the interrupts on the backend.
-@@ -8274,13 +8276,13 @@ static void amdgpu_dm_atomic_commit_tail(struct drm_atomic_state *state)
- struct dm_connector_state *dm_new_con_state = to_dm_connector_state(new_con_state);
- struct dm_connector_state *dm_old_con_state = to_dm_connector_state(old_con_state);
- struct amdgpu_crtc *acrtc = to_amdgpu_crtc(dm_new_con_state->base.crtc);
-- struct dc_surface_update surface_updates[MAX_SURFACES];
-+ struct dc_surface_update dummy_updates[MAX_SURFACES];
- struct dc_stream_update stream_update;
- struct dc_info_packet hdr_packet;
- struct dc_stream_status *status = NULL;
- bool abm_changed, hdr_changed, scaling_changed;
-
-- memset(&surface_updates, 0, sizeof(surface_updates));
-+ memset(&dummy_updates, 0, sizeof(dummy_updates));
- memset(&stream_update, 0, sizeof(stream_update));
-
- if (acrtc) {
-@@ -8337,15 +8339,16 @@ static void amdgpu_dm_atomic_commit_tail(struct drm_atomic_state *state)
- * To fix this, DC should permit updating only stream properties.
- */
- for (j = 0; j < status->plane_count; j++)
-- surface_updates[j].surface = status->plane_states[j];
-+ dummy_updates[j].surface = status->plane_states[0];
-
-
- mutex_lock(&dm->dc_lock);
- dc_commit_updates_for_stream(dm->dc,
-- surface_updates,
-+ dummy_updates,
- status->plane_count,
- dm_new_crtc_state->stream,
-- &stream_update);
-+ &stream_update,
-+ dc_state);
- mutex_unlock(&dm->dc_lock);
- }
-
-diff --git a/drivers/gpu/drm/amd/display/dc/core/dc.c b/drivers/gpu/drm/amd/display/dc/core/dc.c
-index e2cc1a141131..702c266e60f8 100644
---- a/drivers/gpu/drm/amd/display/dc/core/dc.c
-+++ b/drivers/gpu/drm/amd/display/dc/core/dc.c
-@@ -2692,7 +2692,8 @@ void dc_commit_updates_for_stream(struct dc *dc,
- struct dc_surface_update *srf_updates,
- int surface_count,
- struct dc_stream_state *stream,
-- struct dc_stream_update *stream_update)
-+ struct dc_stream_update *stream_update,
-+ struct dc_state *state)
- {
- const struct dc_stream_status *stream_status;
- enum surface_update_type update_type;
-@@ -2711,12 +2712,6 @@ void dc_commit_updates_for_stream(struct dc *dc,
-
-
- if (update_type >= UPDATE_TYPE_FULL) {
-- struct dc_plane_state *new_planes[MAX_SURFACES];
--
-- memset(new_planes, 0, sizeof(new_planes));
--
-- for (i = 0; i < surface_count; i++)
-- new_planes[i] = srf_updates[i].surface;
-
- /* initialize scratch memory for building context */
- context = dc_create_state(dc);
-@@ -2725,21 +2720,15 @@ void dc_commit_updates_for_stream(struct dc *dc,
- return;
- }
-
-- dc_resource_state_copy_construct(
-- dc->current_state, context);
-+ dc_resource_state_copy_construct(state, context);
-
-- /*remove old surfaces from context */
-- if (!dc_rem_all_planes_for_stream(dc, stream, context)) {
-- DC_ERROR("Failed to remove streams for new validate context!\n");
-- return;
-- }
-+ for (i = 0; i < dc->res_pool->pipe_count; i++) {
-+ struct pipe_ctx *new_pipe = &context->res_ctx.pipe_ctx[i];
-+ struct pipe_ctx *old_pipe = &dc->current_state->res_ctx.pipe_ctx[i];
-
-- /* add surface to context */
-- if (!dc_add_all_planes_for_stream(dc, stream, new_planes, surface_count, context)) {
-- DC_ERROR("Failed to add streams for new validate context!\n");
-- return;
-+ if (new_pipe->plane_state && new_pipe->plane_state != old_pipe->plane_state)
-+ new_pipe->plane_state->force_full_update = true;
- }
--
- }
-
-
-diff --git a/drivers/gpu/drm/amd/display/dc/dc_stream.h b/drivers/gpu/drm/amd/display/dc/dc_stream.h
-index e243c01b9672..b7910976b81a 100644
---- a/drivers/gpu/drm/amd/display/dc/dc_stream.h
-+++ b/drivers/gpu/drm/amd/display/dc/dc_stream.h
-@@ -283,7 +283,8 @@ void dc_commit_updates_for_stream(struct dc *dc,
- struct dc_surface_update *srf_updates,
- int surface_count,
- struct dc_stream_state *stream,
-- struct dc_stream_update *stream_update);
-+ struct dc_stream_update *stream_update,
-+ struct dc_state *state);
- /*
- * Log the current stream state.
- */
diff --git a/amdgpu_shutdown.patch b/amdgpu_shutdown.patch
deleted file mode 100644
index 5008e1b2c29e..000000000000
--- a/amdgpu_shutdown.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 7cf0e0150921b809cd69d2834789532e8409ffdf Mon Sep 17 00:00:00 2001
-From: Alex Deucher <alexander.deucher@amd.com>
-Date: Thu, 18 Feb 2021 12:05:53 -0500
-Subject: [PATCH] drm/amdgpu: fix shutdown with s0ix
-
-For shutdown needs to be handled differently and s0ix. Add
-a new flag to shutdown and use it to adjust behavior appropriately.
-
-Bug: https://gitlab.freedesktop.org/drm/amd/-/issues/1499
-Fixes: 628c36d7b238e2 ("drm/amdgpu: update amdgpu device suspend/resume sequence for s0i3 support")
-Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
-Cc: Prike Liang <Prike.Liang@amd.com>
----
- drivers/gpu/drm/amd/amdgpu/amdgpu.h | 1 +
- drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 6 ++++--
- drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 2 ++
- 3 files changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu.h b/drivers/gpu/drm/amd/amdgpu/amdgpu.h
-index 2dd19e2e3e23..d4876e586d93 100644
---- a/drivers/gpu/drm/amd/amdgpu/amdgpu.h
-+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu.h
-@@ -1005,6 +1005,7 @@ struct amdgpu_device {
- /* s3/s4 mask */
- bool in_suspend;
- bool in_hibernate;
-+ bool in_shutdown;
-
- atomic_t in_gpu_reset;
- enum pp_mp1_state mp1_state;
-diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
-index 7052dc35d278..ecd0201050ac 100644
---- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
-+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
-@@ -2678,7 +2678,8 @@ static int amdgpu_device_ip_suspend_phase1(struct amdgpu_device *adev)
- {
- int i, r;
-
-- if (!amdgpu_acpi_is_s0ix_supported(adev) || amdgpu_in_reset(adev)) {
-+ if (adev->in_shutdown ||
-+ !amdgpu_acpi_is_s0ix_supported(adev) || amdgpu_in_reset(adev)) {
- amdgpu_device_set_pg_state(adev, AMD_PG_STATE_UNGATE);
- amdgpu_device_set_cg_state(adev, AMD_CG_STATE_UNGATE);
- }
-@@ -3741,7 +3742,8 @@ int amdgpu_device_suspend(struct drm_device *dev, bool fbcon)
-
- amdgpu_fence_driver_suspend(adev);
-
-- if (!amdgpu_acpi_is_s0ix_supported(adev) || amdgpu_in_reset(adev))
-+ if (adev->in_shutdown ||
-+ !amdgpu_acpi_is_s0ix_supported(adev) || amdgpu_in_reset(adev))
- r = amdgpu_device_ip_suspend_phase2(adev);
- else
- amdgpu_gfx_state_change_set(adev, sGpuChangeState_D3Entry);
-diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
-index 7715f62791b0..f3b91aa55466 100644
---- a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
-+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
-@@ -1263,6 +1263,7 @@ amdgpu_pci_shutdown(struct pci_dev *pdev)
- if (amdgpu_ras_intr_triggered())
- return;
-
-+ adev->in_shutdown = true;
- /* if we are running in a VM, make sure the device
- * torn down properly on reboot/shutdown.
- * unfortunately we can't detect certain
-@@ -1272,6 +1273,7 @@ amdgpu_pci_shutdown(struct pci_dev *pdev)
- adev->mp1_state = PP_MP1_STATE_UNLOAD;
- amdgpu_device_ip_suspend(adev);
- adev->mp1_state = PP_MP1_STATE_NONE;
-+ adev->in_shutdown = false;
- }
-
- static int amdgpu_pmops_suspend(struct device *dev)
---
-2.29.2
diff --git a/config.x86_64 b/config.x86_64
index 5256e31745eb..8810d1ccea94 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.11.2 Kernel Configuration
+# Linux/x86 5.11.3 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 10.2.0"
CONFIG_CC_IS_GCC=y
@@ -252,6 +252,7 @@ CONFIG_USERMODE_DRIVER=y
# CONFIG_BPF_PRELOAD is not set
CONFIG_USERFAULTFD=y
CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE=y
+CONFIG_KCMP=y
CONFIG_RSEQ=y
CONFIG_DEBUG_RSEQ=y
# CONFIG_EMBEDDED is not set
@@ -7460,9 +7461,6 @@ CONFIG_TOUCHSCREEN_DMI=y
# CONFIG_INTEL_UNCORE_FREQ_CONTROL is not set
# CONFIG_INTEL_PMC_CORE is not set
-# CONFIG_INTEL_PMT_CLASS is not set
-# CONFIG_INTEL_PMT_TELEMETRY is not set
-# CONFIG_INTEL_PMT_CRASHLOG is not set
# CONFIG_INTEL_PUNIT_IPC is not set
# CONFIG_INTEL_SCU_PCI is not set
# CONFIG_INTEL_SCU_PLATFORM is not set