summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch30
-rw-r--r--PKGBUILD9
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31a5caeee71f..5d1c663def5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bcm4350
pkgver = 4.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = i686
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = linux-bcm4350
source = change-default-console-loglevel.patch
source = 0001-bcm4350.patch
source = 0002-Add-DC6-disabling-as-a-power-well.patch
+ source = 0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch
sha256sums = 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae
sha256sums = SKIP
sha256sums = 596958c9c4b632fdf5e0cdc677859dccac4304ad07a217c9bcb0e4fa58dbea16
@@ -27,6 +28,7 @@ pkgbase = linux-bcm4350
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = 7a3763a7dcdfada7edda636860ee125e270a9542d70c496edf9850c02a25baad
sha256sums = 7bf515ca1fc1c432999f7c5227d77d7c0429eaabbc48bc887383119bbeca2dd4
+ sha256sums = 7bbd0fb7f0d82d982b0f8ff1299e67c9d40f43dcb8054bd8553396c0e8b2b2c5
pkgname = linux-bcm4350
pkgdesc = The Linux-bcm4350 kernel and modules
diff --git a/0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch b/0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch
new file mode 100644
index 000000000000..f25ca5c4bdc0
--- /dev/null
+++ b/0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch
@@ -0,0 +1,30 @@
+Signed-off-by: Mika Westerberg <mika.westerberg@linux.intel.com>
+---
+ drivers/hid/hid-multitouch.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+diff --git a/drivers/hid/hid-multitouch.c b/drivers/hid/hid-multitouch.c
+index 426b2f1a3450..1911f7698511 100644
+--- a/drivers/hid/hid-multitouch.c
++++ b/drivers/hid/hid-multitouch.c
+@@ -1020,14 +1020,16 @@ static int mt_probe(struct hid_device *hdev, const struct hid_device_id *id)
+ /*
+ * Handle special quirks for Windows 8 certified devices.
+ */
+- if (id->group == HID_GROUP_MULTITOUCH_WIN_8)
++ if (id->group == HID_GROUP_MULTITOUCH_WIN_8) {
+ /*
+ * Some multitouch screens do not like to be polled for input
+- * reports. Fortunately, the Win8 spec says that all touches
+- * should be sent during each report, making the initialization
+- * of input reports unnecessary.
++ * and feature reports. Fortunately, the Win8 spec says that all
++ * touches should be sent during each report, making the
++ * initialization of input reports unnecessary.
+ */
+ hdev->quirks |= HID_QUIRK_NO_INIT_INPUT_REPORTS;
++ hdev->quirks |= HID_QUIRK_NO_INIT_REPORTS;
++ }
+
+ td = devm_kzalloc(&hdev->dev, sizeof(struct mt_device), GFP_KERNEL);
+ if (!td) {
+
diff --git a/PKGBUILD b/PKGBUILD
index 7b7963be4bb5..a8d54cb5126d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgbase=linux-bcm4350 # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-4.3
pkgver=4.3
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -22,7 +22,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'change-default-console-loglevel.patch'
'0001-bcm4350.patch'
- '0002-Add-DC6-disabling-as-a-power-well.patch')
+ '0002-Add-DC6-disabling-as-a-power-well.patch'
+ '0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch')
sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'SKIP'
@@ -31,7 +32,8 @@ sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'7a3763a7dcdfada7edda636860ee125e270a9542d70c496edf9850c02a25baad'
- '7bf515ca1fc1c432999f7c5227d77d7c0429eaabbc48bc887383119bbeca2dd4')
+ '7bf515ca1fc1c432999f7c5227d77d7c0429eaabbc48bc887383119bbeca2dd4'
+ '7bbd0fb7f0d82d982b0f8ff1299e67c9d40f43dcb8054bd8553396c0e8b2b2c5')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -59,6 +61,7 @@ prepare() {
# prevent intel graffics to fail on skylake
patch -p1 -i "${srcdir}/0002-Add-DC6-disabling-as-a-power-well.patch"
+ patch -p1 -i "${srcdir}/0003-HID-multitouch-Do-not-fetch-initial-feature-reports-for-Win8-devices.patch"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config