summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eda23b2030c2..83cbf9878daa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,7 @@
pkgbase = linux-bfq
+ pkgdesc = Linux BFQ-dev
pkgver = 5.3.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
@@ -32,7 +33,7 @@ pkgbase = linux-bfq
sha512sums = e8ada62bb3cec4828d5440bdf82d1b340e9b0f446af625f0351e6f455ff6eb34af8e9393e288769d0fa453f91300a47ef6345a5b86aefce261b48aa0d013bd6d
pkgname = linux-bfq
- pkgdesc = The Linux-bfq kernel and modules with the BFQ-dev
+ pkgdesc = The Linux BFQ-dev kernel and modules
depends = coreutils
depends = kmod
depends = initramfs
@@ -41,10 +42,10 @@ pkgname = linux-bfq
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
pkgname = linux-bfq-headers
- pkgdesc = Header files and scripts for building modules for Linux-bfq kernel
+ pkgdesc = Headers and scripts for building modules for the Linux BFQ-dev kernel
depends = linux-bfq
pkgname = linux-bfq-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bfq kernel
+ pkgdesc = Kernel hacker's manual for the Linux BFQ-dev kernel
depends = linux-bfq
diff --git a/PKGBUILD b/PKGBUILD
index 70981e9d3d1b..fcaa1756b3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,8 @@ _major=5.3
_minor=9
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel=2
+pkgdesc='Linux BFQ-dev'
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -190,7 +191,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the BFQ-dev"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=('coreutils' 'kmod' 'initramfs')
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
@@ -219,7 +220,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=('linux-bfq')
cd $_srcname
@@ -298,7 +299,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
depends=('linux-bfq')
cd $_srcname
@@ -308,8 +309,8 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
+ msg2 "Removing unneeded files..."
+ rm -rv "$builddir"/Documentation/{,output/}.[^.]*
msg2 "Moving HTML docs..."
local src dst