summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-fix-bridge-regression.patch25
-rw-r--r--PKGBUILD19
3 files changed, 12 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2788e776cd1..2902cd6b05de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-c720
- pkgver = 4.2.2
+ pkgver = 4.2.3
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -13,26 +13,24 @@ pkgbase = linux-c720
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.2.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.2.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.3.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.3.sign
source = config
source = config.x86_64
source = linux.preset
source = change-default-console-loglevel.patch
source = 0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch
source = 0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch
- source = 0001-fix-bridge-regression.patch
sha256sums = cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb
sha256sums = SKIP
- sha256sums = 8b4578f1e1dcfbef1e39c39b861d4715aa99917af0b7c2dc324622d65884dcb5
+ sha256sums = e0e066f3fc5f310644e9f3f3ede47db7ac040f44782f0a5cf75ce2c940444972
sha256sums = SKIP
- sha256sums = 6eb2dc9edfb5280912c24f16bf72248f51da8823651c429cb1d00d44df768e85
+ sha256sums = 7c78b6ff96680af2533785610c16a301da0a454241635d379529d182754ad5fd
sha256sums = a071aaa327d2b3577fa4709b47ed5fe81c7914d168607f3db905fdbf226247e7
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = 0b1e41ba59ae45f5929963aa22fdc53bc8ffb4534e976cec046269d1a462197b
sha256sums = 6ed9e31ae5614c289c4884620e45698e764c03670ebc45bab9319d741238cbd3
- sha256sums = 0a8fe4434e930d393c7983e335842f6cb77ee263af5592a0ca7e14bae7296183
pkgname = linux-c720
pkgdesc = The Linux-c720 kernel and modules
diff --git a/0001-fix-bridge-regression.patch b/0001-fix-bridge-regression.patch
deleted file mode 100644
index 250dfcbcfbf8..000000000000
--- a/0001-fix-bridge-regression.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-@@ -, +, @@
----
- net/bridge/br_multicast.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
---- a/net/bridge/br_multicast.c
-+++ a/net/bridge/br_multicast.c
-@@ -991,7 +991,7 @@ static int br_ip4_multicast_igmp3_report(struct net_bridge *br,
-
- ih = igmpv3_report_hdr(skb);
- num = ntohs(ih->ngrec);
-- len = sizeof(*ih);
-+ len = skb_transport_offset(skb) + sizeof(*ih);
-
- for (i = 0; i < num; i++) {
- len += sizeof(*grec);
-@@ -1052,7 +1052,7 @@ static int br_ip6_multicast_mld2_report(struct net_bridge *br,
-
- icmp6h = icmp6_hdr(skb);
- num = ntohs(icmp6h->icmp6_dataun.un_data16[1]);
-- len = sizeof(*icmp6h);
-+ len = skb_transport_offset(skb) + sizeof(*icmp6h);
-
- for (i = 0; i < num; i++) {
- __be16 *nsrcs, _nsrcs;
---
diff --git a/PKGBUILD b/PKGBUILD
index e9eb00cd4acc..a74136b4b5e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 247911 2015-09-30 04:43:22Z tpowa $
+# $Id: PKGBUILD 248309 2015-10-03 17:23:18Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-c720 # Build kernel with a different name
_srcname=linux-4.2
-pkgver=4.2.2
+pkgver=4.2.3
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -22,19 +22,18 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'change-default-console-loglevel.patch'
'0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch'
- '0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch'
- '0001-fix-bridge-regression.patch')
+ '0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch')
+
sha256sums=('cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb'
'SKIP'
- '8b4578f1e1dcfbef1e39c39b861d4715aa99917af0b7c2dc324622d65884dcb5'
+ 'e0e066f3fc5f310644e9f3f3ede47db7ac040f44782f0a5cf75ce2c940444972'
'SKIP'
'7c78b6ff96680af2533785610c16a301da0a454241635d379529d182754ad5fd'
'a071aaa327d2b3577fa4709b47ed5fe81c7914d168607f3db905fdbf226247e7'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'0b1e41ba59ae45f5929963aa22fdc53bc8ffb4534e976cec046269d1a462197b'
- '6ed9e31ae5614c289c4884620e45698e764c03670ebc45bab9319d741238cbd3'
- '0a8fe4434e930d393c7983e335842f6cb77ee263af5592a0ca7e14bae7296183')
+ '6ed9e31ae5614c289c4884620e45698e764c03670ebc45bab9319d741238cbd3')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -59,10 +58,6 @@ prepare() {
# rules are applied during startup - happened with Shorewall; journal had
# many instances of this error: nf_conntrack: table full, dropping packet
patch -p1 -i "${srcdir}/0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch"
-
- # add not-yes-mainlined patch to fix bridge code
- # https://bugzilla.kernel.org/show_bug.cgi?id=104161
- patch -Np1 -i "${srcdir}/0001-fix-bridge-regression.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
@@ -92,7 +87,7 @@ prepare() {
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
- make nconfig # new CLI menu for configuration
+ #make nconfig # new CLI menu for configuration
#make xconfig # X-based configuration
#make oldconfig # using old config from previous kernel version
# ... or manually edit .config