summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--config2
3 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df6a2f5ead77..0f4300301573 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cachyos
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.4.5
- pkgrel = 1
+ pkgver = 6.4.8
+ pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -22,18 +22,18 @@ pkgbase = linux-cachyos
makedepends = patch
makedepends = python
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.5.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.8.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/sched/0001-EEVDF.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/sched/0001-bore-eevdf.patch
- b2sums = 2254e10d0780707591d25d5877dc946ba07b2f5a4f43063de55efea6724e267b1ab8f63329bec14431f4a4355fb4d474161c1d2c0c860d968630a3bb39e1a6e2
- b2sums = 40ea8f1e376c0e838b087009588515c7a6958e75fb79473eba29e5a05e4962c124ce83e6d1d450474dbfcdd6cc9f9a3305fc2a2a04881570a345cef3b62fd9e7
+ b2sums = d8e776a1ebc58f5f236ed3bf231336d1b1b4724f14dfafe2eeda789e022fcfc08bc6ff28c975ed94ede2145fab8aed551589873daefbd159a6fd7d8acc01e2f1
+ b2sums = fc2f4b943dc0a138303ed86b991fff7da256e66cf19673bcae81524f2e6ce692b3c50745b37b824754075ca7106676d12a62de5af0464762d7d7db47409567f8
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
- b2sums = d55de9c256671d398897fec9c212c2109f39cb1bca2a12535e6cd58ab18fd91bf238ff0bc305abb14cad5ff1144fcb42fcc31e632ab7daf7e610bd4a82b7304c
- b2sums = 6942fbf400f1cfb7fd57ae13b62ced22f41c602a7f08c7aeaa9de1fbb805f929d82a69e9a86f5152ab965ce011c474e9ec6a0d4c6369690815e3119036934ce3
- b2sums = 8731b806c5fd2d7922adeeb002aa5d3fdce43705631089062103a9b197c2e77ee72bd2236a17d519a427be5e368b86c4005c34022d0c677e9523da6813652e78
+ b2sums = 9961361f254d189f3b3bffa1276d19e4a1ba8f10454c247582469ee60ca3591f16f709ad1c51d60dafb799c5370f5d6818a5978264903e6517499cf3527aa04b
+ b2sums = 11d5923512051c46477aab7ceddaa1fef962c8d503975e34e660acb1a9c7040b147a935ca3f6f5f7e5cadb37e32a1cd25ddd8fda00c403d6364f9612ceebdc1f
+ b2sums = 893d96b3f582a753cd9821ee78028ef923fbf1c46f45c1c26f76ec02715ae89cdd536c1ebf95d54fb4d4ef4da4f1560f6e6136fd528489f703e41950c03a6dc3
pkgname = linux-cachyos
pkgdesc = The Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index d11410e3e73f..df0329873bdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,8 +73,8 @@ _nr_cpus=${_nr_cpus-}
### Set performance governor as default
_per_gov=${_per_gov-y}
-### Enable TCP_CONG_BBR2
-_tcp_bbr2=${_tcp_bbr2-y}
+### Enable TCP_CONG_BBR3
+_tcp_bbr3=${_tcp_bbr3-y}
### Running with a 1000HZ, 750Hz, 600 Hz, 500Hz, 300Hz, 250Hz and 100Hz tick rate
_HZ_ticks=${_HZ_ticks-500}
@@ -168,7 +168,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.4
-_minor=5
+_minor=8
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -178,7 +178,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -418,16 +418,16 @@ prepare() {
-e CONFIG_CC_OPTIMIZE_FOR_SIZE
fi
- ### Enable bbr2
- if [ -n "$_tcp_bbr2" ]; then
+ ### Enable bbr3
+ if [ -n "$_tcp_bbr3" ]; then
echo "Disabling TCP_CONG_CUBIC..."
scripts/config -m TCP_CONG_CUBIC \
-d DEFAULT_CUBIC \
- -e TCP_CONG_BBR2 \
- -e DEFAULT_BBR2 \
- --set-str DEFAULT_TCP_CONG bbr2
+ -e TCP_CONG_BBR \
+ -e DEFAULT_BBR \
+ --set-str DEFAULT_TCP_CONG bbr
- # BBR2 doesn't work properly with FQ_CODEL
+ # BBR3 doesn't work properly with FQ_CODEL
echo "Disabling fq_codel by default..."
scripts/config -m NET_SCH_FQ_CODEL \
-e NET_SCH_FQ \
@@ -789,9 +789,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('2254e10d0780707591d25d5877dc946ba07b2f5a4f43063de55efea6724e267b1ab8f63329bec14431f4a4355fb4d474161c1d2c0c860d968630a3bb39e1a6e2'
- '40ea8f1e376c0e838b087009588515c7a6958e75fb79473eba29e5a05e4962c124ce83e6d1d450474dbfcdd6cc9f9a3305fc2a2a04881570a345cef3b62fd9e7'
+b2sums=('d8e776a1ebc58f5f236ed3bf231336d1b1b4724f14dfafe2eeda789e022fcfc08bc6ff28c975ed94ede2145fab8aed551589873daefbd159a6fd7d8acc01e2f1'
+ 'fc2f4b943dc0a138303ed86b991fff7da256e66cf19673bcae81524f2e6ce692b3c50745b37b824754075ca7106676d12a62de5af0464762d7d7db47409567f8'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- 'd55de9c256671d398897fec9c212c2109f39cb1bca2a12535e6cd58ab18fd91bf238ff0bc305abb14cad5ff1144fcb42fcc31e632ab7daf7e610bd4a82b7304c'
- '6942fbf400f1cfb7fd57ae13b62ced22f41c602a7f08c7aeaa9de1fbb805f929d82a69e9a86f5152ab965ce011c474e9ec6a0d4c6369690815e3119036934ce3'
- '8731b806c5fd2d7922adeeb002aa5d3fdce43705631089062103a9b197c2e77ee72bd2236a17d519a427be5e368b86c4005c34022d0c677e9523da6813652e78')
+ '9961361f254d189f3b3bffa1276d19e4a1ba8f10454c247582469ee60ca3591f16f709ad1c51d60dafb799c5370f5d6818a5978264903e6517499cf3527aa04b'
+ '11d5923512051c46477aab7ceddaa1fef962c8d503975e34e660acb1a9c7040b147a935ca3f6f5f7e5cadb37e32a1cd25ddd8fda00c403d6364f9612ceebdc1f'
+ '893d96b3f582a753cd9821ee78028ef923fbf1c46f45c1c26f76ec02715ae89cdd536c1ebf95d54fb4d4ef4da4f1560f6e6136fd528489f703e41950c03a6dc3')
diff --git a/config b/config
index f9fd586d68ad..a68d63576ecf 100644
--- a/config
+++ b/config
@@ -2604,7 +2604,7 @@ CONFIG_ZRAM_DEF_COMP_ZSTD=y
# CONFIG_ZRAM_DEF_COMP_842 is not set
CONFIG_ZRAM_DEF_COMP="zstd"
CONFIG_ZRAM_WRITEBACK=y
-# CONFIG_ZRAM_MEMORY_TRACKING is not set
+CONFIG_ZRAM_MEMORY_TRACKING=y
CONFIG_ZRAM_MULTI_COMP=y
CONFIG_BLK_DEV_LOOP=m
CONFIG_BLK_DEV_LOOP_MIN_COUNT=0