summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32efb2ce1e49..46673bce6036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-cachyos
- pkgdesc = Linux SCHED-EXT + Cachy Sauce Kernel by CachyOS with other patches and improvements
+ pkgdesc = Linux SCHED-EXT + Cachy Sauce + BORE Kernel by CachyOS with other patches and improvements
pkgver = 6.8.9
pkgrel = 4
url = https://github.com/CachyOS/linux-cachyos
@@ -37,7 +37,7 @@ pkgbase = linux-cachyos
b2sums = e73f9da7831708b14c3a1542daa89d4a46a44fe8298ce4d6eee780a74eac50669002a1f00e0553ce7c269064f1720d13909dc231355e54f8e6cccbd5ce12736c
pkgname = linux-cachyos
- pkgdesc = The Linux SCHED-EXT + Cachy Sauce Kernel by CachyOS with other patches and improvements kernel and modules
+ pkgdesc = The Linux SCHED-EXT + Cachy Sauce + BORE Kernel by CachyOS with other patches and improvements kernel and modules
depends = coreutils
depends = kmod
depends = initramfs
@@ -52,6 +52,6 @@ pkgname = linux-cachyos
provides = UKSMD-BUILTIN
pkgname = linux-cachyos-headers
- pkgdesc = Headers and scripts for building modules for the Linux SCHED-EXT + Cachy Sauce Kernel by CachyOS with other patches and improvements kernel
+ pkgdesc = Headers and scripts for building modules for the Linux SCHED-EXT + Cachy Sauce + BORE Kernel by CachyOS with other patches and improvements kernel
depends = pahole
depends = linux-cachyos
diff --git a/PKGBUILD b/PKGBUILD
index fa0639a3e0b5..5860844113da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -168,7 +168,7 @@ _stable=${_major}.${_minor}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
-pkgdesc='Linux SCHED-EXT + Cachy Sauce Kernel by CachyOS with other patches and improvements'
+pkgdesc='Linux SCHED-EXT + Cachy Sauce + BORE Kernel by CachyOS with other patches and improvements'
pkgrel=4
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
@@ -210,7 +210,7 @@ fi
# NVIDIA pre-build module support
if [ -n "$_build_nvidia" ]; then
source+=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${_nv_ver}/${_nv_pkg}.run"
- "${_patchsource}/misc/nvidia/0001-NVIDIA-take-modeset-ownership-early.patch")
+ "${_patchsource}/misc/nvidia/make-modeset-fbdev-default.patch")
fi
## List of CachyOS schedulers
@@ -255,7 +255,7 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
src="${src%.zst}"
- [[ $src = 0001-NVIDIA-take-modeset-ownership-early.patch ]] && continue
+ [[ $src = make-modeset-fbdev-default.patch ]] && continue
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
@@ -528,8 +528,8 @@ prepare() {
cd "${srcdir}"
sh "${_nv_pkg}.run" --extract-only
- # Temporary fix for nvidia module
- patch -Np2 --no-backup-if-mismatch -i "${srcdir}/0001-NVIDIA-take-modeset-ownership-early.patch" -d "${srcdir}/${_nv_pkg}/kernel"
+ # Use fbdev and modeset as default
+ patch -Np1 -i "${srcdir}/make-modeset-fbdev-default.patch" -d "${srcdir}/${_nv_pkg}"
fi
}