summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
-rw-r--r--cacule_config270
3 files changed, 274 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27a870ea87e..40704c89217d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux-cacule. Branch with Cacule scheduler by Hamad Marri
pkgver = 5.11.15
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 005976d24d4f..cf67904be6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Joan Figueras <ffigue at gmail dot com>
+# Maintainer: Peter J <admin@ptr1337.dev>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Yoshi2889 <rick.2889 at gmail dot com>
@@ -40,7 +40,7 @@ fi
pkgbase=linux-cacule
_major=5.11
pkgver=${_major}.15
-pkgrel=1
+pkgrel=2
_branch=5.x
pkgdesc='Linux-cacule. Branch with Cacule scheduler by Hamad Marri'
url="http://www.kernel.org/"
@@ -86,7 +86,7 @@ export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})}
prepare() {
- cd linux-${_major}
+ cd linux-$pkgver
# Apply any patch
local src
@@ -101,12 +101,12 @@ prepare() {
# Copy the config file first
# Copy "${srcdir}"/config to linux-${pkgver}/.config
msg2 "Copy "${srcdir}"/config to linux-$pkgver/.config"
- cp "${srcdir}"/config-$major .config
+ cp "${srcdir}"/config .config
# Customize the kernel
source "${startdir}"/cacule_config
- cacule_config
+ configure
cpu_arch
@@ -162,7 +162,7 @@ prepare() {
}
build() {
- cd linux-${_major}
+ cd linux-$pkgver
make -j$(nproc) all
}
@@ -172,7 +172,7 @@ _package() {
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- cd linux-${_major}
+ cd linux-$pkgver
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
@@ -195,7 +195,7 @@ _package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
- cd linux-${_major}
+ cd linux-$pkgver
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing build files..."
diff --git a/cacule_config b/cacule_config
index affcc53d407c..c3ef26b12e6e 100644
--- a/cacule_config
+++ b/cacule_config
@@ -1,3 +1,6 @@
+#!/usr/bin/bash
+
+configure() {
echo "Enable CacULE CPU scheduler..."
scripts/config --enable CONFIG_CACULE_SCHED
echo "Processor type and features Cacule"
@@ -34,8 +37,265 @@ scripts/config --enable CONFIG_MODULE_COMPRESS
scripts/config --disable CONFIG_MODULE_COMPRESS_GZIP
scripts/config --disable CONFIG_MODULE_COMPRESS_XZ
scripts/config --enable CONFIG_MODULE_COMPRESS_ZSTD
-echo "Enable CONFIG_STACK_VALIDATION"
-scripts/config --enable CONFIG_STACK_VALIDATION
-echo "Enable IKCONFIG"
-scripts/config --enable CONFIG_IKCONFIG
-scripts/config --enable CONFIG_IKCONFIG_PROC
+}
+cpu_arch(){
+ plain ""
+ plain "#########################################"
+ plain "Set cpu microarchitecture optimization in GCC"
+ read -rp "`echo $' > 1) M486SX : Select this for an 486-class CPU without an FPU such as AMD/Cyrix/IBM/Intel SL/SLC/SLC2/SLC3/SX/SX2 and UMC U5S.\n \
+ > 2) M486 : Select this for an 486-class CPU such as AMD/Cyrix/IBM/Intel 486DX/DX2/DX4 and UMC U5D.\n \
+ > 3) M586 : Select this for an 586 or 686 series processor such as the AMD K5,the Cyrix 5x86, 6x86 and 6x86MX. This choice does not assume the RDTSC (Read Time Stamp Counter) instruction.\n \
+ > 4) M586TSC : Select this for a Pentium Classic processor with the RDTSC (Read Time Stamp Counter) instruction for benchmarking.\n \
+ > 5) M586MMX : Select this for a Pentium with the MMX graphics/multimedia extended instructions.\n \
+ > 6) M686 : Select this for Intel Pentium Pro chips.\n \
+ > 7) MPENTIUMII : Select this for Intel chips based on the Pentium-II and pre-Coppermine Celeron core.\n \
+ > 8) MPENTIUMIII : Select this for Intel chips based on the Pentium-III and Celeron-Coppermine core.\n \
+ > 9) MPENTIUMM : Select this for Intel Pentium M (not Pentium-4 M) notebook chips.\n \
+ > 10) MPENTIUM4 : Select this for Intel Pentium 4 chips.\n \
+ > 11) MK6 : Select this for an AMD K6-family processor.\n \
+ > 12) MK7 : Select this for an AMD Athlon K7-family processor.\n \
+ > 13) MK8 : Select this for an AMD Opteron or Athlon64 Hammer-family processor.\n \
+ > 14) MK8SSE3 : Select this for improved AMD Opteron or Athlon64 Hammer-family processors.\n \
+ > 15) MK10 : Select this for an AMD 61xx Eight-Core Magny-Cours, Athlon X2 7x50,Phenom X3/X4/II, Athlon II X2/X3/X4, or Turion II-family processor.\n \
+ > 16) MBARCELONA : Select this for AMD Family 10h Barcelona processors.\n \
+ > 17) MBOBCAT : Select this for AMD Family 14h Bobcat processors.\n \
+ > 18) MJAGUAR : Select this for AMD Family 16h Jaguar processors.\n \
+ > 19) MBULLDOZER : Select this for AMD Family 15h Bulldozer processors.\n \
+ > 20) MPILEDRIVER : Select this for AMD Family 15h Piledriver processors.\n \
+ > 21) MSTEAMROLLER : Select this for AMD Family 15h Steamroller processors.\n \
+ > 22) MEXCAVATOR : Select this for AMD Family 15h Excavator processors.\n \
+ > 23) MZEN : Select this for AMD Family 17h Zen processors.\n \
+ > 24) MZEN2 : Select this for AMD Family 17h Zen 2 processors.\n \
+ > 25) MZEN3 : Select this for AMD Family 19h Zen 3 processors. - GCC 10.3 required\n \
+ > 26) MCRUSOE : Select this for a Transmeta Crusoe processor.\n \
+ > 27) MEFFICEON : Select this for a Transmeta Efficeon processor.\n \
+ > 28) MWINCHIPC6 : Select this for an IDT Winchip C6 chip.\n \
+ > 29) MWINCHIP3D : Select this for an IDT Winchip-2, 2A or 3.\n \
+ > 30) MELAN : Select this for an AMD Elan processor.\n \
+ > 31) MGEODEGX1 : Select this for a Geode GX1 (Cyrix MediaGX) chip.\n \
+ > 32) MGEODE_LX Select this for AMD Geode GX and LX processors.\n \
+ > 33) MCYRIXIII : Select this for a Cyrix III or C3 chip.\n \
+ > 34) MVIAC3_2 : Select this for a VIA C3 "Nehemiah".\n \
+ > 35) MVIAC7 : Select this for a VIA C7.\n \
+ > 36) MPSC : Optimize for Intel Pentium 4, Pentium D and older Nocona/Dempsey Xeon CPUs with Intel 64bit which is compatible with x86-64.\n \
+ > 37) MATOM : Select this for the Intel Atom platform.\n \
+ > 38) MCORE2 : Select this for Intel Core 2 and newer Core 2 Xeons (Xeon 51xx and 53xx) CPUs.\n \
+ > 39) MNEHALEM : Select this for 1st Gen Core processors in the Nehalem family.\n \
+ > 40) MWESTMERE : Select this for the Intel Westmere formerly Nehalem-C family.\n \
+ > 41) MSILVERMONT Select this for the Intel Silvermont platform.\n \
+ > 42) MGOLDMONT : Select this for the Intel Goldmont platform including Apollo Lake and Denverton.\n \
+ > 43) MGOLDMONTPLUS : Select this for the Intel Goldmont Plus platform including Gemini Lake.\n \
+ > 44) MSANDYBRIDGE : Select this for 2nd Gen Core processors in the Sandy Bridge family.\n \
+ > 45) MIVYBRIDGE : Select this for 3rd Gen Core processors in the Ivy Bridge family.\n \
+ > 46) MHASWELL : Select this for 4th Gen Core processors in the Haswell family.\n \
+ > 47) MBROADWELL : Select this for 5th Gen Core processors in the Broadwell family.\n \
+ > 48) MSKYLAKE : Select this for 6th Gen Core processors in the Skylake family.\n \
+ > 49) MSKYLAKEX : Select this for 6th Gen Core processors in the Skylake X family.\n \
+ > 50) MCANNONLAKE : Select this for 8th Gen Core processors.\n \
+ > 51) MICELAKE : Select this for 10th Gen Core processors in the Ice Lake family.\n \
+ > 52) MCASCADELAKE : Select this for Xeon processors in the Cascade Lake family.\n \
+ > 53) MCOOPERLAKE : Select this for Xeon processors in the Cooper Lake family. - GCC 10.1 required\n \
+ > 54) MTIGERLAKE : Select this for third-generation 10 nm process processors in the Tiger Lake family. - GCC 10.1 required\n \
+ > 55) MSAPPHIRERAPIDS : Select this for third-generation 10 nm process processors in the Sapphire Rapids family. - GCC 11 required\n \
+ > 56) MALDERLAKE : Select this for twelfth-generation processors in the Alder Lake family.- GCC 11 required\n \
+ > 57) GENERIC_CPU : Generic x86-64 CPU. Run equally well on all x86-64 CPUs.\n \
+ > 58) GENERIC_CPU2 : Run equally well on all x86-64 CPUs with min support of x86-64-v2. - GCC 11 required\n \
+ > 59) GENERIC_CPU3 : Generic x86-64-v3 CPU with v3 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v3. - GCC 11 required\n \
+ > 60) GENERIC_CPU4 : Generic x86-64 CPU with v4 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v4. - GCC 11 required\n \
+ > 61) MNATIVE_INTEL : Intel-Native optimizations autodetected by GCC.\n \
+ > 62) MNATIVE_AMD : AMD-Native optimizations autodetected by GCC.\n \
+ > Default (57 : Gneric CPU)\nchoice[0-62]: '`" _microarchitecture
+
+ if [[ "$_microarchitecture" = "1" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "2" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "3" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586
+ elif [[ "$_microarchitecture" = "4" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586TSC
+ elif [[ "$_microarchitecture" = "5" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586MMX
+ elif [[ "$_microarchitecture" = "6" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M686
+ elif [[ "$_microarchitecture" = "7" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMII
+ elif [[ "$_microarchitecture" = "8" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMIII
+ elif [[ "$_microarchitecture" = "9" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMM
+ elif [[ "$_microarchitecture" = "10" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUM4
+ elif [[ "$_microarchitecture" = "11" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK6
+ elif [[ "$_microarchitecture" = "12" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK7
+ elif [[ "$_microarchitecture" = "13" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8
+ elif [[ "$_microarchitecture" = "14" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8SSE3
+ elif [[ "$_microarchitecture" = "15" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK10
+ elif [[ "$_microarchitecture" = "16" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBARCELONA
+ elif [[ "$_microarchitecture" = "17" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBOBCAT
+ elif [[ "$_microarchitecture" = "18" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MJAGUAR
+ elif [[ "$_microarchitecture" = "19" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBULLDOZER
+ elif [[ "$_microarchitecture" = "20" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPILEDRIVER
+ elif [[ "$_microarchitecture" = "21" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSTEAMROLLER
+ elif [[ "$_microarchitecture" = "22" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEXCAVATOR
+ elif [[ "$_microarchitecture" = "23" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN
+ elif [[ "$_microarchitecture" = "24" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN2
+ elif [[ "$_microarchitecture" = "25" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN3
+ elif [[ "$_microarchitecture" = "26" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCRUSOE
+ elif [[ "$_microarchitecture" = "27" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEFFICEON
+ elif [[ "$_microarchitecture" = "28" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIPC6
+ elif [[ "$_microarchitecture" = "29" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIP3D
+ elif [[ "$_microarchitecture" = "30" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MELAN
+ elif [[ "$_microarchitecture" = "31" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODEGX1
+ elif [[ "$_microarchitecture" = "32" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODE_LX
+ elif [[ "$_microarchitecture" = "33" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCYRIXIII
+ elif [[ "$_microarchitecture" = "34" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC3_2
+ elif [[ "$_microarchitecture" = "35" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC7
+ elif [[ "$_microarchitecture" = "36" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPSC
+ elif [[ "$_microarchitecture" = "37" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MATOM
+ elif [[ "$_microarchitecture" = "38" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCORE2
+ elif [[ "$_microarchitecture" = "39" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNEHALEM
+ elif [[ "$_microarchitecture" = "40" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWESTMERE
+ elif [[ "$_microarchitecture" = "41" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSILVERMONT
+ elif [[ "$_microarchitecture" = "42" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONT
+ elif [[ "$_microarchitecture" = "43" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONTPLUS
+ elif [[ "$_microarchitecture" = "44" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSANDYBRIDGE
+ elif [[ "$_microarchitecture" = "45" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MIVYBRIDGE
+ elif [[ "$_microarchitecture" = "46" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MHASWELL
+ elif [[ "$_microarchitecture" = "47" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBROADWELL
+ elif [[ "$_microarchitecture" = "48" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKE
+ elif [[ "$_microarchitecture" = "49" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKEX
+ elif [[ "$_microarchitecture" = "50" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCANNONLAKE
+ elif [[ "$_microarchitecture" = "51" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MICELAKE
+ elif [[ "$_microarchitecture" = "52" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCASCADELAKE
+ elif [[ "$_microarchitecture" = "53" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCOOPERLAKE
+ elif [[ "$_microarchitecture" = "54" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MTIGERLAKE
+ elif [[ "$_microarchitecture" = "55" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSAPPHIRERAPIDS
+ elif [[ "$_microarchitecture" = "56" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MALDERLAKE
+ elif [[ "$_microarchitecture" = "57" ]]; then
+ scripts/config --enable CONFIG_GENERIC_CPU
+ elif [[ "$_microarchitecture" = "58" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU2
+ elif [[ "$_microarchitecture" = "59" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU3
+ elif [[ "$_microarchitecture" = "60" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU4
+ elif [[ "$_microarchitecture" = "61" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_INTEL
+ elif [[ "$_microarchitecture" = "62" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_AMD
+ else
+ scripts/config --enable CONFIG_GENERIC_CPU
+ fi
+
+ plain ""
+
+ sleep 2
+}