summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--CVE-2016-0728.patch78
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b1a151f243c..9764c33a911f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 13:07:06 UTC 2016
+# Sat Jan 23 12:27:41 UTC 2016
pkgbase = linux-ck
- pkgver = 4.3.3
- pkgrel = 3
+ pkgver = 4.3.4
+ pkgrel = 1
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = i686
arch = x86_64
@@ -13,14 +13,13 @@ pkgbase = linux-ck
options = !strip
source = http://www.kernel.org/pub/linux/kernel/v4.x/linux-4.3.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.3.tar.sign
- source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.3.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.3.sign
+ source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.4.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.4.sign
source = config.x86_64
source = config
source = linux-ck.preset
source = change-default-console-loglevel.patch
source = 0001-disabling-primary-plane-in-the-noatomic-case.patch
- source = CVE-2016-0728.patch
source = http://ck.kolivas.org/patches/4.0/4.3/4.3-ck3/patch-4.3-ck3.xz
source = http://repo-ck.com/source/gcc_patch/enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch.gz
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r8-4.3.patch
@@ -28,14 +27,13 @@ pkgbase = linux-ck
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.3.0.patch
sha256sums = 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae
sha256sums = SKIP
- sha256sums = 95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5
+ sha256sums = 1867a17e108ae8d10163b2494c3b3aa23c03d9a47cda7381aea2f97366bed80d
sha256sums = SKIP
sha256sums = cce1f9916ae58b61f22068a3afe2fd6fc82ffc97c76d56622ea17d8cc603dbb2
sha256sums = 8e83d9306376750632e87bed77d4caf3475a4390a8f6673d58ee959b3722f12c
sha256sums = 2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d
- sha256sums = 03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9
sha256sums = 483c12e130285cbcb49648012416323a5cb8dd8a477fa064d96c2f53019f1b31
sha256sums = cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791
sha256sums = ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490
@@ -51,7 +49,7 @@ pkgname = linux-ck
optdepends = crda: to set the correct wireless channels of your country
optdepends = nvidia-ck: nVidia drivers for linux-ck
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
- provides = linux-ck=4.3.3
+ provides = linux-ck=4.3.4
conflicts = kernel26-ck
conflicts = linux-ck-corex
conflicts = linux-ck-p4
@@ -75,8 +73,8 @@ pkgname = linux-ck
pkgname = linux-ck-headers
pkgdesc = Header files and scripts to build modules for linux-ck.
depends = linux-ck
- provides = linux-ck-headers=4.3.3
- provides = linux-headers=4.3.3
+ provides = linux-ck-headers=4.3.4
+ provides = linux-headers=4.3.4
conflicts = kernel26-ck-headers
conflicts = linux-ck-corex-headers
conflicts = linux-ck-p4-headers
diff --git a/CVE-2016-0728.patch b/CVE-2016-0728.patch
deleted file mode 100644
index e915d8219e1a..000000000000
--- a/CVE-2016-0728.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
-From: Yevgeny Pats <yevgeny@perception-point.io>
-Date: Tue, 19 Jan 2016 22:09:04 +0000
-Subject: [PATCH] KEYS: Fix keyring ref leak in join_session_keyring()
-
-This fixes CVE-2016-0728.
-
-If a thread is asked to join as a session keyring the keyring that's already
-set as its session, we leak a keyring reference.
-
-This can be tested with the following program:
-
- #include <stddef.h>
- #include <stdio.h>
- #include <sys/types.h>
- #include <keyutils.h>
-
- int main(int argc, const char *argv[])
- {
- int i = 0;
- key_serial_t serial;
-
- serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
- "leaked-keyring");
- if (serial < 0) {
- perror("keyctl");
- return -1;
- }
-
- if (keyctl(KEYCTL_SETPERM, serial,
- KEY_POS_ALL | KEY_USR_ALL) < 0) {
- perror("keyctl");
- return -1;
- }
-
- for (i = 0; i < 100; i++) {
- serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
- "leaked-keyring");
- if (serial < 0) {
- perror("keyctl");
- return -1;
- }
- }
-
- return 0;
- }
-
-If, after the program has run, there something like the following line in
-/proc/keys:
-
-3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
-
-with a usage count of 100 * the number of times the program has been run,
-then the kernel is malfunctioning. If leaked-keyring has zero usages or
-has been garbage collected, then the problem is fixed.
-
-Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
-Signed-off-by: David Howells <dhowells@redhat.com>
-Acked-by: Don Zickus <dzickus@redhat.com>
-Acked-by: Prarit Bhargava <prarit@redhat.com>
-Acked-by: Jarod Wilson <jarod@redhat.com>
-Signed-off-by: James Morris <james.l.morris@oracle.com>
----
- security/keys/process_keys.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
-index a3f85d2a..e6d50172 100644
---- a/security/keys/process_keys.c
-+++ b/security/keys/process_keys.c
-@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
- ret = PTR_ERR(keyring);
- goto error2;
- } else if (keyring == new->session_keyring) {
-+ key_put(keyring);
- ret = 0;
- goto error2;
- }
diff --git a/PKGBUILD b/PKGBUILD
index cebebc18d862..a07e67c14deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,8 +52,8 @@ _BFQ_enable_=
pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.3
-pkgver=4.3.3
-pkgrel=3
+pkgver=4.3.4
+pkgrel=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
@@ -71,7 +71,6 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux-ck.preset'
'change-default-console-loglevel.patch'
'0001-disabling-primary-plane-in-the-noatomic-case.patch'
-'CVE-2016-0728.patch'
# ck3
"http://ck.kolivas.org/patches/4.0/4.3/4.3-ck${_ckpatchversion}/${_ckpatchname}.xz"
# gcc
@@ -82,14 +81,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"${_bfqpath}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.3.0.patch")
sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'SKIP'
- '95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5'
+ '1867a17e108ae8d10163b2494c3b3aa23c03d9a47cda7381aea2f97366bed80d'
'SKIP'
'cce1f9916ae58b61f22068a3afe2fd6fc82ffc97c76d56622ea17d8cc603dbb2'
'8e83d9306376750632e87bed77d4caf3475a4390a8f6673d58ee959b3722f12c'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d'
- '03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9'
'483c12e130285cbcb49648012416323a5cb8dd8a477fa064d96c2f53019f1b31'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490'
@@ -110,9 +108,6 @@ prepare() {
# hangs on older intel hardware
patch -Np1 -i "${srcdir}/0001-disabling-primary-plane-in-the-noatomic-case.patch"
- # fixes #47820 CVE-2016-0728.patch
- patch -Np1 -i "${srcdir}/CVE-2016-0728.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)