summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch32
-rw-r--r--PKGBUILD29
3 files changed, 36 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ced2753f92d..14d73d1854a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear
pkgdesc = Clear Linux
- pkgver = 5.12.17
+ pkgver = 5.13.6
pkgrel = 1
url = https://github.com/clearlinux-pkgs/linux
arch = x86_64
@@ -12,22 +12,22 @@ pkgbase = linux-clear
makedepends = libelf
makedepends = xmlto
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.12.tar.xz
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.12.tar.sign
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.12.17.xz
- source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=5.12.16-1054
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.sign
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.13.6.xz
+ source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=5.13.6-1062
source = more-uarches-20210616.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/20210616.tar.gz
source = pci-enable-overrides-for-missing-acs-capabilities.patch
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 7d0df6f2bf2384d68d0bd8e1fe3e071d64364dcdc6002e7b5c87c92d48fac366
+ sha256sums = 3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9
sha256sums = SKIP
- sha256sums = e334769a0947bdca5391168856d422e9f01bb485a7274bbde12c4481aec6036c
+ sha256sums = e83b798bfe22bc9d5e8115cd2bbff24cdf5fd0de1b423a3342985445b02668a8
sha256sums = SKIP
sha256sums = e5b449ef1cd5fef9f24f55250afc2fad85df4fd7371db666f7c7f20eff91c33d
sha256sums = 2c98de0814366b041aeee4cbf82b82620c7834bc33752d50f089e8bd7ea5cf5e
- sha256sums = f3eb1e857f60a96a0c8d4f25f55a64ddf4aa4b3a33e9fcc6886430cf4789cb1c
+ sha256sums = 34614e92ed29d11f5f6150ee8ed6c5ffe7f8f3d99a2fed6aebe40e513749c3ba
pkgname = linux-clear
pkgdesc = The Clear Linux kernel and modules
diff --git a/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch b/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
index 332aa50e5abb..cda2acbc21ed 100644
--- a/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+++ b/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
@@ -1,7 +1,7 @@
-From 1ed48c405ba85328bae25d2f393700ba715a2f81 Mon Sep 17 00:00:00 2001
+From a0a84528e06b99d83046fd16d2fa132c8d20a46c Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Mon, 16 Sep 2019 04:53:20 +0200
-Subject: [PATCH 1/2] ZEN: Add sysctl and CONFIG to disallow unprivileged
+Subject: [PATCH] ZEN: Add sysctl and CONFIG to disallow unprivileged
CLONE_NEWUSER
Our default behavior continues to match the vanilla kernel.
@@ -14,10 +14,10 @@ Our default behavior continues to match the vanilla kernel.
5 files changed, 53 insertions(+)
diff --git a/include/linux/user_namespace.h b/include/linux/user_namespace.h
-index f6c5f784be5a..07d194f23587 100644
+index 1d08dbbcf..180da8f71 100644
--- a/include/linux/user_namespace.h
+++ b/include/linux/user_namespace.h
-@@ -108,6 +108,8 @@ void dec_ucount(struct ucounts *ucounts, enum ucount_type type);
+@@ -112,6 +112,8 @@ void dec_ucount(struct ucounts *ucounts, enum ucount_type type);
#ifdef CONFIG_USER_NS
@@ -26,7 +26,7 @@ index f6c5f784be5a..07d194f23587 100644
static inline struct user_namespace *get_user_ns(struct user_namespace *ns)
{
if (ns)
-@@ -141,6 +143,8 @@ extern bool current_in_userns(const struct user_namespace *target_ns);
+@@ -145,6 +147,8 @@ extern bool current_in_userns(const struct user_namespace *target_ns);
struct ns_common *ns_get_owner(struct ns_common *ns);
#else
@@ -36,10 +36,10 @@ index f6c5f784be5a..07d194f23587 100644
{
return &init_user_ns;
diff --git a/init/Kconfig b/init/Kconfig
-index 5f5c776ef192..afd708ed0241 100644
+index a61c92066..6a2920f2e 100644
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -1177,6 +1177,22 @@ config USER_NS
+@@ -1195,6 +1195,22 @@ config USER_NS
If unsure, say N.
@@ -63,12 +63,12 @@ index 5f5c776ef192..afd708ed0241 100644
bool "PID Namespaces"
default y
diff --git a/kernel/fork.c b/kernel/fork.c
-index 426cd0c51f9e..e83a79860d58 100644
+index a070caed5..03baafd70 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
-@@ -97,6 +97,10 @@
- #include <linux/scs.h>
+@@ -98,6 +98,10 @@
#include <linux/io_uring.h>
+ #include <linux/bpf.h>
+#ifdef CONFIG_USER_NS
+#include <linux/user_namespace.h>
@@ -77,7 +77,7 @@ index 426cd0c51f9e..e83a79860d58 100644
#include <asm/pgalloc.h>
#include <linux/uaccess.h>
#include <asm/mmu_context.h>
-@@ -1872,6 +1876,10 @@ static __latent_entropy struct task_struct *copy_process(
+@@ -1871,6 +1875,10 @@ static __latent_entropy struct task_struct *copy_process(
if ((clone_flags & (CLONE_NEWUSER|CLONE_FS)) == (CLONE_NEWUSER|CLONE_FS))
return ERR_PTR(-EINVAL);
@@ -88,7 +88,7 @@ index 426cd0c51f9e..e83a79860d58 100644
/*
* Thread groups must share signals as well, and detached threads
* can only be started up within the thread group.
-@@ -2971,6 +2979,12 @@ int ksys_unshare(unsigned long unshare_flags)
+@@ -2973,6 +2981,12 @@ int ksys_unshare(unsigned long unshare_flags)
if (unshare_flags & CLONE_NEWNS)
unshare_flags |= CLONE_FS;
@@ -102,7 +102,7 @@ index 426cd0c51f9e..e83a79860d58 100644
if (err)
goto bad_unshare_out;
diff --git a/kernel/sysctl.c b/kernel/sysctl.c
-index 62fbd09b5dc1..01192edd25f3 100644
+index d4a78e08f..0260dfe2d 100644
--- a/kernel/sysctl.c
+++ b/kernel/sysctl.c
@@ -103,6 +103,9 @@
@@ -115,7 +115,7 @@ index 62fbd09b5dc1..01192edd25f3 100644
#if defined(CONFIG_SYSCTL)
-@@ -1902,6 +1905,15 @@ static struct ctl_table kern_table[] = {
+@@ -1896,6 +1899,15 @@ static struct ctl_table kern_table[] = {
.proc_handler = proc_dointvec,
},
#endif
@@ -132,7 +132,7 @@ index 62fbd09b5dc1..01192edd25f3 100644
{
.procname = "tainted",
diff --git a/kernel/user_namespace.c b/kernel/user_namespace.c
-index 9a4b980d695b..4388ca13ea3f 100644
+index 8d6286372..5ca391b2b 100644
--- a/kernel/user_namespace.c
+++ b/kernel/user_namespace.c
@@ -21,6 +21,13 @@
@@ -150,5 +150,5 @@ index 9a4b980d695b..4388ca13ea3f 100644
static DEFINE_MUTEX(userns_state_mutex);
--
-2.31.1
+2.32.0.93.g670b81a890
diff --git a/PKGBUILD b/PKGBUILD
index 04cab932309f..fba1627f3bb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,10 +73,10 @@ _use_current=
### IMPORTANT: Do no edit below this line unless you know what you're doing
-_major=5.12
-_minor=17
+_major=5.13
+_minor=6
_srcname=linux-${_major}
-_clr=${_major}.16-1054
+_clr=${_major}.6-1062
pkgbase=linux-clear
pkgver=${_major}.${_minor}
pkgrel=1
@@ -137,8 +137,7 @@ prepare() {
echo "Enable extra stuff from arch kernel..."
# General setup
- scripts/config --enable IKCONFIG \
- --enable-after IKCONFIG IKCONFIG_PROC \
+ scripts/config --enable IKCONFIG_PROC \
--undefine RT_GROUP_SCHED
# Power management and ACPI options
@@ -147,8 +146,7 @@ prepare() {
# Enable loadable module support
scripts/config --undefine MODULE_SIG_FORCE \
- --enable MODULE_COMPRESS \
- --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ
+ --enable MODULE_COMPRESS_ZSTD
# Networking support
scripts/config --enable NETFILTER_INGRESS
@@ -156,7 +154,6 @@ prepare() {
# Device Drivers
scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
--enable DELL_SMBIOS_SMM \
- --enable NET_VENDOR_AQUANTIA \
--module PATA_JMICRON \
--enable-after SOUND SOUND_OSS_CORE \
--enable SND_OSSEMUL \
@@ -169,12 +166,10 @@ prepare() {
scripts/config --enable SECTION_MISMATCH_WARN_ONLY
# Security options
- scripts/config --enable SECURITY_SELINUX \
- --enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \
- --enable SECURITY_SMACK \
- --enable-after SECURITY_SMACK SECURITY_SMACK_BRINGUP \
- --enable-after SECURITY_SMACK_BRINGUP SECURITY_SMACK_NETFILTER \
- --enable-after SECURITY_SMACK_NETFILTER SECURITY_SMACK_APPEND_SIGNALS \
+ scripts/config --enable SECURITY_SELINUX_BOOTPARAM \
+ --enable SECURITY_SMACK_BRINGUP \
+ --enable SECURITY_SMACK_NETFILTER \
+ --enable SECURITY_SMACK_APPEND_SIGNALS \
--enable SECURITY_TOMOYO \
--enable SECURITY_APPARMOR \
--enable SECURITY_YAMA
@@ -353,13 +348,13 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('7d0df6f2bf2384d68d0bd8e1fe3e071d64364dcdc6002e7b5c87c92d48fac366'
+sha256sums=('3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9'
'SKIP'
- 'e334769a0947bdca5391168856d422e9f01bb485a7274bbde12c4481aec6036c'
+ 'e83b798bfe22bc9d5e8115cd2bbff24cdf5fd0de1b423a3342985445b02668a8'
'SKIP'
'e5b449ef1cd5fef9f24f55250afc2fad85df4fd7371db666f7c7f20eff91c33d'
'2c98de0814366b041aeee4cbf82b82620c7834bc33752d50f089e8bd7ea5cf5e'
- 'f3eb1e857f60a96a0c8d4f25f55a64ddf4aa4b3a33e9fcc6886430cf4789cb1c')
+ '34614e92ed29d11f5f6150ee8ed6c5ffe7f8f3d99a2fed6aebe40e513749c3ba')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds