summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c6978a20b2b..6aa81963d68e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear-lts2018
pkgdesc = Clear Linux lts2018
- pkgver = 4.19.184
+ pkgver = 4.19.185
pkgrel = 1
url = https://github.com/clearlinux-pkgs/linux-lts2018
arch = x86_64
@@ -14,16 +14,16 @@ pkgbase = linux-clear-lts2018
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.sign
- source = https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.19.184.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.19.185.xz
source = linux-clear-lts2018::git+https://github.com/clearlinux-pkgs/linux-lts2018.git#tag=4.19.177-198
- source = enable_additional_cpu_optimizations-20210309.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20210309.tar.gz
+ source = enable_additional_cpu_optimizations-20210327.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20210327.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1
sha256sums = SKIP
- sha256sums = d6f1e5e5770b1710ee7b5d51311b43e598aa450ae9b9c1b166f887fb4e65da29
+ sha256sums = a0e07abdfe0bfa77c33633405f8ee42f82e9698e402ab26f7c76b509ad5c758b
sha256sums = SKIP
- sha256sums = 8fa4ef2c3b392c410c3f74f9b4ab89683b7fca8cac70b96e2bf532a952e46d0b
+ sha256sums = ac0e44bd089eeb7f52d358e6899005599fff50972f090af9c8e6ee0097d01db6
pkgname = linux-clear-lts2018
pkgdesc = The Clear Linux lts2018 kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 177dfb7b5d52..e8df38966c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,9 @@
_makenconfig=
_enable_gcc_more_v="y"
-# Optionally select a sub architecture by number if building in a clean chroot
-# Leaving this entry blank will require user interaction during the build
-# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 32.
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 32.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -45,15 +44,16 @@ _enable_gcc_more_v="y"
# 30. Intel Cooper Lake (MCOOPERLAKE)
# 31. Intel Tiger Lake (MTIGERLAKE)
# 32. Generic-x86-64 (GENERIC_CPU)
-# 33. Native optimizations autodetected by GCC (MNATIVE)
+# 33. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
+# 34. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
_subarch=
-# Compile ONLY used modules to VASTLY reduce the number of modules built
-# and the build time.
+# Only compile active modules to VASTLY reduce the number of modules built and
+# the build time.
#
# To keep track of which modules are needed for your specific system/hardware,
-# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD read the database kept if it exists
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
#
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
@@ -61,7 +61,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
_major=4.19
-_minor=184
+_minor=185
_srcname=linux-${_major}
_clr=${_major}.177-198
pkgbase=linux-clear-lts2018
@@ -73,7 +73,7 @@ url="https://github.com/clearlinux-pkgs/linux-lts2018"
license=('GPL2')
makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
-_gcc_more_v='20210309'
+_gcc_more_v='20210327'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${_major}.tar".{xz,sign}
"https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
@@ -86,6 +86,12 @@ export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
+ # https://bbs.archlinux.org/viewtopic.php?id=265115
+
+ if [[ ! -f "$srcdir/patch-${pkgver}" ]]; then
+ xz -dc "$SRCDEST/patch-${pkgver}.xz" > "patch-${pkgver}"
+ fi
+
cd ${_srcname}
### Add upstream patches
@@ -162,7 +168,7 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/more-uarches-for-gcc-v10-and-kernel-4.19-v5.4.patch"
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/more-uarches-for-kernel-4.19-5.4.patch"
fi
### Get kernel version
@@ -322,9 +328,9 @@ done
sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'SKIP'
- 'd6f1e5e5770b1710ee7b5d51311b43e598aa450ae9b9c1b166f887fb4e65da29'
+ 'a0e07abdfe0bfa77c33633405f8ee42f82e9698e402ab26f7c76b509ad5c758b'
'SKIP'
- '8fa4ef2c3b392c410c3f74f9b4ab89683b7fca8cac70b96e2bf532a952e46d0b')
+ 'ac0e44bd089eeb7f52d358e6899005599fff50972f090af9c8e6ee0097d01db6')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds