summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55cba61c0a68..ae9ec6a0b6e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,6 @@ pkgbase = linux-clear-lts2019
makedepends = bc
makedepends = cpio
makedepends = git
- makedepends = kmod
makedepends = libelf
makedepends = pahole
makedepends = xmlto
@@ -32,7 +31,7 @@ pkgname = linux-clear-lts2019
depends = coreutils
depends = kmod
depends = initramfs
- optdepends = crda: to set the correct wireless channels of your country
+ optdepends = wireless-regdb: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
provides = VIRTUALBOX-GUEST-MODULES
diff --git a/PKGBUILD b/PKGBUILD
index 3c2b5ad9b408..3291b824e40d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,7 +84,7 @@ pkgdesc='Clear Linux lts2019'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2019"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'pahole' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'libelf' 'pahole' 'xmlto')
options=('!strip')
_gcc_more_v='20211114'
source=(
@@ -257,7 +257,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}