summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37e6931181e1..7c1f37985a50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,21 +38,27 @@ _kernelname=${pkgbase#linux}
prepare() {
cd "${srcdir}/linux"
- cp -Tf ../config .config
-
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n
END
+ # mainline: Fix LOCALVERSION
+ touch .scmversion
+
+ # mainline: we have -rcX in EXTRAVERSION, don't touch it
# set extraversion to pkgrel and empty localversion
- sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
- -e "/^EXTRAVERSION =/aLOCALVERSION =" \
- -i Makefile
+ #sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
+ # -e "/^EXTRAVERSION =/aLOCALVERSION =" \
+ # -i Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
+ # mainline: Disabled here, causes make config to run before olddefconfig
+ # get kernel version
+ #make prepare
+
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
@@ -62,6 +68,7 @@ END
make olddefconfig
# ... or manually edit .config
+ # mainline: moved here from before make config
# get kernel version
make prepare