summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--merge-with-testing25
1 files changed, 25 insertions, 0 deletions
diff --git a/merge-with-testing b/merge-with-testing
new file mode 100644
index 000000000000..6bf61e7aba10
--- /dev/null
+++ b/merge-with-testing
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+set -e
+
+if git branch|grep -q merge; then
+ git branch -D merge
+fi
+
+if ! git remote|grep -q arch; then
+ echo "Adding 'arch' remote"
+ git remote add arch git://projects.archlinux.org/svntogit/packages.git
+ git remote set-branches arch packages/linux
+fi
+
+git fetch arch
+git checkout -b merge --no-track arch/packages/linux
+git filter-branch -f --subdirectory-filter trunk/
+grep ^pkgver PKGBUILD
+grep ^pkgrel PKGBUILD
+git checkout master
+
+echo "Automerging configs"
+git checkout merge -- config config.x86_64
+
+echo "All done, you can now do git checkout --patch merge PKGBUILD"