summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch48
-rw-r--r--PKGBUILD16
-rw-r--r--bitmap-enable-booting-for-dm-md-raid1.patch83
4 files changed, 150 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 116692bf193c..2cf6ecb6bd00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-libre
pkgver = 4.1.2_gnu
- pkgrel = 1
+ pkgrel = 2
url = http://linux-libre.fsfla.org/
arch = i686
arch = x86_64
@@ -26,6 +26,8 @@ pkgbase = linux-libre
source = linux.preset
source = 0001-block-loop-convert-to-per-device-workqueue.patch
source = 0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+ source = 0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
+ source = bitmap-enable-booting-for-dm-md-raid1.patch
source = change-default-console-loglevel.patch
sha256sums = 48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324
sha256sums = SKIP
@@ -42,6 +44,8 @@ pkgbase = linux-libre
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f
sha256sums = bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81
+ sha256sums = 08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82
+ sha256sums = 959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
pkgname = linux-libre
diff --git a/0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch b/0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
new file mode 100644
index 000000000000..1d5871606e61
--- /dev/null
+++ b/0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
@@ -0,0 +1,48 @@
+From 7bee8b08c428b63aa4a3765bb907602e36355378 Mon Sep 17 00:00:00 2001
+From: Chris Mason <clm@fb.com>
+Date: Tue, 14 Jul 2015 16:25:30 -0400
+Subject: [PATCH] Bluetooth: btbcm: allow btbcm_read_verbose_config to fail on
+ Apple
+
+Commit 1c8ba6d013 moved around the setup code for broadcomm chips,
+and also added btbcm_read_verbose_config() to read extra information
+about the hardware. It's returning errors on some macbooks:
+
+Bluetooth: hci0: BCM: Read verbose config info failed (-16)
+
+Which makes us error out of the setup function. Since this
+probe isn't critical to operate the chip, this patch just changes
+things to carry on when it fails.
+
+Signed-off-by: Chris Mason <clm@fb.com>
+Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
+Cc: stable@vger.kernel.org # v4.1
+---
+ drivers/bluetooth/btbcm.c | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/drivers/bluetooth/btbcm.c b/drivers/bluetooth/btbcm.c
+index 1e1a432..9ceb8ac 100644
+--- a/drivers/bluetooth/btbcm.c
++++ b/drivers/bluetooth/btbcm.c
+@@ -472,12 +472,11 @@ int btbcm_setup_apple(struct hci_dev *hdev)
+
+ /* Read Verbose Config Version Info */
+ skb = btbcm_read_verbose_config(hdev);
+- if (IS_ERR(skb))
+- return PTR_ERR(skb);
+-
+- BT_INFO("%s: BCM: chip id %u build %4.4u", hdev->name, skb->data[1],
+- get_unaligned_le16(skb->data + 5));
+- kfree_skb(skb);
++ if (!IS_ERR(skb)) {
++ BT_INFO("%s: BCM: chip id %u build %4.4u", hdev->name, skb->data[1],
++ get_unaligned_le16(skb->data + 5));
++ kfree_skb(skb);
++ }
+
+ set_bit(HCI_QUIRK_STRICT_DUPLICATE_FILTER, &hdev->quirks);
+
+--
+2.4.5
+
diff --git a/PKGBUILD b/PKGBUILD
index f7b9b53ea9dd..3db72f1b3efe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _replacesoldmodules=('linux-libre%-kmod-alx') # '%' gets replaced with _kernelna
_srcname=linux-${_pkgbasever%-*}
_archpkgver=${_pkgver%-*}
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -40,6 +40,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'linux.preset'
'0001-block-loop-convert-to-per-device-workqueue.patch'
'0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch'
+ '0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch'
+ 'bitmap-enable-booting-for-dm-md-raid1.patch'
'change-default-console-loglevel.patch')
sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
@@ -56,10 +58,11 @@ sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f'
'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81'
+ '08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82'
+ '959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
- 'C92BAA713B8D53D3CAE63FC9E6974752F9704456' # André Silva
'684D54A189305A9CC95446D36B888913DDB59515' # Márcio Silva
)
@@ -92,6 +95,15 @@ prepare() {
patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+ # Fix bluetooth chip initialization on some macbooks (FS#45554)
+ # http://marc.info/?l=linux-bluetooth&m=143690738728402&w=2
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100651
+ patch -Np1 -i ../0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
+
+ # Fix kernel oops when booting with root on RAID1 LVM (FS#45548)
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100491#c24
+ patch -Np1 -i ../bitmap-enable-booting-for-dm-md-raid1.patch
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
diff --git a/bitmap-enable-booting-for-dm-md-raid1.patch b/bitmap-enable-booting-for-dm-md-raid1.patch
new file mode 100644
index 000000000000..7b29e82f7304
--- /dev/null
+++ b/bitmap-enable-booting-for-dm-md-raid1.patch
@@ -0,0 +1,83 @@
+Subject: [PATCH] Enable loading of bitmaps for dm-md-raid1.
+
+This is also a temporary hack to systems with junk in the rest
+of the bitmap super (instead of zeroes) to boot. This is done by
+checking mddev->sync_super (which is exclusively set by dm-raid)
+is null.
+
+These changes also include zeroing of most bitmap pages while
+allocating so we are sure that the junk is not coming from memory.
+
+Signed-off-by: Neil Brown <neilb@suse.de>
+Signed-off-by: Goldwyn Rodrigues <rgoldwyn@suse.com>
+---
+diff --git a/drivers/md/bitmap.c b/drivers/md/bitmap.c
+index 135a090..dfa5ef3 100644
+--- a/drivers/md/bitmap.c
++++ b/drivers/md/bitmap.c
+@@ -494,7 +494,7 @@ static int bitmap_new_disk_sb(struct bitmap *bitmap)
+ bitmap_super_t *sb;
+ unsigned long chunksize, daemon_sleep, write_behind;
+
+- bitmap->storage.sb_page = alloc_page(GFP_KERNEL);
++ bitmap->storage.sb_page = alloc_page(GFP_KERNEL | __GFP_ZERO);
+ if (bitmap->storage.sb_page == NULL)
+ return -ENOMEM;
+ bitmap->storage.sb_page->index = 0;
+@@ -541,6 +541,7 @@ static int bitmap_new_disk_sb(struct bitmap *bitmap)
+ sb->state = cpu_to_le32(bitmap->flags);
+ bitmap->events_cleared = bitmap->mddev->events;
+ sb->events_cleared = cpu_to_le64(bitmap->mddev->events);
++ bitmap->mddev->bitmap_info.nodes = 0;
+
+ kunmap_atomic(sb);
+
+@@ -568,7 +569,7 @@ static int bitmap_read_sb(struct bitmap *bitmap)
+ goto out_no_sb;
+ }
+ /* page 0 is the superblock, read it... */
+- sb_page = alloc_page(GFP_KERNEL);
++ sb_page = alloc_page(GFP_KERNEL | __GFP_ZERO);
+ if (!sb_page)
+ return -ENOMEM;
+ bitmap->storage.sb_page = sb_page;
+@@ -611,8 +612,15 @@ re_read:
+ daemon_sleep = le32_to_cpu(sb->daemon_sleep) * HZ;
+ write_behind = le32_to_cpu(sb->write_behind);
+ sectors_reserved = le32_to_cpu(sb->sectors_reserved);
+- nodes = le32_to_cpu(sb->nodes);
+- strlcpy(bitmap->mddev->bitmap_info.cluster_name, sb->cluster_name, 64);
++ /* XXX: This is an ugly hack to ensure that we don't use clustering
++ in case dm-raid is in use and the nodes written in bitmap_sb
++ is erroneous.
++ */
++ if (!bitmap->mddev->sync_super) {
++ nodes = le32_to_cpu(sb->nodes);
++ strlcpy(bitmap->mddev->bitmap_info.cluster_name,
++ sb->cluster_name, 64);
++ }
+
+ /* verify that the bitmap-specific fields are valid */
+ if (sb->magic != cpu_to_le32(BITMAP_MAGIC))
+@@ -649,7 +657,7 @@ re_read:
+ goto out;
+ }
+ events = le64_to_cpu(sb->events);
+- if (!nodes && (events < bitmap->mddev->events)) {
++ if (err == 0 && !nodes && (events < bitmap->mddev->events)) {
+ printk(KERN_INFO
+ "%s: bitmap file is out of date (%llu < %llu) "
+ "-- forcing full recovery\n",
+diff --git a/drivers/md/md.c b/drivers/md/md.c
+index 4dbed4a..6bd8bc3 100644
+--- a/drivers/md/md.c
++++ b/drivers/md/md.c
+@@ -7415,7 +7415,7 @@ int md_setup_cluster(struct mddev *mddev, int nodes)
+ err = request_module("md-cluster");
+ if (err) {
+ pr_err("md-cluster module not found.\n");
+- return err;
++ return -ENOENT;
+ }
+
+ spin_lock(&pers_lock);