aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
-rw-r--r--UPDATING23
2 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbd25cc1f4ca..04e65e63fce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ replaces=(kernel26 linux)
backup=(etc/mkinitcpio.d/${pkgname}.preset boot/grub/menu.lst)
install=${pkgname}.install
-build() {
+prepare() {
cd "${srcdir}/${_srcname}"
patch -p1 -i "${srcdir}/patch-${pkgver}"
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
@@ -45,7 +45,9 @@ build() {
sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|g" ./.config
sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
make prepare
-# msg "Stopping build"; return 1
+}
+
+build() {
CFLAGS=${CFLAGS}" -march=corei7 -mtune=corei7 -mcpu=corei7 "
CXXFLAGS=${CXXFLAGS}" -march=corei7 -mtune=corei7 -mcpu=corei7 "
ionice -c 3 nice -n 19 make ${MAKEFLAGS} LOCALVERSION= bzImage modules
diff --git a/UPDATING b/UPDATING
index 0eae9e20788c..7eea80a33492 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,20 +5,16 @@
# Don't actually run this as a shell script - it's part pseudocode
exit
-# Check https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
-# Bump pkgver, pkgrel
-# Sync any new PKGBUILD logic, important patches, configs or other changes
-
# Cleans things up
makepkg -oecd
-# uncomment "return 1"
-sed -i 's/^[#]*\s*\(return\s*1\)$/\1/ig' PKGBUILD
-
-# sources are ready
-makepkg -cd
+# Check https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
+# Bump pkgver, pkgrel
+# Sync any new PKGBUILD logic, important patches, configs or other changes
+# update hashes
-# will probably fail for hashes, reset hashes & redo
+# prepare sources
+makepkg -o
# may prompt for oldconfig
@@ -34,6 +30,7 @@ diff ../../config.x86_64 .config
cd ../..
cp src/linux-${pkgver}/.config config.x86_64
-# update md5s
-# re-comment "return 1"
-sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
+# update md5s + git
+
+# finally:
+makepkg -c