aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 468f0bf3df8e..0d4b796285c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-linode
pkgdesc = Kernel for Linode servers
- pkgver = 4.0.5
+ pkgver = 4.1.0
pkgrel = 1
url = https://github.com/yardenac/linux-linode
install = install
@@ -23,17 +23,13 @@ pkgbase = linux-linode
options = !strip
backup = etc/mkinitcpio.d/linux-linode.preset
backup = boot/grub/menu.lst
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.0.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.0.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.0.5.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.0.5.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.sign
source = config
source = config.x86_64
source = menu.lst
source = preset
- sha512sums = ce13d2c1c17908fd9a4aa42bb6348a0cb13dd22e560bd54c61b8bfdf62726d6095f130c59177a2fe4793b7dc399481bf10d3556d1d571616000f180304e5a995
- sha512sums = SKIP
- sha512sums = 377371371752eb706053282ee296f82b3af0c3cf84c346091b1e347c8d00fcf6787c5b51c76955af3f61e9c20c30035b110368ee3ba2587871f0dbc92826de32
+ sha512sums = 168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0
sha512sums = SKIP
sha512sums = 33c4a5e9f2890c6f22654ba98775e03dbc2b5b6977cfed272a1fe37c0b387d5776b6103a11d4ca8077ff513e24841be29d79b1ef2387a3d3a9ebc45230d3a705
sha512sums = 916c923b346bf2897bc27a021384f095125451bd2186b55915a895442c4f7665e9c5d6af119c5ff0cd269d21668cd165afb924bd2a295d803a98e5dffa52ce0a
diff --git a/PKGBUILD b/PKGBUILD
index ffef347ae63c..7fb6a4d611d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# tracks: https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
pkgname=linux-linode
-_basekernel=4.0
+_basekernel=4.1
_kernelname=${pkgname#linux}
_srcname=linux-${_basekernel}
-pkgver=${_basekernel}.5
+pkgver=${_basekernel}.0
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/yardenac/linux-linode"
@@ -13,13 +13,12 @@ license=(GPL2)
makedepends=(xmlto docbook-xsl kmod inetutils bc 'gcc>=4.9.0')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar."{xz,sign}
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}."{xz,sign}
+# "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}."{xz,sign}
'config'
'config.x86_64'
'menu.lst'
'preset')
-sha512sums=('ce13d2c1c17908fd9a4aa42bb6348a0cb13dd22e560bd54c61b8bfdf62726d6095f130c59177a2fe4793b7dc399481bf10d3556d1d571616000f180304e5a995' 'SKIP'
- '377371371752eb706053282ee296f82b3af0c3cf84c346091b1e347c8d00fcf6787c5b51c76955af3f61e9c20c30035b110368ee3ba2587871f0dbc92826de32' 'SKIP'
+sha512sums=('168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0' 'SKIP'
'33c4a5e9f2890c6f22654ba98775e03dbc2b5b6977cfed272a1fe37c0b387d5776b6103a11d4ca8077ff513e24841be29d79b1ef2387a3d3a9ebc45230d3a705'
'916c923b346bf2897bc27a021384f095125451bd2186b55915a895442c4f7665e9c5d6af119c5ff0cd269d21668cd165afb924bd2a295d803a98e5dffa52ce0a'
'810e1e1cd67b172f29db6c1a3caed8050bb3ff86db1d49abcebd76b5ea70622deefb587cc914d1819df78525ce433564f71533822244a286373fc0f7605e6dde'
@@ -37,7 +36,7 @@ install=install
prepare() {
cd "${srcdir}/${_srcname}"
- patch -p1 -i "${srcdir}/patch-${pkgver}"
+# patch -p1 -i "${srcdir}/patch-${pkgver}"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else