summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4e12bd821fb..0726a432ef6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -210,6 +210,10 @@ prepare() {
fi
fi
+ ## Use DWARF5 debug info for Arch
+ echo "Upgrading debug info from toolchain default to DWARF v5..."
+ scripts/config -e CONFIG_DEBUG_INFO_DWARF5
+
### Running make nconfig
[[ -z "$_makenconfig" ]] || make nconfig
@@ -281,6 +285,10 @@ _package-headers() {
# required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids \
+ || true
+
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include