summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86f8ec7083b2..4936c8b9677c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-macbook
- pkgver = 4.7.5
+ pkgver = 4.7.6
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -14,8 +14,8 @@ pkgbase = linux-macbook
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.7.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.7.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.7.5.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.7.5.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.7.6.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.7.6.sign
source = config
source = config.x86_64
source = linux-macbook.preset
@@ -28,7 +28,7 @@ pkgbase = linux-macbook
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 5190c3d1209aeda04168145bf50569dc0984f80467159b1dc50ad731e3285f10
sha256sums = SKIP
- sha256sums = 46be737415406fd06c1067d1280a4a435f8b0a76d70f5d31858964b41367cc8e
+ sha256sums = 2e425c268076c3b186107edf9045e0910088699e077282b5187efb5edf2b8836
sha256sums = SKIP
sha256sums = 55083afe584da6218b7db9ce1b7c3c20aef6f31f8c55b53864bcf7d45eb81b26
sha256sums = 64e99c3339734f7d58e390d71a4dde706640cb0bca857ac4e637b962d50a010d
@@ -52,12 +52,12 @@ pkgname = linux-macbook
pkgname = linux-macbook-headers
pkgdesc = Header files and scripts for building modules for Linux-macbook kernel (with brightness key and suspend patches)
depends = linux-macbook
- provides = linux-macbook-headers=4.7.5
- provides = linux-headers=4.7.5
+ provides = linux-macbook-headers=4.7.6
+ provides = linux-headers=4.7.6
pkgname = linux-macbook-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-macbook kernel (with brightness key and suspend patches)
depends = linux-macbook
- provides = linux-macbook-docs=4.7.5
- provides = linux-docs=4.7.5
+ provides = linux-macbook-docs=4.7.6
+ provides = linux-docs=4.7.6
diff --git a/PKGBUILD b/PKGBUILD
index 065698c5a3ec..c510bbc791bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=linux-macbook # Build kernel with a different name
_kernelname=-macbook
_srcname=linux-4.7
-pkgver=4.7.5
+pkgver=4.7.6
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -29,7 +29,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
sha256sums=('5190c3d1209aeda04168145bf50569dc0984f80467159b1dc50ad731e3285f10'
'SKIP'
- '46be737415406fd06c1067d1280a4a435f8b0a76d70f5d31858964b41367cc8e'
+ '2e425c268076c3b186107edf9045e0910088699e077282b5187efb5edf2b8836'
'SKIP'
'55083afe584da6218b7db9ce1b7c3c20aef6f31f8c55b53864bcf7d45eb81b26'
'64e99c3339734f7d58e390d71a4dde706640cb0bca857ac4e637b962d50a010d'
@@ -159,7 +159,7 @@ _package() {
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# add vmlinux
- install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+ install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
}
_package-headers() {
@@ -264,7 +264,7 @@ _package-headers() {
# add objtool for external module building and enabled VALIDATION_STACK option
if [ -f tools/objtool/objtool ]; then
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool"
- cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
+ cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
fi
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
@@ -284,7 +284,7 @@ _package-headers() {
# remove unneeded architectures
rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
-
+
# remove a files already in linux-docs package
rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-01"
rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-02"