summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD11
-rw-r--r--linux-macbook.install4
-rw-r--r--macbook-wakeup.service13
4 files changed, 34 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40bda04afa97..72ed1303cedb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-macbook
- pkgver = 4.8.13
+ pkgver = 4.8.14
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -14,10 +14,11 @@ pkgbase = linux-macbook
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.8.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.8.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.8.13.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.8.13.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.8.14.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.8.14.sign
source = config
source = config.x86_64
+ source = macbook-wakeup.service
source = linux-macbook.preset
source = apple-gmux.patch
source = macbook-suspend.patch
@@ -28,10 +29,11 @@ pkgbase = linux-macbook
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 3e9150065f193d3d94bcf46a1fe9f033c7ef7122ab71d75a7fb5a2f0c9a7e11a
sha256sums = SKIP
- sha256sums = f0e2f7f738e1a639956e01ba7ef8d3df40ecb5c7586eb366bcd4af70049a7a3c
+ sha256sums = efa9b7d87a6ca67426e3d7f206ac987eb7cb31602ad2011e81060626de790fcb
sha256sums = SKIP
sha256sums = 1e72cd2e9e1fa8bf1478f7a7d9b9719d1fd2d1754dbe915a6b6d7e0d0a92da0a
sha256sums = 8646ab1d39f1755de240a27dd1970be39b8b81b1f1caca0dd77c0a4b157292d9
+ sha256sums = 72f0b3ce04f33dfae305297bd045fba8cb5e5c8594ffd7a68a4d8ed293b1b1b5
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = bb8af32880059e681396a250d8e78f600f248da8ad4f0e76d7923badb5ee8b42
sha256sums = 4d4a622733c2ba742256f369c32a1e98fc216966589f260c7457d299dbb55971
@@ -52,12 +54,12 @@ pkgname = linux-macbook
pkgname = linux-macbook-headers
pkgdesc = Header files and scripts for building modules for Linux-macbook kernel (with brightness key and suspend patches)
depends = linux-macbook
- provides = linux-macbook-headers=4.8.13
- provides = linux-headers=4.8.13
+ provides = linux-macbook-headers=4.8.14
+ provides = linux-headers=4.8.14
pkgname = linux-macbook-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-macbook kernel (with brightness key and suspend patches)
depends = linux-macbook
- provides = linux-macbook-docs=4.8.13
- provides = linux-docs=4.8.13
+ provides = linux-macbook-docs=4.8.14
+ provides = linux-docs=4.8.14
diff --git a/PKGBUILD b/PKGBUILD
index 2027667b55f2..2897876a721a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=linux-macbook # Build kernel with a different name
_kernelname=-macbook
_srcname=linux-4.8
-pkgver=4.8.13
+pkgver=4.8.14
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -19,6 +19,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
+ # service file for suspend/resume events
+ 'macbook-wakeup.service'
# standard config files for mkinitcpio ramdisk
'linux-macbook.preset'
'apple-gmux.patch'
@@ -29,10 +31,11 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
sha256sums=('3e9150065f193d3d94bcf46a1fe9f033c7ef7122ab71d75a7fb5a2f0c9a7e11a'
'SKIP'
- 'f0e2f7f738e1a639956e01ba7ef8d3df40ecb5c7586eb366bcd4af70049a7a3c'
+ 'efa9b7d87a6ca67426e3d7f206ac987eb7cb31602ad2011e81060626de790fcb'
'SKIP'
'1e72cd2e9e1fa8bf1478f7a7d9b9719d1fd2d1754dbe915a6b6d7e0d0a92da0a'
'8646ab1d39f1755de240a27dd1970be39b8b81b1f1caca0dd77c0a4b157292d9'
+ '72f0b3ce04f33dfae305297bd045fba8cb5e5c8594ffd7a68a4d8ed293b1b1b5'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'bb8af32880059e681396a250d8e78f600f248da8ad4f0e76d7923badb5ee8b42'
'4d4a622733c2ba742256f369c32a1e98fc216966589f260c7457d299dbb55971'
@@ -160,6 +163,10 @@ _package() {
# add vmlinux
install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+
+ # install macbook-wakeup.service
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ install -D -m644 "${srcdir}/macbook-wakeup.service" "${pkgdir}/usr/lib/systemd/system/macbook-wakeup.service"
}
_package-headers() {
diff --git a/linux-macbook.install b/linux-macbook.install
index 475462b7d987..818e0fe587d8 100644
--- a/linux-macbook.install
+++ b/linux-macbook.install
@@ -14,8 +14,8 @@ cat <<-EOF
in /etc/default/grub and then ran the following command as root:
grub-mkconfig -o /boot/grub/grub.cfg
- Create /etc/tmpfiles.d/wakeup.conf with the contents:
- w /proc/acpi/wakeup - - - - LID0
+ Enable the macbook-wakeup service for suspend/resume on LID events:
+ systemctl enable --now macbook-wakeup.service
EOF
}
diff --git a/macbook-wakeup.service b/macbook-wakeup.service
new file mode 100644
index 000000000000..48ac5f514dd9
--- /dev/null
+++ b/macbook-wakeup.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Configure device events for linux-macbook
+ConditionPathExists=/proc/acpi/wakeup
+
+[Service]
+Type=oneshot
+ExecStart=/bin/sh -c "awk '$1 !~ /^LID/ && $3 ~ /enabled/ {print $1}' /proc/acpi/wakeup | xargs -I{} echo '{}' > /proc/acpi/wakeup"
+ExecStart=/bin/sh -c "awk '$1 ~ /^LID/ && $3 ~ /disabled/ {print $1}' /proc/acpi/wakeup | xargs -I{} echo '{}' > /proc/acpi/wakeup"
+RemainAfterExit=yes
+TimeoutSec=0
+
+[Install]
+WantedBy=multi-user.target