summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--linux.install15
3 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78a0991c59ea..e0c59c734f72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-macbook
pkgver = 4.18.11.arch1
- pkgrel = 1
+ pkgrel = 2
url = https://git.archlinux.org/linux.git/log/?h=v4.18.11-arch1
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 09a64ace1e24..82c7ac72d01b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=linux-macbook # Build kernel with a different name
_srcver=4.18.11-arch1
pkgver=${_srcver//-/.}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
diff --git a/linux.install b/linux.install
index 37ba37494605..c8e5a68d75ba 100644
--- a/linux.install
+++ b/linux.install
@@ -1,7 +1,22 @@
+display_requirements () {
+cat <<-EOF
+
+ To get suspend working properly you must do the following:
+
+ Enable the macbook-wakeup service for suspend/resume on LID events:
+ systemctl enable --now macbook-wakeup.service
+
+ Optionally, include the kernel boot option processor.ignore_ppc=1
+ to allow frequency changing on battery power.
+
+EOF
+}
+
post_upgrade() {
if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
echo "WARNING: /boot appears to be a separate partition but is not mounted."
fi
+ display_requirements
}
post_remove() {