summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 155e2b383dd3..fff80983945b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-mainline-bootsplash
pkgdesc = Linux Mainline - with bootsplash support
pkgver = 5.8rc7
- pkgrel = 3
+ pkgrel = 4
url = https://kernel.org/
arch = x86_64
license = GPL2
@@ -69,3 +69,6 @@ pkgname = linux-mainline-bootsplash
pkgname = linux-mainline-bootsplash-headers
pkgdesc = Headers and scripts for building modules for the Linux Mainline - with bootsplash support kernel
+pkgname = linux-mainline-bootsplash-docs
+ pkgdesc = Documentation for the Linux Mainline - with bootsplash support kernel
+
diff --git a/PKGBUILD b/PKGBUILD
index bd0b40e66ac9..625c99ac7716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=linux-mainline-bootsplash # Build kernel with a different name
_tag=v5.8-rc7
pkgver=5.8rc7
-pkgrel=3
+pkgrel=4
pkgdesc="Linux Mainline - with bootsplash support"
arch=(x86_64)
url="https://kernel.org/"
@@ -95,6 +95,7 @@ prepare() {
build() {
cd $_srcname
make all
+ make htmldocs
}
_package() {
@@ -221,7 +222,7 @@ _package-docs() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=("$pkgbase" "$pkgbase-headers")
+pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")