summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 2 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73d3e822b01d..9c91f0ae8ba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -71,6 +71,3 @@ pkgname = linux-mainline-bootsplash
pkgname = linux-mainline-bootsplash-headers
pkgdesc = Headers and scripts for building modules for the Linux Mainline - with bootsplash support kernel
-pkgname = linux-mainline-bootsplash-docs
- pkgdesc = Documentation for the Linux Mainline - with bootsplash support kernel
-
diff --git a/PKGBUILD b/PKGBUILD
index 52e7595f61bd..4eacdc8f5edb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -88,7 +88,7 @@ prepare() {
echo "Setting config..."
cp ../config .config
- make olddefconfig
+ make localmodconfig
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -97,7 +97,6 @@ prepare() {
build() {
cd $_srcname
make all
- make htmldocs
}
_package() {
@@ -224,7 +223,7 @@ _package-docs() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")