summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD2
-rw-r--r--v0-ASoC-cs35l41-CSC3551.patch13
4 files changed, 18 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0728977e14bc..71762aaa8928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,6 +23,7 @@ pkgbase = linux-mainline-um5302ta
source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v5.19-rc4
source = config
source = v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+ source = v0-ASoC-cs35l41-CSC3551.patch
source = v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
@@ -30,6 +31,7 @@ pkgbase = linux-mainline-um5302ta
sha256sums = SKIP
sha256sums = 382aa201a6a6939210dd8668ab052724547b4bd489b38e97502bbd0848061b35
sha256sums = a78e1868cfcaa34d5e5c8e16f2072e54966798664e5148a804579819ef965814
+ sha256sums = 66ecbd41168b1fb7fe8c8bba8a374456130aeceb64df2708d62f7ac3e700df1f
sha256sums = 5212ffc69ba29c5b29365849e8bdb621c8cadac4025de5a503f55af923f123f0
pkgname = linux-mainline-um5302ta
diff --git a/.gitignore b/.gitignore
index 953619cbf014..edcdabfce317 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,5 @@
!/.SRCINFO
!/config
!/v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+!/v0-ASoC-cs35l41-CSC3551.patch
!/v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2a67128621be..b9d0151704d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ source=(
"$_srcname::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=$_srctag"
config # the main kernel config file
v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+ v0-ASoC-cs35l41-CSC3551.patch
v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
)
validpgpkeys=(
@@ -30,6 +31,7 @@ validpgpkeys=(
sha256sums=('SKIP'
'382aa201a6a6939210dd8668ab052724547b4bd489b38e97502bbd0848061b35'
'a78e1868cfcaa34d5e5c8e16f2072e54966798664e5148a804579819ef965814'
+ '66ecbd41168b1fb7fe8c8bba8a374456130aeceb64df2708d62f7ac3e700df1f'
'5212ffc69ba29c5b29365849e8bdb621c8cadac4025de5a503f55af923f123f0')
export KBUILD_BUILD_HOST=archlinux
diff --git a/v0-ASoC-cs35l41-CSC3551.patch b/v0-ASoC-cs35l41-CSC3551.patch
new file mode 100644
index 000000000000..df20d15b5195
--- /dev/null
+++ b/v0-ASoC-cs35l41-CSC3551.patch
@@ -0,0 +1,13 @@
+diff --git a/sound/pci/hda/cs35l41_hda.c b/sound/pci/hda/cs35l41_hda.c
+index cce27a86267f..7374565ecf15 100644
+--- a/sound/pci/hda/cs35l41_hda.c
++++ b/sound/pci/hda/cs35l41_hda.c
+@@ -420,7 +420,7 @@ static int cs35l41_hda_read_acpi(struct cs35l41_hda *cs35l41, const char *hid, i
+ * And devm functions expect that the device requesting the resource has the correct
+ * fwnode.
+ */
+- if (strncmp(hid, "CLSA0100", 8) != 0)
++ if (strncmp(hid, "CLSA0100", 8) != 0 && strncmp(hid, "CSC3551", 7) != 0)
+ return -EINVAL;
+
+ /* check I2C address to assign the index */