summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--cs35l42-hda-no-acpi-dsd-csc3551.patch14
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d6635329493..45a08c5096b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-mainline-um5302ta
pkgdesc = Linux
pkgver = 6.1rc3
- pkgrel = 1
+ pkgrel = 2
url = https://git.kernel.org/torvalds/h/v6.1-rc3
arch = x86_64
license = GPL2
@@ -30,7 +30,7 @@ pkgbase = linux-mainline-um5302ta
sha256sums = SKIP
sha256sums = 05168cbbeb6378eec6c84fe3300cede4fa5cf6130c39fb8af95040529bd390a6
sha256sums = 1391b24a25148c3f1a60867d2f805f85c3dd201ffd0293b66d1ac892da20d910
- sha256sums = 405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82
+ sha256sums = e2613a7336bd01a2727ca2fc37e1000be6e9d30632aec56eff334e3f7b23e487
pkgname = linux-mainline-um5302ta
pkgdesc = The Linux kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index d75a279ed3a3..661172efb78c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-mainline-um5302ta
pkgver=6.1rc3
-pkgrel=1
+pkgrel=2
pkgdesc='Linux'
_srctag=v6.1-rc3
url="https://git.kernel.org/torvalds/h/$_srctag"
@@ -30,7 +30,7 @@ validpgpkeys=(
sha256sums=('SKIP'
'05168cbbeb6378eec6c84fe3300cede4fa5cf6130c39fb8af95040529bd390a6'
'1391b24a25148c3f1a60867d2f805f85c3dd201ffd0293b66d1ac892da20d910'
- '405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82')
+ 'e2613a7336bd01a2727ca2fc37e1000be6e9d30632aec56eff334e3f7b23e487')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/cs35l42-hda-no-acpi-dsd-csc3551.patch b/cs35l42-hda-no-acpi-dsd-csc3551.patch
index b512b6254e17..be3b6ff2eb71 100644
--- a/cs35l42-hda-no-acpi-dsd-csc3551.patch
+++ b/cs35l42-hda-no-acpi-dsd-csc3551.patch
@@ -1,13 +1,13 @@
diff --git a/sound/pci/hda/cs35l41_hda.c b/sound/pci/hda/cs35l41_hda.c
-index 129bffb431c2..ca3f53bba93d 100644
+index e5f0549bf06d..3917f398334d 100644
--- a/sound/pci/hda/cs35l41_hda.c
+++ b/sound/pci/hda/cs35l41_hda.c
-@@ -1156,7 +1156,7 @@ static int cs35l41_no_acpi_dsd(struct cs35l41_hda *cs35l41, struct device *physd
- hw_cfg->valid = true;
- put_device(physdev);
+@@ -1231,7 +1231,7 @@ static int cs35l41_no_acpi_dsd(struct cs35l41_hda *cs35l41, struct device *physd
-- if (strncmp(hid, "CLSA0100", 8) == 0) {
-+ if (strncmp(hid, "CLSA0100", 8) == 0 || strncmp(hid, "CSC3551", 7) == 0) {
+ if (strncmp(hid, "CLSA0100", 8) == 0) {
hw_cfg->bst_type = CS35L41_EXT_BOOST_NO_VSPK_SWITCH;
- } else if (strncmp(hid, "CLSA0101", 8) == 0) {
+- } else if (strncmp(hid, "CLSA0101", 8) == 0) {
++ } else if (strncmp(hid, "CLSA0101", 8) == 0 || strncmp(hid, "CSC3551", 7) == 0) {
hw_cfg->bst_type = CS35L41_EXT_BOOST;
+ hw_cfg->gpio1.func = CS35l41_VSPK_SWITCH;
+ hw_cfg->gpio1.valid = true;