summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch39
-rw-r--r--PKGBUILD12
-rw-r--r--acp6x-um5302ta-quirk.patch18
-rw-r--r--config5
-rw-r--r--patch-realtek-um5302ta-quirk.patch10
7 files changed, 60 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9282db6ec24b..77e4a8f60441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = linux-mainline-um5302ta
pkgdesc = Linux
- pkgver = 6.0rc5
+ pkgver = 6.0rc7
pkgrel = 2
- url = https://git.kernel.org/torvalds/h/v6.0-rc5
+ url = https://git.kernel.org/torvalds/h/v6.0-rc7
arch = x86_64
license = GPL2
makedepends = bc
@@ -20,19 +20,19 @@ pkgbase = linux-mainline-um5302ta
makedepends = texlive-latexextra
makedepends = git
options = !strip
- source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.0-rc5
+ source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.0-rc7
source = config
source = cs35l42-hda-no-acpi-dsd-csc3551.patch
source = patch-realtek-um5302ta-quirk.patch
- source = acp6x-um5302ta-quirk.patch
+ source = ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
- sha256sums = ec58b63109b23d318af62b48a4f43e3042ddb45e71060c885d5d03f2cb3760b0
+ sha256sums = 1e07bdd94abe73ac2074b151729cd9b73c7fa7a615a3a331a89dcb0da42649f8
sha256sums = 405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82
- sha256sums = 132ece1b42f359fcbb4c97e96615747d34355f2f682efe744257f3310de77a98
- sha256sums = 25ec00e28f43db69b60714b749d12a482d8a47c8fce5bec04b64da2abd8948c6
+ sha256sums = 9bb8bba7e33aa57b54f855d9dd788e9aa63e8c01526454694438cbaa22b1b7c5
+ sha256sums = c5e4e17c3e265710325d2af16bb1ba3b4a6e22f10677fef79ce7a22f91596bda
pkgname = linux-mainline-um5302ta
pkgdesc = The Linux kernel and modules
diff --git a/.gitignore b/.gitignore
index 4f35281305ce..411fe5757a11 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@
!/config
!/cs35l42-hda-no-acpi-dsd-csc3551.patch
!/patch-realtek-um5302ta-quirk.patch
-!/acp6x-um5302ta-quirk.patch
+!/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
diff --git a/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch b/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
new file mode 100644
index 000000000000..0edafd25276f
--- /dev/null
+++ b/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
@@ -0,0 +1,39 @@
+From 4df5b13dec9e1b5a12db47ee92eb3f7da5c3deb5 Mon Sep 17 00:00:00 2001
+From: Xiaoyan Li <lxy.lixiaoyan@gmail.com>
+Date: Tue, 20 Sep 2022 15:14:34 -0500
+Subject: ASoC: amd: yc: Add ASUS UM5302TA into DMI table
+
+ASUS Zenbook S 13 OLED (UM5302TA) needs this quirk to get the built-in
+microphone working properly.
+
+Link: https://bugzilla.kernel.org/show_bug.cgi?id=216270
+Signed-off-by: Xiaoyan Li <lxy.lixiaoyan@gmail.com>
+Suggested-by: Mario Limonciello <mario.limonciello@amd.com>
+Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>
+Signed-off-by: Mario Limonciello <mario.limonciello@amd.com>
+Link: https://lore.kernel.org/r/20220920201436.19734-2-mario.limonciello@amd.com
+Signed-off-by: Mark Brown <broonie@kernel.org>
+---
+ sound/soc/amd/yc/acp6x-mach.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/sound/soc/amd/yc/acp6x-mach.c b/sound/soc/amd/yc/acp6x-mach.c
+index e0b24e1daef3d..5eab3baf3573d 100644
+--- a/sound/soc/amd/yc/acp6x-mach.c
++++ b/sound/soc/amd/yc/acp6x-mach.c
+@@ -171,6 +171,13 @@ static const struct dmi_system_id yc_acp_quirk_table[] = {
+ DMI_MATCH(DMI_PRODUCT_NAME, "21J6"),
+ }
+ },
++ {
++ .driver_data = &acp6x_card,
++ .matches = {
++ DMI_MATCH(DMI_BOARD_VENDOR, "ASUSTeK COMPUTER INC."),
++ DMI_MATCH(DMI_PRODUCT_NAME, "UM5302TA"),
++ }
++ },
+ {}
+ };
+
+--
+cgit
diff --git a/PKGBUILD b/PKGBUILD
index 277fc559694f..1cff9fbba437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-mainline-um5302ta
-pkgver=6.0rc5
+pkgver=6.0rc7
pkgrel=2
pkgdesc='Linux'
-_srctag=v6.0-rc5
+_srctag=v6.0-rc7
url="https://git.kernel.org/torvalds/h/$_srctag"
arch=(x86_64)
license=(GPL2)
@@ -21,7 +21,7 @@ source=(
config # the main kernel config file
cs35l42-hda-no-acpi-dsd-csc3551.patch
patch-realtek-um5302ta-quirk.patch
- acp6x-um5302ta-quirk.patch
+ ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -29,10 +29,10 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'ec58b63109b23d318af62b48a4f43e3042ddb45e71060c885d5d03f2cb3760b0'
+ '1e07bdd94abe73ac2074b151729cd9b73c7fa7a615a3a331a89dcb0da42649f8'
'405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82'
- '132ece1b42f359fcbb4c97e96615747d34355f2f682efe744257f3310de77a98'
- '25ec00e28f43db69b60714b749d12a482d8a47c8fce5bec04b64da2abd8948c6')
+ '9bb8bba7e33aa57b54f855d9dd788e9aa63e8c01526454694438cbaa22b1b7c5'
+ 'c5e4e17c3e265710325d2af16bb1ba3b4a6e22f10677fef79ce7a22f91596bda')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/acp6x-um5302ta-quirk.patch b/acp6x-um5302ta-quirk.patch
deleted file mode 100644
index 9d2bb5fe60f9..000000000000
--- a/acp6x-um5302ta-quirk.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/sound/soc/amd/yc/acp6x-mach.c b/sound/soc/amd/yc/acp6x-mach.c
-index e0b24e1daef3..5eab3baf3573 100644
---- a/sound/soc/amd/yc/acp6x-mach.c
-+++ b/sound/soc/amd/yc/acp6x-mach.c
-@@ -171,6 +171,13 @@ static const struct dmi_system_id yc_acp_quirk_table[] = {
- DMI_MATCH(DMI_PRODUCT_NAME, "21J6"),
- }
- },
-+ {
-+ .driver_data = &acp6x_card,
-+ .matches = {
-+ DMI_MATCH(DMI_BOARD_VENDOR, "ASUSTeK COMPUTER INC."),
-+ DMI_MATCH(DMI_PRODUCT_NAME, "UM5302TA"),
-+ }
-+ },
- {}
- };
-
diff --git a/config b/config
index 4944c196bb73..e48c315284ec 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.19.6-arch1 Kernel Configuration
+# Linux/x86 5.19.12-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -2980,7 +2980,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_FLAKEY=m
CONFIG_DM_VERITY=m
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
-# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG_SECONDARY_KEYRING is not set
+CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG_SECONDARY_KEYRING=y
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_SWITCH=m
CONFIG_DM_LOG_WRITES=m
@@ -3782,7 +3782,6 @@ CONFIG_IWLWIFI_DEBUGFS=y
CONFIG_IWLWIFI_DEVICE_TRACING=y
# end of Debugging Options
-CONFIG_IWLMEI=m
CONFIG_WLAN_VENDOR_INTERSIL=y
CONFIG_HOSTAP=m
CONFIG_HOSTAP_FIRMWARE=y
diff --git a/patch-realtek-um5302ta-quirk.patch b/patch-realtek-um5302ta-quirk.patch
index ddcded4f3e63..617265348484 100644
--- a/patch-realtek-um5302ta-quirk.patch
+++ b/patch-realtek-um5302ta-quirk.patch
@@ -1,12 +1,12 @@
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
-index fd630d62b5a0..3c31bd17e091 100644
+index f9d46ae4c7b7..1774a6d981a8 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
-@@ -9313,6 +9313,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
- SND_PCI_QUIRK(0x1043, 0x1e51, "ASUS Zephyrus M15", ALC294_FIXUP_ASUS_GU502_PINS),
+@@ -9392,6 +9392,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
SND_PCI_QUIRK(0x1043, 0x1e8e, "ASUS Zephyrus G15", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x1c52, "ASUS Zephyrus G15 2022", ALC289_FIXUP_ASUS_GA401),
SND_PCI_QUIRK(0x1043, 0x1f11, "ASUS Zephyrus G14", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x1f12, "ASUS UM5302TA", ALC287_FIXUP_CS35L41_I2C_2),
- SND_PCI_QUIRK(0x1043, 0x1d42, "ASUS Zephyrus G14 2022", ALC289_FIXUP_ASUS_GA401),
- SND_PCI_QUIRK(0x1043, 0x16b2, "ASUS GU603", ALC289_FIXUP_ASUS_GA401),
SND_PCI_QUIRK(0x1043, 0x3030, "ASUS ZN270IE", ALC256_FIXUP_ASUS_AIO_GPIO2),
+ SND_PCI_QUIRK(0x1043, 0x831a, "ASUS P901", ALC269_FIXUP_STEREO_DMIC),
+ SND_PCI_QUIRK(0x1043, 0x834a, "ASUS S101", ALC269_FIXUP_STEREO_DMIC),