summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD2
-rw-r--r--v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch12
4 files changed, 17 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71762aaa8928..c641a3ef1ed7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,6 +23,7 @@ pkgbase = linux-mainline-um5302ta
source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v5.19-rc4
source = config
source = v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+ source = v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch
source = v0-ASoC-cs35l41-CSC3551.patch
source = v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
@@ -31,6 +32,7 @@ pkgbase = linux-mainline-um5302ta
sha256sums = SKIP
sha256sums = 382aa201a6a6939210dd8668ab052724547b4bd489b38e97502bbd0848061b35
sha256sums = a78e1868cfcaa34d5e5c8e16f2072e54966798664e5148a804579819ef965814
+ sha256sums = 6b86f4d857af3622f66da8ad9ea059ea39693fe80e5fbb507b0f8d9bc4616f88
sha256sums = 66ecbd41168b1fb7fe8c8bba8a374456130aeceb64df2708d62f7ac3e700df1f
sha256sums = 5212ffc69ba29c5b29365849e8bdb621c8cadac4025de5a503f55af923f123f0
diff --git a/.gitignore b/.gitignore
index edcdabfce317..27f893344709 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,6 @@
!/.SRCINFO
!/config
!/v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+!/v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch
!/v0-ASoC-cs35l41-CSC3551.patch
!/v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
diff --git a/PKGBUILD b/PKGBUILD
index b9d0151704d6..332fd37a4155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ source=(
"$_srcname::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=$_srctag"
config # the main kernel config file
v5-ACPI-skip-IRQ1-override-on-3-Ryzen-6000-laptops.patch
+ v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch
v0-ASoC-cs35l41-CSC3551.patch
v4-Bluetooth-btusb-Add-a-new-VID-PID-0489-e0e2-for-MT7922.patch
)
@@ -31,6 +32,7 @@ validpgpkeys=(
sha256sums=('SKIP'
'382aa201a6a6939210dd8668ab052724547b4bd489b38e97502bbd0848061b35'
'a78e1868cfcaa34d5e5c8e16f2072e54966798664e5148a804579819ef965814'
+ '6b86f4d857af3622f66da8ad9ea059ea39693fe80e5fbb507b0f8d9bc4616f88'
'66ecbd41168b1fb7fe8c8bba8a374456130aeceb64df2708d62f7ac3e700df1f'
'5212ffc69ba29c5b29365849e8bdb621c8cadac4025de5a503f55af923f123f0')
diff --git a/v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch b/v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch
new file mode 100644
index 000000000000..91ec33f96dca
--- /dev/null
+++ b/v0-ALSA-hda-realtek-Add-quirk-for-ASUS-UM5302TA.patch
@@ -0,0 +1,12 @@
+diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
+index cee69fa7e246..2e4dbd14e43f 100644
+--- a/sound/pci/hda/patch_realtek.c
++++ b/sound/pci/hda/patch_realtek.c
+@@ -9137,6 +9137,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
+ SND_PCI_QUIRK(0x1043, 0x1e51, "ASUS Zephyrus M15", ALC294_FIXUP_ASUS_GU502_PINS),
+ SND_PCI_QUIRK(0x1043, 0x1e8e, "ASUS Zephyrus G15", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x1f11, "ASUS Zephyrus G14", ALC289_FIXUP_ASUS_GA401),
++ SND_PCI_QUIRK(0x1043, 0x1f12, "ASUS UM5302TA", ALC287_FIXUP_CS35L41_I2C_2),
+ SND_PCI_QUIRK(0x1043, 0x1d42, "ASUS Zephyrus G14 2022", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x16b2, "ASUS GU603", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x3030, "ASUS ZN270IE", ALC256_FIXUP_ASUS_AIO_GPIO2),