summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD5
-rw-r--r--PKGBUILD_change.patch12
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1418d0a91fbd..9b8402fd7ad0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,8 +13,6 @@ pkgbase = linux-manjaro-xanmod
makedepends = xmlto
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.8.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/patch-5.8.6.xz
- source = git+https://gitlab.manjaro.org/packages/core/linux58.git
source = https://github.com/xanmod/linux/releases/download/5.8.6-xanmod1/patch-5.8.6-xanmod1.xz
source = choose-gcc-optimization.sh
source = config
@@ -23,7 +21,6 @@ pkgbase = linux-manjaro-xanmod
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
source = 0001-i2c-nuvoton-nc677x-hwmon-driver.patch
source = 0001-iomap-iomap_bmap-should-accept-unwritten-maps.patch
- source = 0001-futex.patch
source = 0001-apparmor-patch-to-provide-compatibility-with-v2-net-rules.patch
source = 0002-apparmor-af_unix-mediation.patch
source = 0003-apparmor-fix-use-after-free-in-sk_peer_label.patch
@@ -45,17 +42,14 @@ pkgbase = linux-manjaro-xanmod
source = 0012-bootsplash.patch
source = 0013-bootsplash.gitpatch
sha256sums = e7f75186aa0642114af8f19d99559937300ca27acaf7451b36d4f9b0f85cf1f5
- sha256sums = b4ab9987a715753e64f0aa264dac91c3d7ca0651bfdd8fa5d19c8990f3b08abc
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 88af7b1e73f8e8d4d7e04da7f41564dbd4431a7f888efa7d12b64df19550141d
sha256sums = 0ecba3688f213c56b443145c5ffcf3ddfbe9cb0ee4c1fc4bd1351266224ad997
sha256sums = b44d81446d8b53d5637287c30ae3eb64cae0078c3fbc45fcf1081dd6699818b5
sha256sums = c079a87a7de0001f5f2b7a42a822c262e31f19f2c547613885f273822c9d4dcc
sha256sums = 986f8d802f37b72a54256f0ab84da83cb229388d58c0b6750f7c770818a18421
sha256sums = 7823d7488f42bc4ed7dfae6d1014dbde679d8b862c9a3697a39ba0dae5918978
sha256sums = 95745075edd597caa92b369cfbcd11a04c9e3c88c0c987c70114924e1e01df5c
- sha256sums = 78dde51123a21ec5efe9c420b309d03263001dafd8684f71c167f02e3f504f9e
sha256sums = 98202b8ad70d02d86603294bae967874fa7b18704b5c7b867568b0fd33a08921
sha256sums = 5cbbf3db9ea3205e9b89fe3049bea6dd626181db0cb0dc461e4cf5a400c68dd6
sha256sums = c7dbec875d0c1d6782c037a1dcefff2e5bdb5fc9dffac1beea07dd8c1bdef1d7
@@ -78,12 +72,13 @@ pkgbase = linux-manjaro-xanmod
sha256sums = 035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef
pkgname = linux-manjaro-xanmod
- pkgdesc = The Linux kernel and modules with Xanmod and Manjaro patches
+ pkgdesc = The Linux kernel and modules with Xanmod and Manjaro patches (Bootsplash support)
depends = coreutils
depends = linux-firmware
depends = kmod
depends = mkinitcpio>=27
optdepends = crda: to set the correct wireless channels of your country
+ optdepends = bootsplash-systemd: to enable bootsplash
provides = linux=5.8.6
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
diff --git a/PKGBUILD b/PKGBUILD
index f6ffcc467417..182b8b670733 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -182,9 +182,10 @@ build() {
}
package_linux-manjaro-xanmod() {
- pkgdesc="The Linux kernel and modules with Xanmod and Manjaro patches"
+ pkgdesc="The Linux kernel and modules with Xanmod and Manjaro patches (Bootsplash support)"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=27')
- optdepends=('crda: to set the correct wireless channels of your country')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'bootsplash-systemd: to enable bootsplash')
provides=("linux=${pkgver}" VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
cd "${srcdir}/linux-${_basekernel}"
diff --git a/PKGBUILD_change.patch b/PKGBUILD_change.patch
index 1b0e225477dd..0efbcafd2215 100644
--- a/PKGBUILD_change.patch
+++ b/PKGBUILD_change.patch
@@ -121,18 +121,22 @@
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
-@@ -148,8 +181,8 @@
+@@ -148,10 +181,11 @@
make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}
-package_linux58() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
+package_linux-manjaro-xanmod() {
-+ pkgdesc="The Linux kernel and modules with Xanmod and Manjaro patches"
++ pkgdesc="The Linux kernel and modules with Xanmod and Manjaro patches (Bootsplash support)"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=27')
- optdepends=('crda: to set the correct wireless channels of your country')
+- optdepends=('crda: to set the correct wireless channels of your country')
++ optdepends=('crda: to set the correct wireless channels of your country'
++ 'bootsplash-systemd: to enable bootsplash')
provides=("linux=${pkgver}" VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
-@@ -193,8 +226,8 @@
+
+ cd "${srcdir}/linux-${_basekernel}"
+@@ -193,8 +227,8 @@
install -Dt "${pkgdir}/usr/lib/modules/${_kernver}/build" -m644 vmlinux
}