summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d31205decc15..b308121b4c29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-manjaro-xanmod
pkgdesc = Linux Xanmod
- pkgver = 5.9.1
+ pkgver = 5.9.6
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -19,16 +19,16 @@ pkgbase = linux-manjaro-xanmod
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.9.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.9.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.9.1-xanmod1/patch-5.9.1-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.9.6-xanmod1/patch-5.9.6-xanmod1.xz
source = choose-gcc-optimization.sh
- source = manjaro.tar.gz::https://gitlab.manjaro.org/packages/core/linux59/-/archive/535feac9e5cfcdb830b4db8a60fafd1dfc661108/linux59-535feac9e5cfcdb830b4db8a60fafd1dfc661108.tar.gz
+ source = manjaro.tar.gz::https://gitlab.manjaro.org/packages/core/linux59/-/archive/7f7c583889d06f534296bca8c60642358c29549f/linux59-7f7c583889d06f534296bca8c60642358c29549f.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06
sha256sums = SKIP
- sha256sums = bf7703e423fb7b79b96ee462c660eb9ecd4a1ee5fc1ace68606841ea037fe344
+ sha256sums = 7521333c5b6ef735bf5247e2785a8c71ec015373b6ca47bccca1edf7e9938d41
sha256sums = 2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511
- sha256sums = b322760a2a9c8dad6842c9623d6e9362342d29b4e8e8bae1615c2e94f2793c1f
+ sha256sums = b6cf678ccce5797edd262194aa0693c370a935b0029270f0e312dfadf9680f7f
pkgname = linux-manjaro-xanmod
pkgdesc = The Linux kernel and modules with Xanmod and Manjaro patches (Bootsplash support). Ashmem and binder are enabled
diff --git a/PKGBUILD b/PKGBUILD
index 6957758db341..0bd069c73d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Andrey Alekseev <andrey.android7890@gmail.com>
+# Maintainer: ANDRoid7890 <andrey.android7890@gmail.com>
# https://gitlab.manjaro.org/packages/core/linux59
#
@@ -78,7 +78,7 @@ _makenconfig=
pkgbase=linux-manjaro-xanmod
pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.9.1
+pkgver=5.9.6
_major=5.9
_branch=5.x
xanmod=1
@@ -87,7 +87,7 @@ pkgdesc='Linux Xanmod'
url="http://www.xanmod.org/"
arch=(x86_64)
-__commit="535feac9e5cfcdb830b4db8a60fafd1dfc661108" # 5.9.1-1
+__commit="7f7c583889d06f534296bca8c60642358c29549f" # 5.9.6-1
license=(GPL2)
makedepends=(
@@ -100,11 +100,11 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
"https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}/patch-${pkgver}-xanmod${xanmod}.xz"
choose-gcc-optimization.sh
"manjaro.tar.gz::https://gitlab.manjaro.org/packages/core/linux59/-/archive/${__commit}/linux59-${__commit}.tar.gz")
-sha256sums=('3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06'
- 'SKIP'
- 'bf7703e423fb7b79b96ee462c660eb9ecd4a1ee5fc1ace68606841ea037fe344'
- '2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511'
- 'b322760a2a9c8dad6842c9623d6e9362342d29b4e8e8bae1615c2e94f2793c1f')
+sha256sums=('3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06' # kernel tar.xz
+ 'SKIP' # tar.sign
+ '7521333c5b6ef735bf5247e2785a8c71ec015373b6ca47bccca1edf7e9938d41' # xanmod
+ '2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511' # choose-gcc-optimization.sh
+ 'b6cf678ccce5797edd262194aa0693c370a935b0029270f0e312dfadf9680f7f') # manjaro
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -142,6 +142,7 @@ prepare() {
done
# Manjaro patches
+ rm ../linux59-$__commit/0103-futex.patch # remove conflicting one
local _patch
for _patch in ../linux59-$__commit/*; do
[[ $_patch = *.patch ]] || continue