summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--90-linux.hook (renamed from 99-linux.hook)0
-rw-r--r--PKGBUILD34
-rw-r--r--config.i686 (renamed from config)0
4 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a590177cdd0e..642ddb070758 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Apr 15 22:39:52 UTC 2017
+# Sat Apr 15 22:47:25 UTC 2017
pkgbase = linux-mptcp
pkgver = 0.92.rc1
pkgrel = 1
@@ -13,12 +13,13 @@ pkgbase = linux-mptcp
makedepends = kmod
makedepends = inetutils
makedepends = bc
+ makedepends = libelf
makedepends = git
options = !strip
source = git+https://github.com/multipath-tcp/mptcp#commit=4b7df55ef0fd6e3863477477f0b9567555d66644
- source = config
+ source = config.i686
source = config.x86_64
- source = 99-linux.hook
+ source = 90-linux.hook
source = linux.preset
source = change-default-console-loglevel.patch
sha256sums = SKIP
@@ -29,7 +30,7 @@ pkgbase = linux-mptcp
sha256sums = 567bdc00dbecae3e03c4d5306c8156d4a76485925404cf0c30f15f2c3661d32f
pkgname = linux-mptcp
- pkgdesc = The Linux kernel and modules with Multipath TCP support (based on linux 4.1.35)
+ pkgdesc = The Linux kernel and modules with Multipath TCP support (based on linux 4.4.56)
install = linux.install
depends = coreutils
depends = linux-firmware
diff --git a/99-linux.hook b/90-linux.hook
index 9851151995bc..9851151995bc 100644
--- a/99-linux.hook
+++ b/90-linux.hook
diff --git a/PKGBUILD b/PKGBUILD
index c13e20d3c8e5..a7967cc1a393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,13 @@ epoch=1
arch=('i686' 'x86_64')
url="http://www.multipath-tcp.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
+makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf' 'git')
options=('!strip')
source=("git+https://github.com/multipath-tcp/mptcp#commit=4b7df55ef0fd6e3863477477f0b9567555d66644"
# the main kernel config files
- 'config' 'config.x86_64'
+ 'config.i686' 'config.x86_64'
# pacman hook for initramfs regeneration
- '99-linux.hook'
+ '90-linux.hook'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch')
@@ -44,11 +44,7 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- if [ "${CARCH}" = "x86_64" ]; then
- cat "${srcdir}/config.x86_64" > ./.config
- else
- cat "${srcdir}/config" > ./.config
- fi
+ cat "${srcdir}/config.${CARCH}" > ./.config
if [ "${_kernelname}" != "" ]; then
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
@@ -80,18 +76,13 @@ build() {
cd "${srcdir}/${_srcname}"
# save configuration for later reuse
- if [ "${CARCH}" = "x86_64" ]; then
- cat .config > "${startdir}/config.x86_64.last"
- else
- cat .config > "${startdir}/config.last"
- fi
+ cat .config > "${startdir}/config.${CARCH}.last"
- # build!
make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}
_package() {
- pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 4.1.35)"
+ pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 4.4.56)"
[ "${pkgbase}" = "linux" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country'
@@ -123,8 +114,8 @@ _package() {
install -D -m644 /dev/stdin "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# install pacman hook for initramfs regeneration
- sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
- install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
+ sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/90-linux.hook" |
+ install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/90-${pkgbase}.hook"
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
@@ -163,7 +154,7 @@ _package-headers() {
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include"
for i in acpi asm-generic config crypto drm generated keys linux math-emu \
- media net pcmcia scsi sound trace uapi video xen; do
+ media net pcmcia scsi soc sound trace uapi video xen; do
cp -a include/${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/include/"
done
@@ -245,6 +236,12 @@ _package-headers() {
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
done
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ if [ -f tools/objtool/objtool ]; then
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool"
+ cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
+ fi
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
@@ -271,7 +268,6 @@ _package-headers() {
_package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
- arch=("any")
cd "${srcdir}/${_srcname}"
diff --git a/config b/config.i686
index b6e2c810565f..b6e2c810565f 100644
--- a/config
+++ b/config.i686