summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 4 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 713936f9dfa2..6cdfa3ba73c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-next-git
- pkgver = 20190319.r0.g75e6a83b189c
+ pkgver = 20190412.r0.gbcb67f0fbce9
pkgrel = 1
url = http://www.kernel.org/
arch = x86_64
@@ -8,8 +8,6 @@ pkgbase = linux-next-git
makedepends = inetutils
makedepends = bc
makedepends = libelf
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
source = git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git
source = config
diff --git a/PKGBUILD b/PKGBUILD
index 1a1d409dd08c..5ec844ca99d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,14 +50,14 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20190319.r0.g75e6a83b189c
+pkgver=20190412.r0.gbcb67f0fbce9
_srcname=linux-next
pkgrel=1
arch=('x86_64')
url="http://www.kernel.org/"
license=('GPL2')
options=('!strip')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'python-sphinx' 'graphviz')
+makedepends=('kmod' 'inetutils' 'bc' 'libelf')
source=("git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git"
# the main kernel config files
@@ -183,7 +183,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -340,18 +340,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"