summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD234
-rw-r--r--config4
3 files changed, 124 insertions, 136 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b69b4155f63..388d67fbff61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-pds
- pkgver = 5.2.9.arch1
+ pkgver = 5.2.10.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.2.9-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.2.10-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -15,7 +15,7 @@ pkgbase = linux-pds
makedepends = graphviz
makedepends = imagemagick
options = !strip
- source = git+https://git.archlinux.org/linux?signed#tag=v5.2.9-arch1
+ source = git+https://git.archlinux.org/linux?signed#tag=v5.2.10-arch1
source = git+https://github.com/graysky2/kernel_gcc_patch
source = config
source = 60-linux.hook
@@ -28,7 +28,7 @@ pkgbase = linux-pds
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 51ed43342e4ba7f4b38b05db77f280138b2d49b4bef3cf216da30436dcb016951240af76178a013c7cd0022ac1d3823eccf8c6012e269134567466cbacc74877
+ sha512sums = 06fa3df82f3ba9517c6d1e4946c5b29ba7c9adc755a7d2312d4cdd86de60dfdb70e424a572784add0456eabfd5a0fe026629cb18ae7f7d1df8b58541cfb22069
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
sha512sums = 2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
@@ -44,18 +44,18 @@ pkgname = linux-pds
depends = mkinitcpio
depends = thrash-protect
optdepends = crda: to set the correct wireless channels of your country
- provides = linux-pds=5.2.9.arch1
+ provides = linux-pds=5.2.10.arch1
backup = etc/mkinitcpio.d/linux-pds.preset
pkgname = linux-pds-headers
pkgdesc = Header files and scripts for building modules for Linux-pds kernel ~ featuring Alfred Chen's PDS CPU scheduler, rebased by TkG
- depends = linux-pds=5.2.9.arch1
- provides = linux-pds-headers=5.2.9.arch1
- provides = linux-headers=5.2.9.arch1
+ depends = linux-pds=5.2.10.arch1
+ provides = linux-pds-headers=5.2.10.arch1
+ provides = linux-headers=5.2.10.arch1
pkgname = linux-pds-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-pds kernel ~ featuring Alfred Chen's PDS CPU scheduler, rebased by TkG
- depends = linux-pds=5.2.9.arch1
- provides = linux-pds-docs=5.2.9.arch1
- provides = linux-docs=5.2.9.arch1
+ depends = linux-pds=5.2.10.arch1
+ provides = linux-pds-docs=5.2.10.arch1
+ provides = linux-docs=5.2.10.arch1
diff --git a/PKGBUILD b/PKGBUILD
index 60a8e14cacbc..f3acf8a594c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,8 +67,8 @@ _subarch=
_localmodcfg=
pkgbase=linux-pds
-_srcver_tag=5.2.9-arch1
-pkgver="${_srcver_tag//-/.}"
+_srcver_tag=5.2.10-arch1
+pkgver=${_srcver_tag//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver_tag"
@@ -85,20 +85,20 @@ makedepends=(
graphviz
imagemagick
)
-options=("!strip")
+options=('!strip')
_reponame="linux"
-_repo_url="https://git.archlinux.org/${_reponame}"
+_repo_url="https://git.archlinux.org/$_reponame"
_reponame_gcc_patch="kernel_gcc_patch"
-_repo_url_gcc_patch="https://github.com/graysky2/${_reponame_gcc_patch}"
+_repo_url_gcc_patch="https://github.com/graysky2/$_reponame_gcc_patch"
_gcc_patch_name="enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
_pkgdesc_extra="~ featuring Alfred Chen's PDS CPU scheduler, rebased by TkG"
source=(
- "git+${_repo_url}?signed#tag=v${_srcver_tag}"
- "git+${_repo_url_gcc_patch}"
+ "git+$_repo_url?signed#tag=v$_srcver_tag"
+ "git+$_repo_url_gcc_patch"
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -107,13 +107,13 @@ source=(
02-Glitched-PDS-by-TkG.patch
)
validpgpkeys=(
- "ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
- "647F28654894E3BD457199BE38DBBDC86092693E" # Greg Kroah-Hartman
- "8218F88849AAC522E94CF470A5E9288C4FA415FA" # Jan Alexander Steffens (heftig)
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha512sums=('SKIP'
'SKIP'
- '51ed43342e4ba7f4b38b05db77f280138b2d49b4bef3cf216da30436dcb016951240af76178a013c7cd0022ac1d3823eccf8c6012e269134567466cbacc74877'
+ '06fa3df82f3ba9517c6d1e4946c5b29ba7c9adc755a7d2312d4cdd86de60dfdb70e424a572784add0456eabfd5a0fe026629cb18ae7f7d1df8b58541cfb22069'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
'2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
@@ -124,34 +124,34 @@ _kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
prepare() {
- cd ${_reponame}
+ cd $_reponame
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
- echo "-${pkgrel}" > localversion.10-pkgrel
- echo "${_kernelname}" > localversion.20-pkgname
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "$_kernelname" > localversion.20-pkgname
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching to enabled additional gcc CPU optimizatons..."
- patch -Np1 -i "${srcdir}/${_reponame_gcc_patch}/${_gcc_patch_name}"
+ patch -Np1 -i "$srcdir/$_reponame_gcc_patch/$_gcc_patch_name"
# From https://github.com/Tk-Glitch/PKGBUILDS/tree/master/linux52-tkg/linux52-tkg-patches
msg2 "Patching Undead PDS 0.99o 5.2 rebase by TkG"
- patch -Np1 -i "${srcdir}/01-Undead-PDS-0.99o-rebase-by-TkG.patch"
- patch -Np1 -i "${srcdir}/02-Glitched-PDS-by-TkG.patch"
+ patch -Np1 -i "$srcdir/01-Undead-PDS-0.99o-rebase-by-TkG.patch"
+ patch -Np1 -i "$srcdir/02-Glitched-PDS-by-TkG.patch"
msg2 "Setting config..."
cp ../config .config
- if [ -n "${_subarch}" ]; then
- yes "${_subarch}" | make oldconfig
+ if [ -n "$_subarch" ]; then
+ yes "$_subarch" | make oldconfig
else
make prepare
fi
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "${_localmodcfg}" ]; then
+ if [ -n "$_localmodcfg" ]; then
msg "If you have modprobed-db installed, running it in recall mode now"
if [ -e /usr/bin/modprobed-db ]; then
[[ -x /usr/bin/sudo ]] || {
@@ -162,7 +162,7 @@ prepare() {
fi
fi
- if [ -z "${_sched_yield_type}" ]; then
+ if [ -z "$_sched_yield_type" ]; then
plain ""
plain "CPU sched_yield_type - Choose what sort of yield sched_yield will perform."
plain ""
@@ -172,33 +172,33 @@ prepare() {
plain "2: Expire timeslice and recalculate deadline."
read -rp "`echo $'\n> 0 (Recommended option for gaming on PDS - "tkg" default)\n 1 (Default, but can lead to stability issues on some platforms)\n 2 (Usually the slowest option for PDS, not recommended unless you have issues with 0 or 1)\n [0-2?]: '`" _sched_yield_type;
fi
- if [ "${_sched_yield_type}" == "1" ]; then
+ if [ "$_sched_yield_type" == "1" ]; then
msg2 "Using default CPU sched yield type (1)"
- elif [ "${_sched_yield_type}" == "2" ]; then
- sed -i -e "s/int sched_yield_type __read_mostly = 1;/int sched_yield_type __read_mostly = 2;/" ./kernel/sched/pds.c
+ elif [ "$_sched_yield_type" == "2" ]; then
+ sed -i -e 's/int sched_yield_type __read_mostly = 1;/int sched_yield_type __read_mostly = 2;/' ./kernel/sched/pds.c
else
- sed -i -e "s/int sched_yield_type __read_mostly = 1;/int sched_yield_type __read_mostly = 0;/" ./kernel/sched/pds.c
+ sed -i -e 's/int sched_yield_type __read_mostly = 1;/int sched_yield_type __read_mostly = 0;/' ./kernel/sched/pds.c
fi
# do not run "make olddefconfig" as it sets default options
yes "" | make config >/dev/null
make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "${pkgbase}" "$(<../version)"
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
- [[ -z "${_makenconfig}" ]] || make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
# save configuration for later reuse
- cat .config > "${startdir}/config.last"
+ cat .config > "$startdir/config.last"
}
build() {
- cd ${_reponame}
+ cd $_reponame
make bzImage modules htmldocs
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules ${_pkgdesc_extra}"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules $_pkgdesc_extra"
depends=(
coreutils
linux-firmware
@@ -207,189 +207,177 @@ _package() {
thrash-protect
)
optdepends=("crda: to set the correct wireless channels of your country")
- provides=("${pkgbase}=${pkgver}")
- backup=("etc/mkinitcpio.d/${pkgbase}.preset")
+ provides=("$pkgbase=$pkgver")
+ backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
local kernver="$(<version)"
- local modulesdir="${pkgdir}/usr/lib/modules/${kernver}"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- cd ${_reponame}
+ cd $_reponame
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "${modulesdir}/vmlinuz"
- install -Dm644 "${modulesdir}/vmlinuz" "${pkgdir}/boot/vmlinuz-${pkgbase}"
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
- local extramodules="extramodules${_kernelname}"
- local extradir="${pkgdir}/usr/lib/modules/${extramodules}"
- install -Dt "${extradir}" -m644 ../version
- ln -sr "${extradir}" "${modulesdir}/extramodules"
+ local extramodules="extramodules$_kernelname"
+ local extradir="$pkgdir/usr/lib/modules/$extramodules"
+ install -Dt "$extradir" -m644 ../version
+ ln -sr "$extradir" "$modulesdir/extramodules"
# remove build and source links
- rm "${modulesdir}"/{source,build}
+ rm "$modulesdir"/{source,build}
msg2 "Installing hooks..."
# sed expression for following substitutions
local subst="
- s|%PKGBASE%|${pkgbase}|g
- s|%KERNVER%|${kernver}|g
- s|%EXTRAMODULES%|${extramodules}|g
+ s|%PKGBASE%|$pkgbase|g
+ s|%KERNVER%|$kernver|g
+ s|%EXTRAMODULES%|$extramodules|g
"
# hack to allow specifying an initially nonexisting install file
- sed "${subst}" "${startdir}/${install}" > "${startdir}/${install}.pkg"
- true && install=${install}.pkg
+ sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
+ true && install=$install.pkg
# fill in mkinitcpio preset and pacman hooks
- sed "${subst}" ../linux.preset | install -Dm644 /dev/stdin \
- "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
- sed "${subst}" ../60-linux.hook | install -Dm644 /dev/stdin \
- "${pkgdir}/usr/share/libalpm/hooks/60-${pkgbase}.hook"
- sed "${subst}" ../90-linux.hook | install -Dm644 /dev/stdin \
- "${pkgdir}/usr/share/libalpm/hooks/90-${pkgbase}.hook"
+ sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
+ "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
+ sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
+ "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
+ sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
+ "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "${pkgdir}"
+ chmod -Rc u=rwX,go=rX "$pkgdir"
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel ${_pkgdesc_extra}"
- depends=("${pkgbase}=${pkgver}")
+ pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel $_pkgdesc_extra"
+ depends=("$pkgbase=$pkgver")
provides=(
- "${pkgbase}-headers=${pkgver}"
- "linux-headers=${pkgver}"
+ "$pkgbase-headers=$pkgver"
+ "linux-headers=$pkgver"
)
- local builddir="${pkgdir}/usr/lib/modules/$(<version)/build"
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- cd ${_reponame}
+ cd $_reponame
msg2 "Installing build files..."
- install -Dt "${builddir}" -m644 Makefile .config Module.symvers System.map vmlinux
- install -Dt "${builddir}/kernel" -m644 kernel/Makefile
- install -Dt "${builddir}/arch/x86" -m644 arch/x86/Makefile
- cp -t "${builddir}" -a scripts
+ install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
# add objtool for external module building and enabled VALIDATION_STACK option
- install -Dt "${builddir}/tools/objtool" tools/objtool/objtool
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# add xfs and shmem for aufs building
- mkdir -p "${builddir}"/{fs/xfs,mm}
+ mkdir -p "$builddir"/{fs/xfs,mm}
# ???
- mkdir "${builddir}/.tmp_versions"
+ mkdir "$builddir/.tmp_versions"
msg2 "Installing headers..."
- cp -t "${builddir}" -a include
- cp -t "${builddir}/arch/x86" -a arch/x86/include
- install -Dt "${builddir}/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
- install -Dt "${builddir}/drivers/md" -m644 drivers/md/*.h
- install -Dt "${builddir}/net/mac80211" -m644 net/mac80211/*.h
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
# http://bugs.archlinux.org/task/13146
- install -Dt "${builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# http://bugs.archlinux.org/task/20402
- install -Dt "${builddir}/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
- install -Dt "${builddir}/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
- install -Dt "${builddir}/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
msg2 "Installing KConfig files..."
- find . -name "Kconfig*" -exec install -Dm644 {} "${builddir}/{}" \;
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
msg2 "Removing unneeded architectures..."
local arch
- for arch in "${builddir}"/arch/*/; do
- [[ ${arch} = */x86/ ]] && continue
- echo "Removing $(basename "${arch}")"
- rm -r "${arch}"
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
done
msg2 "Removing documentation..."
- rm -r "${builddir}/Documentation"
+ rm -r "$builddir/Documentation"
msg2 "Removing broken symlinks..."
- find -L "${builddir}" -type l -printf "Removing %P\n" -delete
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
msg2 "Removing loose objects..."
- find "${builddir}" -type f -name "*.o" -printf "Removing %P\n" -delete
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
msg2 "Stripping build tools..."
local file
- while read -rd "" file; do
- case "$(file -bi "${file}")" in
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
- strip -v $STRIP_SHARED "${file}" ;;
+ strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
- strip -v $STRIP_STATIC "${file}" ;;
+ strip -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
- strip -v $STRIP_BINARIES "${file}" ;;
+ strip -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
- strip -v $STRIP_SHARED "${file}" ;;
+ strip -v $STRIP_SHARED "$file" ;;
esac
- done < <(find "${builddir}" -type f -perm -u+x ! -name vmlinux -print0)
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
msg2 "Adding symlink..."
- mkdir -p "${pkgdir}/usr/src"
- ln -sr "${builddir}" "${pkgdir}/usr/src/${pkgbase}-${pkgver}"
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "${pkgdir}"
+ chmod -Rc u=rwX,go=rX "$pkgdir"
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel ${_pkgdesc_extra}"
- depends=("${pkgbase}=${pkgver}")
+ pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel $_pkgdesc_extra"
+ depends=("$pkgbase=$pkgver")
provides=(
- "${pkgbase}-docs=${pkgver}"
- "linux-docs=${pkgver}"
+ "$pkgbase-docs=$pkgver"
+ "linux-docs=$pkgver"
)
- local builddir="${pkgdir}/usr/lib/modules/$(<version)/build"
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- cd ${_reponame}
+ cd $_reponame
msg2 "Installing documentation..."
- mkdir -p "${builddir}"
- cp -t "${builddir}" -a Documentation
-
- # msg2 "Removing doctrees..."
- # rm -r "${builddir}/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd "" src; do
- dst="${builddir}/Documentation/${src#${builddir}/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "${src}" "${dst}"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "${builddir}/Documentation/output" -type f -print0)
+ mkdir -p "$builddir"
+ cp -t "$builddir" -a Documentation
msg2 "Adding symlink..."
- mkdir -p "${pkgdir}/usr/share/doc"
- ln -sr "${builddir}/Documentation" "${pkgdir}/usr/share/doc/${pkgbase}"
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "${pkgdir}"
+ chmod -Rc u=rwX,go=rX "$pkgdir"
}
pkgname=(
- "${pkgbase}"
- "${pkgbase}-headers"
- "${pkgbase}-docs"
+ "$pkgbase"
+ "$pkgbase-headers"
+ "$pkgbase-docs"
)
for _p in "${pkgname[@]}"; do
- eval "package_${_p}() {
- $(declare -f "_package${_p#${pkgbase}}")
- _package${_p#${pkgbase}}
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
}"
done
diff --git a/config b/config
index bd0364986111..7a8914b8b51e 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.2.9-arch1 Kernel Configuration
+# Linux/x86 5.2.10-arch1 Kernel Configuration
#
#
@@ -8495,7 +8495,7 @@ CONFIG_IOMMU_SUPPORT=y
# CONFIG_IOMMU_DEFAULT_PASSTHROUGH is not set
CONFIG_OF_IOMMU=y
CONFIG_AMD_IOMMU=y
-CONFIG_AMD_IOMMU_V2=m
+CONFIG_AMD_IOMMU_V2=y
CONFIG_DMAR_TABLE=y
CONFIG_INTEL_IOMMU=y
CONFIG_INTEL_IOMMU_SVM=y