summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
-rw-r--r--config5
-rw-r--r--linux.install19
4 files changed, 24 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa2a3434cb14..f9a71eaaea46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Thu Nov 22 14:17:47 UTC 2018
+# Thu Nov 29 19:02:00 UTC 2018
pkgbase = linux-rc
- pkgver = 4.19.4rc1
+ pkgver = 4.19.6rc1
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -11,20 +11,20 @@ pkgbase = linux-rc
makedepends = bc
makedepends = libelf
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.3.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.3.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/patch-4.19.4-rc1.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/patch-4.19.4-rc1.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.5.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.5.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/patch-4.19.6-rc1.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/patch-4.19.6-rc1.sign
source = config
source = 60-linux.hook
source = 90-linux.hook
source = linux.preset
source = 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- sha256sums = 1e3c5712d4d0fdf307cf6b69d220f8e54def487e41efb0fbabe652a7a9986420
+ sha256sums = 8c839ec29cce7eb0e8ef7eaa10d1eb9d84d2be2521e352fb4f9414e76856ef75
sha256sums = SKIP
- sha256sums = 4cacd757443dba24cbb638ee0f4d7f01bae847527df06b09e8224206b0d76178
+ sha256sums = c54b9f6caaf24d6477f1bbf4b949dac677bc76872c488d4171689b6e3681e6c1
sha256sums = SKIP
- sha256sums = 986918689166b88f03579bda4a5a964ec4a1db18423b89981ba58da7e35e8e89
+ sha256sums = e7fa30bb2de12d1a2488423e27c00f26d55668e310e69aaf93673c1afd89dbaf
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
diff --git a/PKGBUILD b/PKGBUILD
index 79c49828bc7f..99fb60bf5352 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=linux-rc
pkgrel=1
_srcname=linux-4.19
-_stable=4.19.3
-_patchver=4.19.4
+_stable=4.19.5
+_patchver=4.19.6
_rcver=1
pkgver=${_patchver}rc${_rcver}
_rcpatch=patch-${_patchver}-rc${_rcver}
@@ -29,11 +29,11 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('1e3c5712d4d0fdf307cf6b69d220f8e54def487e41efb0fbabe652a7a9986420'
+sha256sums=('8c839ec29cce7eb0e8ef7eaa10d1eb9d84d2be2521e352fb4f9414e76856ef75'
'SKIP'
- '4cacd757443dba24cbb638ee0f4d7f01bae847527df06b09e8224206b0d76178'
+ 'c54b9f6caaf24d6477f1bbf4b949dac677bc76872c488d4171689b6e3681e6c1'
'SKIP'
- '986918689166b88f03579bda4a5a964ec4a1db18423b89981ba58da7e35e8e89'
+ 'e7fa30bb2de12d1a2488423e27c00f26d55668e310e69aaf93673c1afd89dbaf'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -94,15 +94,17 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd linux-$_stable
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
diff --git a/config b/config
index 18372f6895ec..b1859e9cb727 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.2-arch1 Kernel Configuration
+# Linux/x86 4.19.3-arch1 Kernel Configuration
#
#
@@ -1603,6 +1603,7 @@ CONFIG_L2TP_V3=y
CONFIG_L2TP_IP=m
CONFIG_L2TP_ETH=m
CONFIG_STP=m
+CONFIG_GARP=m
CONFIG_MRP=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y
@@ -1619,7 +1620,7 @@ CONFIG_NET_DSA_TAG_LAN9303=y
CONFIG_NET_DSA_TAG_MTK=y
CONFIG_NET_DSA_TAG_QCA=y
CONFIG_VLAN_8021Q=m
-# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_VLAN_8021Q_GVRP=y
CONFIG_VLAN_8021Q_MVRP=y
# CONFIG_DECNET is not set
CONFIG_LLC=m
diff --git a/linux.install b/linux.install
index 046277584140..43b8071cf8a4 100644
--- a/linux.install
+++ b/linux.install
@@ -1,27 +1,12 @@
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
-}
-
post_upgrade() {
if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
echo "WARNING: /boot appears to be a separate partition but is not mounted."
fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
-
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
}
post_remove() {
- # also remove the compat symlinks
rm -f boot/initramfs-%PKGBASE%.img
rm -f boot/initramfs-%PKGBASE%-fallback.img
}
+
+# vim:set ft=sh ts=8 sts=2 sw=2 et: