summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch14
-rw-r--r--0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch85
-rw-r--r--PKGBUILD10
4 files changed, 108 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69bd052e8751..be27ba12c1a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-rc
- pkgver = 5.13.8rc1
+ pkgver = 5.13.9rc1
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -12,20 +12,22 @@ pkgbase = linux-rc
makedepends = tar
makedepends = xz
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.13.8-rc1.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.13.8-rc1.sign
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.13.7.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.13.7.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.13.9-rc1.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.13.9-rc1.sign
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.13.8.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.13.8.tar.sign
source = config
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ source = 0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- b2sums = 201d2ccee279efa8d102bf7e3957e285a2ed7c9af9dc6e937a4ad6a2fdf30435be99a3fd31132df08cb9491af35913aa58a7450c00201e4495d142c17d3344d5
+ b2sums = 782ac3d6eac495eed708de5b06eaacdc37385f25ab69940653586abe4bf247f372f1b13a3b7cdcd95dcf0d925ac2436807ec056a388b9d8a95cdfbc084fe0b39
b2sums = SKIP
- b2sums = 2204912daa4b48f551f8d72b6f982e7e0c3bd12c98a9f4fe3a038c72a3229803e39577da057149d1b1bb117dc4fc33ed3ec0b3889b4d94470f7d77d9dd2c812d
+ b2sums = 567812f1ad10dd2fa260cd087849148b8b4ea05db73ec9743c44e49e572cb5604ac24fd402db0b22660cdbc59e4dd5dac4662acf33b468018c31e250ba75eb0a
b2sums = SKIP
b2sums = 135757fad4d5301d665bcda81118b3b2dd855b4732593841ff6f01d175d63632cfd98b215a3117b7c2363be9ebd3966e1ba3c66fdd326ff6a4c43fb56fa3af3b
- b2sums = 87175031fe8d6e2afb71d43624a21c789e6fd44072ae9f191170ae04e392b32fc114b3ccd0f4c80e4b87168c52da35c78cadadc5f8ca0238eafbf93b8ffa50ed
+ b2sums = e6df0ce8d665261cffc930e0a99023abd1b26caf1e89dda756cf76713953e6b3a36d3210a4c01beedb2a28acc357a9880d19870a71864ede86e29b58991fff72
+ b2sums = ea7fd8a0fd1431078f158ef3bc184b3b826290ae4fde9739e9159444e44c8ed9fb33b1419f4650977e701f8bbbddf22a16b0dfa7aa775c89e42cb54e213de146
pkgname = linux-rc
pkgdesc = The release candidate kernel and modules
diff --git a/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch b/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
index 17037d74db17..1381204c86ae 100644
--- a/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+++ b/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
@@ -1,7 +1,7 @@
-From a5b30f8875bb823de46bb8809e6a7932a567d357 Mon Sep 17 00:00:00 2001
+From 90de407f12e8ed9cb361678882c2af236b06107e Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Mon, 16 Sep 2019 04:53:20 +0200
-Subject: [PATCH 1/2] ZEN: Add sysctl and CONFIG to disallow unprivileged
+Subject: [PATCH 1/3] ZEN: Add sysctl and CONFIG to disallow unprivileged
CLONE_NEWUSER
Our default behavior continues to match the vanilla kernel.
@@ -14,10 +14,10 @@ Our default behavior continues to match the vanilla kernel.
5 files changed, 53 insertions(+)
diff --git a/include/linux/user_namespace.h b/include/linux/user_namespace.h
-index 1d08dbbcfe32..180da8f71205 100644
+index bfa6463f8a95..27aa2bd5e50a 100644
--- a/include/linux/user_namespace.h
+++ b/include/linux/user_namespace.h
-@@ -112,6 +112,8 @@ void dec_ucount(struct ucounts *ucounts, enum ucount_type type);
+@@ -116,6 +116,8 @@ void put_ucounts(struct ucounts *ucounts);
#ifdef CONFIG_USER_NS
@@ -26,7 +26,7 @@ index 1d08dbbcfe32..180da8f71205 100644
static inline struct user_namespace *get_user_ns(struct user_namespace *ns)
{
if (ns)
-@@ -145,6 +147,8 @@ extern bool current_in_userns(const struct user_namespace *target_ns);
+@@ -149,6 +151,8 @@ extern bool current_in_userns(const struct user_namespace *target_ns);
struct ns_common *ns_get_owner(struct ns_common *ns);
#else
@@ -63,7 +63,7 @@ index a61c92066c2e..6a2920f2e2ad 100644
bool "PID Namespaces"
default y
diff --git a/kernel/fork.c b/kernel/fork.c
-index a070caed5c8e..03baafd70b98 100644
+index 567fee340500..f8ad32116152 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -98,6 +98,10 @@
@@ -132,7 +132,7 @@ index d4a78e08f6d8..0260dfe2daff 100644
{
.procname = "tainted",
diff --git a/kernel/user_namespace.c b/kernel/user_namespace.c
-index 8d62863721b0..5ca391b2b506 100644
+index 27670ab7a4ed..300c72d2a381 100644
--- a/kernel/user_namespace.c
+++ b/kernel/user_namespace.c
@@ -21,6 +21,13 @@
diff --git a/0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch b/0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch
new file mode 100644
index 000000000000..d4288838ae0f
--- /dev/null
+++ b/0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch
@@ -0,0 +1,85 @@
+From bdb12383a58d6989a0b1c2f925890948146bbc90 Mon Sep 17 00:00:00 2001
+From: Pauli Virtanen <pav@iki.fi>
+Date: Mon, 26 Jul 2021 21:02:06 +0300
+Subject: [PATCH 2/3] Bluetooth: btusb: check conditions before enabling USB
+ ALT 3 for WBS
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Some USB BT adapters don't satisfy the MTU requirement mentioned in
+commit e848dbd364ac ("Bluetooth: btusb: Add support USB ALT 3 for WBS")
+and have ALT 3 setting that produces no/garbled audio. Some adapters
+with larger MTU were also reported to have problems with ALT 3.
+
+Add a flag and check it and MTU before selecting ALT 3, falling back to
+ALT 1. Enable the flag for Realtek, restoring the previous behavior for
+non-Realtek devices.
+
+Tested with USB adapters (mtu<72, no/garbled sound with ALT3, ALT1
+works) BCM20702A1 0b05:17cb, CSR8510A10 0a12:0001, and (mtu>=72, ALT3
+works) RTL8761BU 0bda:8771, Intel AX200 8087:0029 (after disabling
+ALT6). Also got reports for (mtu>=72, ALT 3 reported to produce bad
+audio) Intel 8087:0a2b.
+
+Signed-off-by: Pauli Virtanen <pav@iki.fi>
+Fixes: e848dbd364ac ("Bluetooth: btusb: Add support USB ALT 3 for WBS")
+Tested-by: Michał Kępień <kernel@kempniu.pl>
+
+Fixes: https://bugs.archlinux.org/task/71567
+---
+ drivers/bluetooth/btusb.c | 22 ++++++++++++++--------
+ 1 file changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
+index 6d23308119d1..e8062d0b7d4d 100644
+--- a/drivers/bluetooth/btusb.c
++++ b/drivers/bluetooth/btusb.c
+@@ -516,6 +516,7 @@ static const struct dmi_system_id btusb_needs_reset_resume_table[] = {
+ #define BTUSB_HW_RESET_ACTIVE 12
+ #define BTUSB_TX_WAIT_VND_EVT 13
+ #define BTUSB_WAKEUP_DISABLE 14
++#define BTUSB_USE_ALT3_FOR_WBS 15
+
+ struct btusb_data {
+ struct hci_dev *hdev;
+@@ -1748,16 +1749,20 @@ static void btusb_work(struct work_struct *work)
+ /* Bluetooth USB spec recommends alt 6 (63 bytes), but
+ * many adapters do not support it. Alt 1 appears to
+ * work for all adapters that do not have alt 6, and
+- * which work with WBS at all.
++ * which work with WBS at all. Some devices prefer
++ * alt 3 (HCI payload >= 60 Bytes let air packet
++ * data satisfy 60 bytes), requiring
++ * MTU >= 3 (packets) * 25 (size) - 3 (headers) = 72
++ * see also Core spec 5, vol 4, B 2.1.1 & Table 2.1.
+ */
+- new_alts = btusb_find_altsetting(data, 6) ? 6 : 1;
+- /* Because mSBC frames do not need to be aligned to the
+- * SCO packet boundary. If support the Alt 3, use the
+- * Alt 3 for HCI payload >= 60 Bytes let air packet
+- * data satisfy 60 bytes.
+- */
+- if (new_alts == 1 && btusb_find_altsetting(data, 3))
++ if (btusb_find_altsetting(data, 6))
++ new_alts = 6;
++ else if (test_bit(BTUSB_USE_ALT3_FOR_WBS, &data->flags) &&
++ hdev->sco_mtu >= 72 &&
++ btusb_find_altsetting(data, 3))
+ new_alts = 3;
++ else
++ new_alts = 1;
+ }
+
+ if (btusb_switch_alt_setting(hdev, new_alts) < 0)
+@@ -4733,6 +4738,7 @@ static int btusb_probe(struct usb_interface *intf,
+ * (DEVICE_REMOTE_WAKEUP)
+ */
+ set_bit(BTUSB_WAKEUP_DISABLE, &data->flags);
++ set_bit(BTUSB_USE_ALT3_FOR_WBS, &data->flags);
+ }
+
+ if (!reset)
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index f8117bea6ee7..0028fe468399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _srcname=linux-5.13
_major=5.13
### on initial release this is null otherwise it is the current stable subversion
### ie 1,2,3 corresponding $_major.1, $_major.3 etc
-_minor=7
+_minor=8
_minorc=$((_minor+1))
### on initial release this is just $_major
_fullver=$_major.$_minor
@@ -30,17 +30,19 @@ source=(
https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_fullver.tar.{xz,sign}
config # the main kernel config file
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-b2sums=('201d2ccee279efa8d102bf7e3957e285a2ed7c9af9dc6e937a4ad6a2fdf30435be99a3fd31132df08cb9491af35913aa58a7450c00201e4495d142c17d3344d5'
+b2sums=('782ac3d6eac495eed708de5b06eaacdc37385f25ab69940653586abe4bf247f372f1b13a3b7cdcd95dcf0d925ac2436807ec056a388b9d8a95cdfbc084fe0b39'
'SKIP'
- '2204912daa4b48f551f8d72b6f982e7e0c3bd12c98a9f4fe3a038c72a3229803e39577da057149d1b1bb117dc4fc33ed3ec0b3889b4d94470f7d77d9dd2c812d'
+ '567812f1ad10dd2fa260cd087849148b8b4ea05db73ec9743c44e49e572cb5604ac24fd402db0b22660cdbc59e4dd5dac4662acf33b468018c31e250ba75eb0a'
'SKIP'
'135757fad4d5301d665bcda81118b3b2dd855b4732593841ff6f01d175d63632cfd98b215a3117b7c2363be9ebd3966e1ba3c66fdd326ff6a4c43fb56fa3af3b'
- '87175031fe8d6e2afb71d43624a21c789e6fd44072ae9f191170ae04e392b32fc114b3ccd0f4c80e4b87168c52da35c78cadadc5f8ca0238eafbf93b8ffa50ed')
+ 'e6df0ce8d665261cffc930e0a99023abd1b26caf1e89dda756cf76713953e6b3a36d3210a4c01beedb2a28acc357a9880d19870a71864ede86e29b58991fff72'
+ 'ea7fd8a0fd1431078f158ef3bc184b3b826290ae4fde9739e9159444e44c8ed9fb33b1419f4650977e701f8bbbddf22a16b0dfa7aa775c89e42cb54e213de146')
export KBUILD_BUILD_HOST=archlinux